PDA

View Full Version : newbie: SlimServer problem playing FLAC files



Will Meyer
2004-06-10, 17:51
Thanks very much to Pat Farrell and kdf for responding.

Using the d_source debugging, it was clear it just couldn't find the
lame binary. It's on the path, though. The actual problem is that the
lame I have requires a DLL, and DLLs can't load out of directories that
aren't the system dir or the current process's working dir, unless they
are explictly loaded by the app. This seems like it would get most
windows users, maybe I missed it when searching for FAQs. If anything
the lame binary should load its own DLL dynamically, not link it early,
as it appears it is doing. Anyway, got it all working like a champ now,
putting the DLL in win sys dir.

Thanks again...

Will

P.S. I'm only streaming to MP3 so I can listen remotely with reasonable
bandwidth, at home it's all FLAC into a nice external DAC and 2-channel
setup!








At 09:02 PM 6/9/2004, Will Meyer wrote:
>I've just got the slimserver up and running, Win XP, works great for
>MP3s. My collection is all FLAC, though (360G of them).

Good show.


>I have FLAC installed and on my path, as well as LAME. I saw in a
>transcoders file that there is a mapping for FLAC->MP3.

First, lets get it working, and then we'll get you to stop
transcoding from a good format (flac) to a bad one (mp3) when
you can feed .wav data and get full quality at no extra cost.



> What am I doing wrong? I am not sure which module is relevant so
> haven't tried to use the debug logs to much.

You have to turn on the verbosity debugging so you can see what is
happening.


>not sure how files are decoded (as needed, batched, or what), but do know
>that I don't see flac.exe running or anything while the player is just
>silent and the web interface says Stopped.

That almost always means that the flac decoding failed.
the normal process is for flac to run and decode to a stream
as long as the song takes.

Go the server base page, usually <whateverslimserver>:9000/
then Server settings -> additional Server settings -> file types
and make sure that the checkbox is set.

For the convert command, I have
FLAC (to) MP3
[flac] -dcs $FILE$ | [lame] --resample 44100 --silent -q 9 -b $BITRATE$ - -

FLAC (to) WAV
[flac] -dcs --force-raw-format --endian=little --sign=signed $FILE$

See if you have that close. And make _sure_ that both flac and lame are
on the
path of the userid that your slimserver is runing under, which may not be
the one you run under.

Pat