PDA

View Full Version : Controlling SC with Ipod and Ipeng



Northbull
2009-07-14, 12:08
Hi guys, I really hope you can help me here.


I have a Qnap TS-119 + SqueezeBox Duet and everything has been running smoothly. No problems for weeks with this setup.

-But now a problem has accured.
This is the second time its happened and I cant fix it now.


When I try to control SqueezeCenter with an Ipod +Ipeng (3rd. party software) it starts to go suuuuuuper slow.
I get a 15-20 seconds delay, from push button to action.
I get this in the SSOTS log (I run SC on a NAS Qnap TS-119 server and the program running SC is called SlimSever on TurboStation)

My server log:
16265: [09-07-14 18:29:58.9212] Slim::Networking::Select::select (245) Error: Select task failed: 'x' outside of string in unpack at /share/HDA_DATA/SqueezeCenter/Slim/Networking/Discovery.pm line 154.

I am getting this same error over and over, but I have no idea what it means.

I don't know what caused this, because I am doing so much different stuff on my server all the time.



If I use the "logitech" remote it works, but when Ipod connects it get major delay. It has worked fine before though.


Any one has an idea?


Thank you!

pippin
2009-07-14, 13:40
Is the "logitech" remote the Duet Controller?

Have you tried to re-install the server?

Northbull
2009-07-14, 22:16
It works again now.

I am really having a hard time understanding the problem though. When I got up it was still running with a 20 sec delay. Then I turned off a USB printer I have connected to my server, deleted the MAC adress in Ipeng settings and flushed the cache. I don't know why it started working after that, but it did.
After it syncronized the cache it was working normally again.

Rather wierd, but it works now, so hephey! =)

I am running version 7.0 of squeezecenter
I was had no delay when I controlled SC in the web interface or when I used the remote that came with the SqueezeBox Duet.


I think ill upgrade my SC sometime in the weekend and see if that will eleminate the problem for good.

Northbull
2009-07-15, 10:11
Problem is back... I didnt change anything.

Everything works super good, but as soon as Ipeng tries to send a command to the Squeezecenter, everthing gets a 10-15 sec delay.

I has been working perfectly before..
Ill try to install a newer version of Squeeze Center in this weekend.

Just wierd when everything was working perfectly before.


I still really recommend using Ipod+Ipeng to control SqueezeCenter, it give a super nice interface and a lovely feeling when browsing.

Bryan Jan
2009-07-15, 23:02
Nothing you can do unless you move the squeezecentre to a proper PC.

Northbull
2009-08-09, 02:44
It just dosn't make any sense, that it works with the original Remote that comes with the Squeezebox Duet, but the Ipod only works sometimes.

I can also control it in my webbrowser using the normal squeezecenter interface.


I have no idea what the problem is.


Sometimes it starts working again if I restart SSOTS (slimserver on turbostation), a plugin for my Qnap TS-119 that starts the squeezecenter.

Northbull
2009-08-09, 02:46
Can it have something to do with the squeezecenter sleeping?

"SqueezeCenter

Process status : PID 15803, state R (running)
Memory usage : 77 MB total, 69 MB (90%) RSS
SSODS/SC flags : noupnp

MySQL

090809 11:43:07 [Warning] option 'max_join_size': unsigned value 18446744073709551615 adjusted to 4294967295
090809 11:43:07 [Warning] option 'max_join_size': unsigned value 18446744073709551615 adjusted to 4294967295
090809 11:43:07 [Warning] option 'myisam_max_extra_sort_file_size': unsigned value 2147483648 adjusted to 214748364
Process status : PID 15822, state S (sleeping)"


Its only the Ipeng that dosnt work.

pippin
2009-08-09, 03:38
I have no idea what the problem is.


Can you please write again what exactly the problem is, how it starts etc.
Also, can you give a bit more detail about your setup (network, server version, things like that).

Also, is iPeng syncing the cache (do you see the blue "progress bar" on "Albums"?