PDA

View Full Version : Gaps in playback



Keith
2004-06-07, 16:33
Robert,

I agree that it's serious. The constant, random breaks make it very
difficult to enjoy the music. On the up-side, if this has only recently
started happening, it should be relatively straightforward to identify
the code changes made since it was working okay.

On the resource contention, I was meaning that I don't think the
problems is caused by contention between the squeezebox software and
another application. Whatever is causing the problems for squeezebox,
it's internal to its own code.

Cheers,
Keith

-----Original Message-----
From: discuss-bounces (AT) lists (DOT) slimdevices.com
[mailto:discuss-bounces (AT) lists (DOT) slimdevices.com] On Behalf Of Robert
Wallace
Sent: 08 June 2004 00:13
To: 'Slim Devices Discussion'
Subject: [slim] Gaps in playback

Keith,

I stream flac (converted to wav by Slimserver) and I see this as well.
This
is a recent occurrence - it didn't happen on earlier builds, but I don't
know exactly when it started. I've got the same setup you have.

In any case, there is a resource contention: If Slimserver is grabbing
100%
CPU, then it doing something other than pushing bits out the ethernet
port
and during that busy period the Squeezebox buffer empties. Note that
Slimserver's normal music serving doesn't require near that much CPU.

What's Slimserver doing at that moment in time? I don't know, but this
problem and the back-from-the-dead Pause problem are rather serious, in
my
opinion.

Robert

-----Original Message-----
From: discuss-bounces (AT) lists (DOT) slimdevices.com
[mailto:discuss-bounces (AT) lists (DOT) slimdevices.com] On Behalf Of Keith Leng
Sent: Monday, June 07, 2004 4:35 AM
To: discuss (AT) lists (DOT) slimdevices.com
Subject: [slim] Gaps in playback


Hi,

I'm experiencing random gaps when playing songs. They last for a few
seconds. The distribution is very random but it probably averages out to
1 every 10 to 15 minutes. I don't think it's a resource contention
problem. Nothing else is grabbing bandwidth or CPU cycles. During the
gap, the slim executable is using 100% CPU.

Is this is a known problem? Are there any workarounds?

Thanks,
Keith

Windows XP
Server 5.1.6
Player Firmware 23