PDA

View Full Version : some mp3s don't work



evencoil
2009-06-19, 09:31
Occasionally I run across an mp3 file that simply refuses to play in squeezecenter. If I try to play it I get no audio and it will skip to the next track very shortly after beginning to play. I can't discern any common qualities that mp3s that do this have. They all will play correctly in other media players. Any idea what's going on?

CatBus
2009-06-19, 10:07
Possible bug in the native MP3 (firmware) decoder? Try turning off native decoding for MP3 in SqueezeCenter (stream as FLAC), and see if it plays okay. If so, then that's your workaround for the time being, and I'm sure the dev team would love you to open a bug on this, including an example of a problem MP3.

evencoil
2009-06-19, 10:14
can you explain how to do that? the only options for decoder that I have are native and disabled and the only stream format for mp3 is mp3 itself. I suppose I have to edit convert.conf, but I'm not sure what to add...

SuperQ
2009-06-19, 10:46
Would you mind posting a copy of the file that doesn't play properly? It would help in debugging.

evencoil
2009-06-19, 10:59
the forum won't let me upload anything larger than 200 kb...

toby10
2009-06-19, 12:02
Would you happen to know the source of the problem MP3? Did you rip it yourself? Was it purchased from a download site like Yahoo Music?

andyg
2009-06-19, 12:31
Best bet is to open a bug and attach a file that won't play.

evencoil
2009-06-19, 12:39
ok I'll do that.

Here's the bug report: http://bugs.slimdevices.com/show_bug.cgi?id=12464

evencoil
2009-06-29, 13:32
since this problem seems to be particular to my system, can you tell me what the logging options are that I can use to debug this?

The exact behavior is that squeezecenter appears to play the song for about 10 seconds (judging by the progress bar) maybe 7-10 times in a row, then moves on to the next song. All of this without any sounds of course.

finnbrodersen
2009-06-29, 13:58
Hi

I had the same problem with one mp3 song in an album some time back. I never found the cause of the problem, but after deleting the ID3v2.3 tags and re-writeing them again, I have never had any problems with the song again.

Maybe some corrupt ID3 tag was the problem

evencoil
2009-06-29, 14:31
thanks for the suggestion, tried stripping the id3v2 tags and nothing changed.

b1ackmai1er
2009-07-08, 08:07
If you are using Linux, try MP3Diags.

It can scan and identify many errors.

Offers many options to try and repair MP3 files.

Regards

evencoil
2010-01-03, 09:53
I finally figured out what the common thread for my problem mp3s was. It's the sample rate. My squeezecenter seems only able to play mp3s with a 44.1 khz sample rate. Does anyone know why this might be? Some setting I have inadvertently set? Thanks!