PDA

View Full Version : Assigning static IP to Squeezebox Duet receiver and controller



Simsalabim
2009-06-18, 14:38
Hello,

I have a lot of problems with finding where I can assign a static IP to the SBR and SBC.

Can anyone tell me how it is done?

jrichardson
2009-06-18, 14:41
The best and fastest place to do it is in your Router

Typical under the Advanced settings

Depending on the manufacture, they will call it different things. Look for 'Static IP address' or DHCP Reservation

Consult your Routers manual or online help for detailed instructions

Simsalabim
2009-06-19, 02:02
Thank you for your suggestion.

I don't think that it is possible to assign MAC-adresses to certain IP-adresses with my Linksys WRT54G router.

I have had static IP-adresses on my Squeezebox system when I set it up, but now I don't remember how I did it. I can only remember that it was not easy :-)

Do anyone know the solution when the router can do it?

Howard Passman
2009-06-19, 02:23
Thank you for your suggestion.

I don't think that it is possible to assign MAC-adresses to certain IP-adresses with my Linksys WRT54G router.

I have had static IP-adresses on my Squeezebox system when I set it up, but now I don't remember how I did it. I can only remember that it was not easy :-)

Do anyone know the solution when the router can do it?

I've had to set up a new SBC last week and this week when I loaded 7.3.3 it somehow blew out my ip address in both SBC's. The only easy way I know to statically address both devices is to make sure you have turned off DHCP in your router and make sure there are no other routers nearby with DHCP on. The SB's will try to connect to the router after you put in the WEP key, etc and when they can't, they should present you with the choice to try again or assign a static ip address. I have no idea why, but even if I assign an SSID or pick one and there is any other device broadcasting DHCP, I will get an address from that device.

Good luck.

Howard

trouty00
2009-06-19, 03:54
Its near but impossible using traditional methods, I battled with ages with my install going through reset more than 20 times and disabling the dhcp on router but then it just wont connect via ethernet or wireless. I think i got asked once to assign a static ip which i did (correct of course, i am skilled user) but it wouldn't connect. I eventually gave up and completely unsecured my wireless network (just so controller would connect)

I eventually got it connected via dhcp with security and then yesterday used the udap program to remote access my receiver and change the ip to static that way and now I am looking at the ssh remote login to see if i can do the same with the controller.

There really needs to be an advanced network settings option on the controller so you can change all these things completely manually.

Stu

mowa
2009-06-19, 04:07
If you know how to mess around in a Linux prompt, you can edit the file /etc/network/interfaces on the controller to give it a static IP.

Change this section:

iface <name of your wifi network> inet dhcp
script /etc/network/udhcpc_action

to:

iface <name of your wifi network> inet static
address 192.168.2.50
netmask 255.255.255.0
network 192.168.2.0
broadcast 192.168.2.255
gateway 192.168.2.1

Ofcourse you should use the correct IP addresses/netmasks that goes for your system - you can use /sbin/ifconfig to get the info needed. You might also have to edit /etc/resolv.conf, but I guess it'll already have the correct value (name server) if you're running DHCP now.

Make a copy of the settings to a file on your PC as I guess it's lost on firmware upgrade.

trouty00
2009-06-19, 04:28
mowa, thanks very much for that, I guess its only editable with vi, I've only used nano when i was playing around on my mybook so will have to do some research on vi to work out how the hell i use it.

many thanks

kantblue
2009-06-19, 04:29
Hi Simsalabim

I had virtually the same experience as trouty00 when setting up my duet/controller. Like trouty00 I did ONCE see the fabled manual IP setup on the controller, but could never get it to show again.

I ended up using the UDAP application to set a static address and since then its been working fine.

If you have a router and a separate cable/adsl modem, then disconnect this from the router before you start the setup process. I found that even with DHCP turned off on my router, the duet was then finding the DHCP that (unknown to me) was running on my cable device. Hope this makes sense?

See the thread I started below for more information:

http://forums.slimdevices.com/showthread.php?t=62348

and if you want to vote for this bug to be fixed you can go here to vote, and the more people that vote the better!

http://bugs.slimdevices.com/show_bug.cgi?id=7502

kantblue

mowa
2009-06-19, 04:40
mowa, thanks very much for that, I guess its only editable with vi, I've only used nano when i was playing around on my mybook so will have to do some research on vi to work out how the hell i use it.

many thanks

Right, there are things in the world that are a bit more self-explainatory than vi. :) What you need:

i for insert mode
<ESC> to exit insert mode
x for delete
dd for delete line
<shift>-ZZ for write+exit
:q! to exit without writing

trouty00
2009-06-19, 04:44
Ok so I just changed it and rebooted the controller and double checked the diagnostics info in the settings>advanced menu and it as changed to a static IP so that is fantastic,

can you just confirm with me what these two lines do though

network 192.168.2.0
broadcast 192.168.2.255

I assume its something to do with the subnet range, I just googled and found that the broadcast is for sending messages to all devices on the network, how is this used by the controller, but not sure what the network one is used for as surely it would use the router to route commands to relevant reciever.

ta
Stu

trouty00
2009-06-19, 04:55
I figure it out with vi before you posted, i only needed to figure out how to exit with saving so quite easy!

first enable remote login on your controller, it will tell you the ip and password

get a ssh program I used putty
type IP in 'Host Name(or IP address)' field and select the radio button for SSH, this will auto select port 22 and press open.

NOTE - type what is inside of the ' ' marks.

you will then be presented with a comand line
login as: type 'root'
root@192.168.1.30's password: type the password the remote gave you i think default for all remotes are '1234'

-navigate to /etc/network/
'cd /etc' [Press Enter]
'cd network'
type 'vi interfaces'

Change this section:

iface <name of your wifi network> inet dhcp
script /etc/network/udhcpc_action

to:

iface <name of your wifi network> inet static [name of wifi network should already be present]
address 192.168.2.50 [this is IP address you want to set controller too, make sure its unique and not in use by another computer/console/phone]
netmask 255.255.255.0
network 192.168.2.0 [this is your gateway/router address but with last value set to 0]
broadcast 192.168.2.255 [this is your gateway/router address but with last value set to 255]
gateway 192.168.2.1 [this is your gateway/router address]
press ESC key [this puts you into command mode]
type ':wq' [Then press enter]


turn your controller on and off again and job done

check the diagnostics info in the settings>advanced menu

This is assuming you have already configured your controller for wireless use.

If anything goes wrong you can reset you controller to factory settings by holding + key as you turn it on.

You do this at your own risk but as long as you only edit the said file you should be fine.

HTH someone.

Stu

judkins
2009-06-19, 05:05
Hi,
my problem is that my router which i u se as DHCP server as well does not assign / reserve IPs static IPS to specific clients via mac Adress. I find it quite cumbersome though to set up the static IP on the controller. Has anyone ever tried to use a DHCP server software that is much better to set static IPS's vs. the process via the controller.
But in general I would expect to be able to configure my duet IP settings either via SC or SN. Doe sanyone know whether this is planned?

Alex

mowa
2009-06-19, 05:27
Ok so I just changed it and rebooted the controller and double checked the diagnostics info in the settings>advanced menu and it as changed to a static IP so that is fantastic,

can you just confirm with me what these two lines do though

network 192.168.2.0
broadcast 192.168.2.255

I assume its something to do with the subnet range, I just googled and found that the broadcast is for sending messages to all devices on the network, how is this used by the controller, but not sure what the network one is used for as surely it would use the router to route commands to relevant reciever.

ta
Stu

The broadcast is used to tell everybody that "I'm alive and kickin', now you know where I live, come and get me." - or "I'm alive and kickin', but I need someone to talk to! Squeeze gadget, where are you?".

"Network" is just the address of the network - the lowest IP in the subnet.

By the way, make sure your DHCP server knows it should assign IP's in the range you're using for static IP's. :)

trouty00
2009-06-19, 05:29
The broadcast is used to tell everybody that "I'm alive and kickin', now you know where I live, come and get me." - or "I'm alive and kickin', but I need someone to talk to! Squeeze gadget, where are you?".

"Network" is just the address of the network - the lowest IP in the subnet.

By the way, make sure your DHCP server knows it should assign IP's in the range you're using for static IP's. :)

you mean 'make sure your DHCP server knows it should'NT assign IP's in the range you're using for static IP's.'

mowa
2009-06-19, 05:31
you mean 'make sure your DHCP server knows it should'NT assign IP's in the range you're using for static IP's.'

Definately, I'm sure the forum software ate the 'NT - perhaps it's running Linux... :)

mowa
2009-06-19, 05:39
I figure it out with vi before you posted, i only needed to figure out how to exit with saving so quite easy!

first enable remote login on your controller, it will tell you the ip and password

get a ssh program I used putty
type IP in 'Host Name(or IP address)' field and select the radio button for SSH, this will auto select port 22 and press open.

NOTE - type what is inside of the ' ' marks.

you will then be presented with a comand line
login as: type 'root'
root@192.168.1.30's password: type the password the remote gave you i think default for all remotes are '1234'

-navigate to /etc/network/
'cd /etc' [Press Enter]
'cd network'
type 'vi interfaces'

Change this section:

iface <name of your wifi network> inet dhcp
script /etc/network/udhcpc_action

to:

iface <name of your wifi network> inet static [name of wifi network should already be present]
address 192.168.2.50 [this is IP address you want to set controller too, make sure its unique and not in use by another computer/console/phone]
netmask 255.255.255.0
network 192.168.2.0 [this is your gateway/router address but with last value set to 0]
broadcast 192.168.2.255 [this is your gateway/router address but with last value set to 255]
gateway 192.168.2.1 [this is your gateway/router address]
press ESC key [this puts you into command mode]
type ':wq' [Then press enter]


turn your controller on and off again and job done

check the diagnostics info in the settings>advanced menu

This is assuming you have already configured your controller for wireless use.

If anything goes wrong you can reset you controller to factory settings by holding + key as you turn it on.

You do this at your own risk but as long as you only edit the said file you should be fine.

HTH someone.

Stu

You assume the user has a class C network (255.255.255.0) - can't always be sure about that... Mask and broadcast address can be retrieved using "ifconfig eth0" - don't really know how to easilty retrieve network address - but you could use http://www.subnetmask.info/ to calculate it. No worries if netmask is 255.255.255.0, everything is good then.

mowa
2009-06-19, 05:47
You assume the user has a class C network (255.255.255.0) - can't always be sure about that... Mask and broadcast address can be retrieved using "ifconfig eth0" - don't really know how to easilty retrieve network address - but you could use http://www.subnetmask.info/ to calculate it. No worries if netmask is 255.255.255.0, everything is good then.

Just remembered a way to get the network address - just run "route" on the prompt, it'll be in "Destination".

Simsalabim
2009-06-19, 18:44
Thank you the replies.

Here is what I do:

1. Factory reset on controller
2. Disable DHCP on router
3. Connect controller to wireless network
4. "Adress problem" - chose "try again", "self-assign adress" or "use a static"
5. I chose "use a static"
6. Assingning IP, subnet, gateway, DNS
7. "Set up reciever"
8. Assigning IP (after chosing Ethernet - oter option: Wireless)
9. Connecting... (reciever changes status from red to green)
10. Connection problem... and then I can do nothing

It sais "Couldn't connect your Squeezebox to your ethernet network. (connection error)

I can ping the squeezebox reciever on the correct IP.
I can't ping the controller on the IP.

I have tryed it putting DHCP on after number 6, but then the reciever just changes into blue LED instead :-/

I have tryed assigning the reciever to connect wirelessly, but that just results in the led going to white and then green and blue and then controller sais "connection problem".

trouty00
2009-06-21, 04:50
honestly, It's cause the s/w I think could be a whole lot better, unless you want to go the more technical route and try and ssh in and use udap i don't know what your options are apart from vote on the bug to get manual IP address configuration in the controller config. I would be very surprised if this ins't added in the near future but who knows.

Stu

OppfinnarJocke
2009-06-24, 12:14
HTH someone.

Stu

Sure helped me!
I just went through it all and seem to have managed it without any mistake (vi!). My SBC now has a fixed (as opposed to static) IP-address. I have great hopes that this will finally fix my connectivity problems.

Great, thanks!

PS. Maybe someone said this already, but make sure your router does not hand out via DHCP the addresses that you assign as fixed. I set my router to not DHCP addresses above 192.168.1.199, so all addresses in the 200-range are ok for me to set as fixed.

jbraveman
2009-06-24, 19:56
what happens to this line?:

"script /etc/network/udhcpc_action"

Does it get deleted or just moved to the end of the other text.

peterw
2009-06-24, 21:39
Sure helped me!
I just went through it all and seem to have managed it without any mistake (vi!). My SBC now has a fixed (as opposed to static) IP-address.

Being somewhat pedantic here -- in networking circles, "static" means the device has been configured to use certain networking parameters and does NOT use DHCP. I've seen some on these forums talk about configuring "static" addresses on the router -- wrong. If you configure the router/access point/DHCP server to always give a certain IP to a certain MAC/device, that's a "DHCP reservation", not a "static" address.

It's funny, I have two Controllers, and only set one of them to use a static IP -- the other gets a plain old, not reserved, DHCP lease. Both have had zero networking problems since I reconfigured one, where previously both were flaky. Ther have been a few firmware updates since then, so I'd hope this static IP stuff would no longer be needed...

judkins
2009-06-25, 00:50
The best and fastest place to do it is in your Router

Typical under the Advanced settings

Depending on the manufacture, they will call it different things. Look for 'Static IP address' or DHCP Reservation

Consult your Routers manual or online help for detailed instructions

Hi,
my problem is that my router which i use as DHCP server as well does not assign / reserve IPs static IPS to specific clients. I find it quite cumbersome though to set up the static IP on the controller. Do you know whether using a DHCP server software would be an option? It is much better to assign IPS's in the software vs. the process via the controller.

Alex

trouty00
2009-06-25, 01:46
what happens to this line?:

"script /etc/network/udhcpc_action"

Does it get deleted or just moved to the end of the other text.

sorry its took me a couple of days, been to lazy to login and check, Ive just checked and mine is currently

iface lo inet loopback

mapping eth0
script /etc/network/if_mapping
iface logitech*squeezebox*0004201719bb inet dhcp
script /etc/network/udhcpc_action
iface Stueys inet static
address 192.168.1.30
netmask 255.255.255.0
network 192.168.1.0
broadcast 192.168.1.255
gateway 192.168.1.1


you will need to get rid of the line "script /etc/network/udhcpc_action" which is below iface<wi-fi network> inet dhcp

after logging in and seeing this I am wondering if the lines regarding my squeezebox has made it go DHCP even after amending it via net-udap.

I think its time for me to experiment.

Stu

OppfinnarJocke
2009-06-25, 03:49
Being somewhat pedantic here -- in networking circles, "static" means the device has been configured to use certain networking parameters and does NOT use DHCP. I've seen some on these forums talk about configuring "static" addresses on the router -- wrong. If you configure the router/access point/DHCP server to always give a certain IP to a certain MAC/device, that's a "DHCP reservation", not a "static" address.

Yes, your right. The current vocabulary (on this forum, at least) seem to use "static" to mean "reserved". So I tried to use "fixed" to mean, well... "static" in the real sense then... Of course, we really should use "reserved" and "static" instead, as it would concur with the way network professionals use those words.



It's funny, I have two Controllers, and only set one of them to use a static IP -- the other gets a plain old, not reserved, DHCP lease. Both have had zero networking problems since I reconfigured one, where previously both were flaky. Ther have been a few firmware updates since then, so I'd hope this static IP stuff would no longer be needed...

I have only one SBC, and it is since yesterday evening on static (in the real sense) IP whereas it previously was on a reserved IP. All day I have had zero trouble. Previously I had daily connectivity problems, even with latest FW. I have great hopes now that it will finally finally be reliable. The future will tell...

avta
2009-06-25, 07:17
Here's some useful info. Hopefully the attachment shows up.

trouty00
2009-06-25, 07:25
Here's some useful info. Hopefully the attachment shows up.


If only that actually worked we wouldn't have threads like these in the first place!

tcutting
2009-06-25, 09:31
I've gone to static (not reserverd - my router doesn't seem to support reserved DHCP), and found improved performance (set my desktop PC, server PC, network printer, squeezeboxes and controller to static IPs... my laptop still gets IP through DHCP dynamically). I think the issue with the controller on dynamic DHCP addressing was that the controller can go into "suspend" mode, where it turns off its wi-fi. It "felt" like when it would turn back on, there was a chance that the router re-allocated that IP address to another device, but the controller was expecting the same IP address. Not sure if that was really the case, but my problems would be greatest if a device was power cycled, and I'd seem to have to completely reset all the devices to get things working again. Since i've gone to static addressing (and upgraded firmware in the router) things seemed to get a lot more stable. Plus the controller firmware upgrades seem to help. The day-to-day improvement I see with the static addressing is switching between players on the controller - that seemed to speed up considerably.

OppfinnarJocke
2009-06-25, 12:45
I've gone to static (not reserverd - my router doesn't seem to support reserved DHCP), and found improved performance [...] I think the issue with the controller on dynamic DHCP addressing was that the controller can go into "suspend" mode, where it turns off its wi-fi. It "felt" like when it would turn back on, there was a chance that the router re-allocated that IP address to another device, but the controller was expecting the same IP address. Not sure if that was really the case, but my problems would be greatest if a device was power cycled, and I'd seem to have to completely reset all the devices to get things working again. Since i've gone to static addressing (and upgraded firmware in the router) things seemed to get a lot more stable. Plus the controller firmware upgrades seem to help. The day-to-day improvement I see with the static addressing is switching between players on the controller - that seemed to speed up considerably.

I have also gone to static IP. Was using reserved IP but with lots of connectivity problems. Now everything seems much more stable. So I don't think that the problem is with being assigned different IP's. The problem is simply flaky DHCP implementation.

TheLastMan
2009-06-26, 02:14
If only that actually worked we wouldn't have threads like these in the first place!

I have had Buffalo, Netgear and Speedtouch routers and this procedure has worked on all of them exactly as Avta describes.

One thing he does not describe is that in some routers, my Netgear DG834GT being one, you can set the range of addresses that it uses for DHCP. I have therefore set addresses .200 - .254 for the DHCP server to use and can therefore use addresses .2 - .199 for "static" addresses without fear that the DHCP server will cause a conflict.

If you are not able to go through these steps then it is likely that there is a problem either with your router or with your Controller.

Like tcutting I now have assigned fixed IP addresses for all devices in my network - except my laptop which has to connect both at work and at home.

My network, and particularly my SqueezeBox stuff, is now amazingly stable. I do tend to keep the Controller permanently in its dock though. If they sold separate chargers I would have a second charger in the living room so that it can be docked there as well as the kitchen (where we tend to listen to most music).

It is a good discipline for the kids to put it back in the dock too, otherwise heaven knows where it would end up!

Following a frantic search just before going away for a weekend, I once found my digital camera hanging from a small bush in the garden, in the rain, alongside one of my daughter's trainers and a plastic dinosaur. When asked for an explanation of this bizarre collection my daughter said she was growing a "shopping" tree.

Hmmm...

upstatemike
2009-08-22, 06:53
Here's some useful info. Hopefully the attachment shows up.

Even if this procedure worked (and plenty have had trouble with it) it is still an extremely complex process to expect somebody to go through to use a piece of consumer audio gear.

Hildebrandt
2009-09-16, 04:34
Ok... Did the putty thing and restarted controllers (2) afterwards - now:
entering settings>advanced - where does it say that ip is static (can't see it anywhere)?? And - how do i set my reciever to accept SSH???

Thx...

trouty00
2009-09-16, 04:40
I dont belive it does say on the controller its static but you can logon your router/switch and look at the DHCP table and it will tel you what devices are currently connected via DHCP although you should have set-up a dhcp range on router say 192.168.1.30 > 192.168.1.254

then you assign anything below .30 to your static devices and you know for sure that way.

your receiver doesn't accept ssh but it accepts udap connections which require no config on receiver although if its connected to a server you dont get full options so just reset it to red (bear in mind your factory reseting it) flashing by holding the pause button on the receiver for a few seconds.

HTH - Stu

Hildebrandt
2009-09-16, 04:45
thx for fast reply...

Posts above state that i can see that ip is static by entering settings>advanced????

trouty00
2009-09-16, 04:48
which post number you referring too?

tbh, i dont actually own a controller anymore so cant check on mine for you.

Viragored
2009-10-06, 18:15
Here's some useful info. Hopefully the attachment shows up.

Hi - I tried following the steps in the helpful pdf document, but the process went differently for me. I disabled DHCP in the router, factory-reset the controller and Duet player, and got the 'connection problem' message on the controller. The choices then available were:
1. Try again
2. Try a different network
3. Go Back

Try again failed, and I gave up after four attempts. There were no different wireless networks to try, so as far as I can tell nobody round where I live was broadcasting DHCP. Go back merely took me back to re-enter the WEP key.

I've gone back to normal service by switching DHCP back on in the router, then another factory re-set of the controller, and then through the menus. (Try again on the controller didn't pick up the DHCP without the factory re-set.)

Unfortunately I don't know enough about the insides of computers and networks to make any progress with net::udap - I tried running it but got a blank screen in response to the first commands.

So the question is - can I actually manage to get my controller on to static IP addressing? It's version 7.3 r6038

Thanks for any help - Dave

OppfinnarJocke
2009-10-07, 00:06
@Viragored: If you disable DHCP in teh router and do not set a static IP-address for the controller and player, you will not be able to connect.

Do not disable DHCP, you probably have other computers that attach to the network through DHCP. What you need to do is set the controller (and probably only the controller) to a static IP address. This you do by logging into it via SSH, use Putty (http://www.chiark.greenend.org.uk/~sgtatham/putty/download.html if you're on windows) as root, password "1234". Then change the file /etc/network/interfaces to the following text, where the text within < > should be changed to your particular setting:



iface lo inet loopback
mapping eth0
script /etc/network/if_mapping
iface <your SSID> inet static
address 192.168.1.<static IP>
netmask 255.255.255.0
network 192.168.1.0
broadcast 192.168.1.255
gateway 192.168.1.1


As <static IP> I have 200. Make sure that the router does not hand out those numbers by DHCP, my router is set to only hand out by DHCP addresses in the range 1-199, so for me 200-255 are safe to use as static IP-addresses. How you set up this depends on your router.

This is by no means trivial, you need to be rather computer savvy to fix this, and hopefully an easier way to do this will be available in upcoming versions of the controller FW.

Note also that a factory reset will require you to do this all over again...

More here http://forums.slimdevices.com/showthread.php?t=57994&highlight=iface and http://forums.slimdevices.com/showthread.php?t=66926

TheLastMan
2009-10-07, 01:38
Hi - I tried following the steps in the helpful pdf document, but the process went differently for me. I disabled DHCP in the router, factory-reset the controller and Duet player, and got the 'connection problem' message on the controller. The choices then available were:
1. Try again
2. Try a different network
3. Go Back

Try again failed, and I gave up after four attempts. There were no different wireless networks to try, so as far as I can tell nobody round where I live was broadcasting DHCP. Go back merely took me back to re-enter the WEP key.

I've gone back to normal service by switching DHCP back on in the router, then another factory re-set of the controller, and then through the menus. (Try again on the controller didn't pick up the DHCP without the factory re-set.)

Unfortunately I don't know enough about the insides of computers and networks to make any progress with net::udap - I tried running it but got a blank screen in response to the first commands.

So the question is - can I actually manage to get my controller on to static IP addressing? It's version 7.3 r6038

Thanks for any help - Dave

Hi Dave, don't give up on the 'disable DHCP' method yet - it works for me.

Looking at the message I would say your problem is that setup is not getting as far as setting the IP address, it is not even finding your wireless network!

The routine is that it should first show you a list of the available wireless networks in your vicinity. You then choose your network and type in, using the scroll wheel, your wireless password.

It will then give you the spinning dots and eventually prompt you with something like

Cannot assign IP address
1. Try again
2. Self assign IP
3. Static IP
4. Go back

I am not sure I have the choices in the right order, but just choose 'Static IP'. You will then be asked for the IP you want to use, the IP of your router, the subnet mask (always 255.255.255.000) and your DNS server (usually your Router IP again).

I am not sure what is going on for you but in your router setup screen make sure
- wireless is enabled
- SSID is 'broadcast'
- make sure you know your password, or reset it if you are unsure

The best encryption scheme is WPA pr WPA2 with PSK (pre-shared key). Whether it is AES or TKIP does not matter, the Controller will work with both.

You also need to make sure that SqueezeCenter or SqueezeBox Server is running on your server.

Once you have gone through this process it will then prompt you to select a Receiver. At this point, because DHCP is off, it will ask you to enter the IP you wish to assign to the Receiver.

Using this routine you end up with both the Controller and the Receiver using proper static IP addresses, which makes for a quicker and more stable network all round.

Once you have the Controller and Receiver working OK, you can then turn DHCP back on again.

Have another go - the method does work and requires a lot less computer knowledge than using SSH, Putty and command line editing. Good luck!

Hildebrandt
You can find the IP address your Controller is using by choosing on the Controller;
Settings/Advanced/Information/
Choose your player name and press the centre button.

It is also shown, along with the Mac address and other useful stuff on;
Settings/Advanced/Wireless Networks
Select your wireless network and press centre button

OppfinnarJocke
2009-10-07, 02:44
eventually prompt you with something like

Cannot assign IP address
1. Try again
2. Self assign IP
3. Static IP
4. Go back



If this works, it is surely the way to go.
This is exactly the "easier way" that I expected to become "available in upcoming versions of the controller FW". Seems it is already available...

TheLastMan
2009-10-07, 04:25
If this works, it is surely the way to go.
This is exactly the "easier way" that I expected to become "available in upcoming versions of the controller FW". Seems it is already available...

It does work, but it is a bit of a hassle because you have to disable DHCP in your Router before it prompts you.

It would be better, when setting up the Controller, if after you have selected your wireless network and set the password that it prompted you with a two level menu as follows:

1. Automatic connection (recommended)
2. Manual connection (advanced users)
3. Go back

The novice would select 1 and DHCP would take over the settings, the more savvy user could then choose 2, in which case the menu could be:

1. Set IP Manually
2. Set IP Automatically using DHCP (further opportunity for the confused to choose automatic setup)
3. Self assign IP
4. Go back

The rest of the menus could be the same as currently if the DHCP server is off.

(p.s. dug out those headphones yet?) :)

Kasper_b
2009-10-07, 05:23
Here's some useful info. Hopefully the attachment shows up.

Thanks alot avta - Worked perfectly for me :D
Kasper

OppfinnarJocke
2009-10-07, 06:14
It does work, but it is a bit of a hassle because you have to disable DHCP in your Router before it prompts you.


Agreed. Setup could use some love...



(p.s. dug out those headphones yet?) :)

:) Will do as soon as I get back home... And I'll use my real ones, not the ones from Air Canada :)

Viragored
2009-10-08, 13:13
@Viragored: If you disable DHCP in teh router and do not set a static IP-address for the controller and player, you will not be able to connect.

This is by no means trivial, you need to be rather computer savvy to fix this, and hopefully an easier way to do this will be available in upcoming versions of the controller FW.

Note also that a factory reset will require you to do this all over again...

More here http://forums.slimdevices.com/showthread.php?t=57994&highlight=iface and http://forums.slimdevices.com/showthread.php?t=66926

Thanks for the information - I'll spend some time trying to work out if I can understand enough to give this a go. My network is small, both PCs use static IP, and I plan to keep DHCP going on the router so that won't be an issue. I just want to get the Squeezebox locked down too!

Cheers, Dave

Viragored
2009-10-10, 18:02
Hi Dave, don't give up on the 'disable DHCP' method yet - it works for me.

Looking at the message I would say your problem is that setup is not getting as far as setting the IP address, it is not even finding your wireless network!

The routine is that it should first show you a list of the available wireless networks in your vicinity. You then choose your network and type in, using the scroll wheel, your wireless password.

It will then give you the spinning dots and eventually prompt you with something like

Cannot assign IP address
1. Try again
2. Self assign IP
3. Static IP
4. Go back

I am not sure I have the choices in the right order, but just choose 'Static IP'. You will then be asked for the IP you want to use, the IP of your router, the subnet mask (always 255.255.255.000) and your DNS server (usually your Router IP again).

I am not sure what is going on for you but in your router setup screen make sure
- wireless is enabled
- SSID is 'broadcast'
- make sure you know your password, or reset it if you are unsure

The best encryption scheme is WPA pr WPA2 with PSK (pre-shared key). Whether it is AES or TKIP does not matter, the Controller will work with both.

You also need to make sure that SqueezeCenter or SqueezeBox Server is running on your server.

Once you have gone through this process it will then prompt you to select a Receiver. At this point, because DHCP is off, it will ask you to enter the IP you wish to assign to the Receiver.

Using this routine you end up with both the Controller and the Receiver using proper static IP addresses, which makes for a quicker and more stable network all round.

Once you have the Controller and Receiver working OK, you can then turn DHCP back on again.

Have another go - the method does work and requires a lot less computer knowledge than using SSH, Putty and command line editing. Good luck!


Hi there- thanks for the advice. I've tried again and get the same result. I didn't include all the steps in the post that you replied to - but I did do all the steps listed in the helpful pdf document that Avta posted. The controller did find the correct network, accepted the WEP key and then went on to give the options I described ... which are different to the options you had.

I've been doing some homework on Putty and am ready to give it a go.

Cheers, Dave
PS - I'm thinking of changing my signature to "Why isn't anything simple any more?"

Viragored
2009-10-10, 18:14
@Viragored: If you disable DHCP in the router and do not set a static IP-address for the controller and player, you will not be able to connect.

Do not disable DHCP, you probably have other computers that attach to the network through DHCP. What you need to do is set the controller (and probably only the controller) to a static IP address. This you do by logging into it via SSH, use Putty (http://www.chiark.greenend.org.uk/~sgtatham/putty/download.html if you're on windows) as root, password "1234". Then change the file /etc/network/interfaces to the following text, where the text within < > should be changed to your particular setting:



iface lo inet loopback
mapping eth0
script /etc/network/if_mapping
iface <your SSID> inet static
address 192.168.1.<static IP>
netmask 255.255.255.0
network 192.168.1.0
broadcast 192.168.1.255
gateway 192.168.1.1


As <static IP> I have 200. Make sure that the router does not hand out those numbers by DHCP, my router is set to only hand out by DHCP addresses in the range 1-199, so for me 200-255 are safe to use as static IP-addresses. How you set up this depends on your router.

This is by no means trivial, you need to be rather computer savvy to fix this, and hopefully an easier way to do this will be available in upcoming versions of the controller FW.

Note also that a factory reset will require you to do this all over again...

More here http://forums.slimdevices.com/showthread.php?t=57994&highlight=iface and http://forums.slimdevices.com/showthread.php?t=66926


HI again - well, I've spent some time on the putty web site, loaded it on to a PC running XP and had a go at accessing the Squeezebox Controller. I've got as far as "Network error - connection refused". I think that tells me the controller is there but doesn't want to talk to my Putty - is that right? Any suggestions for Putty settings to make the connection work?

And then comes the next question for after I've logged on to the controller - is there some place that will tell me (in simple words!) how to make the changes to the file you specify - including how to find the file?

I've worked out all the settings I will need by looking in my router - the addressing structure (10.1.1.nnn) and sub-net mask (255.0.0.0) are all quite different from yours, but I think I have pinned them down properly. Both PCs are working quite happily using those settings so I think I'm on the right track.

Grateful for all help :-)
Dave

Mnyb
2009-10-10, 22:42
There is a difference between 7.3 and 7.4

In 7.3.x I used this interfaces file:



auto lo

iface lo inet loopback

mapping eth0
script /etc/network/if_mapping
iface Liogor inet static
address 192.168.1.6
netmask 255.255.255.0
gateway 192.168.1.1
dns 192.168.1.1
up echo 'nameserver 192.168.1.1' > /etc/resolv.conf


In 7.4 firmware I have to use



auto lo

iface lo inet loopback

mapping eth0
script /etc/network/if_mapping
auto eth0=Liogor
iface Liogor inet static
address 192.168.1.6
netmask 255.255.255.0
gateway 192.168.1.1
dns 192.168.1.1
up echo 'nameserver 192.168.1.1' > /etc/resolv.conf


difference seems to be the auto eth0=< your SSID >

Don't use my numbers here it's just an example.

I've seem to manage without the broadcast and network lines ? will add them any way for completeness

Anyone finding it tedius to change wpa password have a look at this file:

etc/wpa_supplicant.conf

Obviously you have to take measures to not lock yourself out if you edit this way :) For example first change it in the controller file turn it off then change it in the router...
You notice when your locked out ;)

OppfinnarJocke
2009-10-11, 09:40
There is a difference between 7.3 and 7.4

[...]

difference seems to be the auto eth0=< your SSID >


Strange... I have made no changes in my controller after the 7.4 update. It used the IP address I assigned it statically for 7.3, so it seems that either:
1. the "eth0=<SSID>" is added automatically, or
2. It is not really necessary...

@Viragored: I'll see if I can get some time later to write a more detailed how-to...

Mnyb
2009-10-11, 09:53
it's 1.

Discovered this after fw update 7.3 > 7.4 com started working again after factory reset, i saw this in the interfaces file in fiddled around and noticed it was necessary for proper function.

Got a good answer why in the beta forum if i can find the tread.

Found it:

http://forums.slimdevices.com/showthread.php?t=66926&highlight=interfaces

It is very important that line
auto eth0=< your SSID > without it will lose connection after suspend.

So keep this line if you manipulate your interfaces file

OppfinnarJocke
2009-10-11, 10:49
it's 1.
[...]

It is very important that line
auto eth0=< your SSID > without it will lose connection after suspend.

So keep this line if you manipulate your interfaces file

OK, great, thanks.

@Viragored: Here http://forums.slimdevices.com/showpost.php?p=444629&postcount=2 is a description of how to alter the file; as detailed as it gets, I guess. And alter the file (using vi, *ugh*) to what Mnvb shows, but with your specific SSID and IP addresses.

hpvvz
2010-09-04, 14:18
Hi Avta,

I just spend 4 hours on the duet trying to get some sound out of it.
no luck so far.

you describe in your .pdf on static adresses resetting the controller and then being asked at some stage for the player/receiver to be put in wireless or wiredLAN mode. I have not seen that anywhere.

Do we have a utility with which that can be done? I just want my receiver to not use wifi as its in a place with poor reception.

frustrating product, this is.

thanks in advance,
hans

tcutting
2010-09-05, 09:30
An alternate method to specify network settings for the Duet Receiver is to use the net-udap utility. It can be found by doing a search on this forum.
(here's link to the appropriate thread: http://forums.slimdevices.com/showthread.php?t=57861)
It requires you to connect the Receiver wired to your network, and use a computer to configure the receiver. It's not a "pretty" graphical utility, but it would allow you to configure not only static addressing, but also can help you setup wired vs. wireless networking.