PDA

View Full Version : Do any of the 'software' players now work on Macs?



snoogly
2009-06-01, 14:35
I'd love to be able to get one of the 'software' players working on my Mac, but I have had no joy. Has anyone had any success? How?

I really feel Mac users are being let down (though I do realize we have no 'right' to something that works).

bpa
2009-06-01, 15:24
Softsqueeze is now community supported which means users have to try to help themselves.

I don't have a Mac but if 3.7 worked on previous version of OSX then it would seem to be a Java issue rather than a Softsqueeze one.

The Java version you mentioned in another post is not the latest version as used on Linux/Windows (1.6 update 13). Is 1.6 not available on OSX ?

Have you tried running Softsqueeze from a command line (i.e. java -jar SoftSqueeze.jar) rather than using jnlp as that would help narrows down the problem area.

avta
2009-06-01, 15:34
Have you tried Play? It's at www.sbooth.org I have used Max for ripping and tried the new Rip in beta form with good results.

epoch1970
2009-06-01, 15:43
I run 10.5.6 (intel) and just fired Softsqueeze, it installed and ran with no problem at all. I also used some time ago a beta of Squeezeplay, works ok too.
I have no idea what your problem might be. Perhaps you need to run the disk utility and check/repair permissions on the system drive ? (can do wonders at times)

davep
2009-06-01, 17:15
I successfully use, at different times, SoftSqueeze, SqueezePlay and SqueezeSlave on my Mac running latest updated OS X. I think there was a hoop I had to jump through for SoftSqueeze regarding which version of java I was running, and I recall this being resolved by somewhere in the MAC OS specifying which version was to take precedence as I had more than one java installed. Can't remember the details at this point however. although I think the tip came from this forum so should be findable.

davep

snoogly
2009-06-02, 00:52
My Java version is 1.5.0_16, can't find 1.6 for Mac anywhere, so i guess it's not available.

When I launch softsqueeze, Java doesn't render the player or controller at all - so I just get a blank desktop.

I'm at a loss what to do now.

:-(

Update:-
Some progress! Downloaded Softsqueeze 3.8 (rather than letting SN download it for me). Launches, and I can see the soft player and controller - but the sound is way to distorted to listen to.

bpa
2009-06-02, 00:57
Have you installed Java SE 6 (aka 1.6) ?

As I understand it, if you have only installed Java SE 5 you will only get updates for Java SE 5.

The following indicates there is a Java SE 6 available of OSX.
http://support.apple.com/kb/HT2733

Edit

See also - it implies SE6 is only for 64 bit Intel Macs.
http://support.apple.com/downloads/Java_for_Mac_OS_X_10_5_Update_1
http://support.apple.com/downloads/Java_for_Mac_OS_X_10_5_Update_2

snoogly
2009-06-02, 01:13
Have you installed Java SE 6 (aka 1.6) ?

As I understand it, if you have only installed Java SE 5 you will only get updates for Java SE 5.

The following indicates there is a Java SE 6 available of OSX.
http://support.apple.com/kb/HT2733

Edit

See also - it implies SE6 is only for 64 bit Intel Macs.
http://support.apple.com/downloads/Java_for_Mac_OS_X_10_5_Update_1
http://support.apple.com/downloads/Java_for_Mac_OS_X_10_5_Update_2

Thanks for those leads, but I can't find any of downloading 1.6 for Macs. Mac software update should be detecting the latest available option to download, and it is finding nothing newer than I have. If someone could let me know where I can download a newer version (1.6) than Mac makes available, I'll be very happy!

bpa
2009-06-02, 01:43
the Update 1 link of
http://wsidecar.apple.com/cgi-bin/nph-reg3rdpty2.pl/product=18844&cat=59&platform=osx&method=sa/JavaForMacOSX10.5Update1.dmg

is supposed to have SE 6.