View Full Version : Errors loading iTunes library on linux

Mike Androff
2004-05-29, 21:29
I manage my MP3s on my Mac using iTunes and rsync them
to my Red Hat 9 linux box which runs 24/7 as my
slimserver. I never realized until recently reading
this forum that I could get my iTunes playlists to
show up on my SliMP3. So, I copied my iTunes library
files to the linux box, updated the slimserver to the
latest nightly (5/29), told the server to use iTunes
and where to find the iTunes library file and its MP3
directory, restart the server, and...nothing, no songs
listed under slimserver. I turned on -d__itunes, and
log file showed the following error message for each
MP3 file:

2004-05-29 18:49:09.3860 got a track named Dancing
2004-05-29 18:49:09.3878 Correcting for Linux:
to file:///itunes/iTunes
2004-05-29 18:49:09.3896 iTunes: file not found:
/itunes/iTunesMusicABBA/Arrival/Dancing Queen.mp3
Use of uninitialized value in concatenation (.) or
string at /usr/local/slimserver/Slim/Music/iTunes.pm
line 592.
iTunes: unknown file type MPEG audio file at
/usr/local/slimserver/Slim/Music/iTunes.pm line 592.

My Max music dir is /Volumes/Stuff/Music and the
equivalent linux dir is /itunes/iTunes Music. Note
that in the error message, when it replaced the Mac
dir with the linux path, it wasn't putting a "/"
between the linux music dir and the rest of the MP3's

For a quick fix, I did a quick hack in the iTunes.pm
file mentioned in the error message to always put a
"/" after the converted URL prefix. This fixed it and
all is well in SliMP3 land (and there was much

Is this a bug, or is there some setting I missed in my
slimserver config? I tried to add a "/" to the end of
the iTunes Music folder path in the slimserver config,
but it would just strip off the "/" when I saved the change.