PDA

View Full Version : Headphone port not working?....



ekadish
2009-05-22, 19:16
When I change the controller to play through the controller I hear music through the internal speaker. When I plug in headphones, I still hear music through the internal speaker and nothing in the headphones. Is something possibly wrong with my controller?...

Mnyb
2009-05-22, 23:05
Which version of SC are you running ?

if 7.3.2 try a 7.3.3 beta (stay away from the 7.4 right now, it is in quite unstable state at the moment, and "they" don't keep older betas around for to long )

Then the controller fw should upgrade to a more recent version that works better.

Audio playback trough controller is beta and is not supposed to work yet.
so don't be surprised if it does not work properly yet.

And also other post on this forum has indicated that the development of the audio playback for controller is somewhat low priority right now.
The dev's are soon to release 7.3.3 and are fighting to iron out the most alarming bugs in the controller, which of course have higher priority.

If you search the forum there is a tread somewhere on wich files to hack in the controller to improve this behavior.

There is bit of paradox the 7.3r3993 fw version of the controller has problems with headphone switching.

Never version have improved headphone switching but sometimes suffers from stutter in the playback ?

So if one is desperate to have headphone playback, one is to hack the 7.3r3993 version and run SC7.3.2

And to ask the obvious is the headphone port is tigth fit have inserted the plug all the way or tried another pair of phones.

with r3993 i had to go trough a special routine to make it work
1. enable audio playback ( beta ) in the advanced settings of the controller
2. turn of the controller
3. start (or restart, reboot) Squeezecenter
4. make sure that SC is up and running
5. Start the controller

In short make sure that SC is running before starting my controller.
And to repeat this every time i shut down my SC and lef t controller running.

Never betas has passed this stage and the controller player is available all the time, but in many cases suffers from stutter in the playback as I and others have discovered.

ekadish
2009-05-23, 06:33
Thanks for the thoughts! I knew it was beta status but quick searches on 'headphone' didn't yield much. Due to limited available time, I'll probably just hold out for this to, hopefully, get ironed out with newer firmware.

Generally speaking, I can understand getting bugs worked out is important but I'd think reliable headphone use of the controller for streaming would be a strong marketing point since you're effectively getting two playback devices with the Duet.

Thanks again.

simonjedrake
2009-05-23, 15:14
Thanks for the thoughts! I knew it was beta status but quick searches on 'headphone' didn't yield much. Due to limited available time, I'll probably just hold out for this to, hopefully, get ironed out with newer firmware.

Generally speaking, I can understand getting bugs worked out is important but I'd think reliable headphone use of the controller for streaming would be a strong marketing point since you're effectively getting two playback devices with the Duet.

Thanks again.

The latest 7.3.3 beta's are now pretty stable in 99% of the Duet features.

agbagb
2009-05-23, 16:38
SqueezeCenter Version: 7.3.2 - 24695 under Vista
2 x SB3s, wireless, WPA2, in sync.
Controller 7.3 r3993

For me, the above configuration had both audio speaker, and headphones, + perfectly reliable automatic switching between the 2, out of the box.

Your experience may vary!

AGB

ekadish
2009-05-25, 07:46
Hmm... I just upgraded to 7.3.3 r5577 and I still don't get audio through the headphone port. Maybe I have a bad controller?...

agbagb
2009-05-25, 08:31
In CONTROLLER - SETTINGS, have you tried digging down into AUDIO, disabling the Beta Controller-as-Player feature, rebooting Controller, and then digging down and reselecting the Beta?

Worth a try....