PDA

View Full Version : Transporter & NAPSTER



golddustpeak
2009-05-18, 20:17
I have several devices in the house (Duet, Boom & Transporter) which have ALL been working with SN, SC, net streaming, and my files.

Today I decided to audition NAPSTER with my free 30 days.

I started with the Duet and Squeezebox receiver, and all went well.

Next I turned on the Transporter but it only plays one song at a time from an album, that is, I have to manually forward the track to hear the next song.

Now this problem dose not exists with the Transporter, my library or with other net offered services.

The Squeezebox receiver dose not exhibit this problem. The problem Iím describing occurs only with the Transporter and either the SN or SC using NAPSTER. The other device works fine on both.

Iíve looked in the SC, SN and Transporter for settings that might cause this but I find nothing.

Any ideas????

Siduhe
2009-05-19, 01:58
Have you checked the Behaviour settings for the Transporter in Squeezenetwork?
Log into Squeezenetwork, Players/Transporter/Settings/Behaviour/Play Other Songs in Album should be set to "Play other Songs in Album" not "Play Only Selected Song".

If your SB3 and Duet are working as expected, this is the most likely cause I can think of.

golddustpeak
2009-05-19, 05:16
Have you checked the Behaviour settings for the Transporter in Squeezenetwork?
Log into Squeezenetwork, Players/Transporter/Settings/Behaviour/Play Other Songs in Album should be set to "Play other Songs in Album" not "Play Only Selected Song".

If your SB3 and Duet are working as expected, this is the most likely cause I can think of.

Yes I've checked this and it is set to "Play other Songs in Album".

The Transporter works properly with my Albums and other streaming services. It's just gets stuck with NAPSTER using SN or SC.

Siduhe
2009-05-19, 06:37
I assume you are using the same action to play napster tracks on the Transporter as the SB3 i.e. pressing the same button on the remote - or are you using the front panel of the transporter? What about if you play napster tracks via the web interface on the SB3 and the Transporter - do you see the same behaviour, or does that work?

If it's working fine with everything except napster, and both the SC and SN player settings are set to "play entire album", then I'm stumped. You may want to contact support@slimdevices.com.

golddustpeak
2009-05-19, 16:31
Today out of frustration I turned on the Transporter and used its remote rather than the Duet remote that I had been using.

The Transporter worked as it should have, with no stopping after the first songÖÖÖ

Unfortunately I was called away and could go no further.

More testing tomorrow.

Siduhe
2009-05-20, 00:28
If you are using the Duet remote, doublecheck the setting of Playlist Mode - it should be on Disabled rather than On or Off.

golddustpeak
2009-05-20, 06:44
After further testing it appears that Iíve not been consistent in my testing.

This morning, being extremely careful to test the same albums networks etc. the problem now appears to be with NAPSTER or the NAPSTER plug-in. Some albums play in song after song while others just play the first track.

Siduhe
2009-05-20, 07:04
Can you give an example album?

Some napster tracks are limited to 30 sec previews which don't play via the Squeezebox, but they shouldn't even show up on the listings.

However, again - if these are working on your SB3 and not on your Transporter, that points to a problem with the Transporter setup/behaviour rather than Napster itself.

golddustpeak
2009-05-20, 07:48
Sorry about the confusion Iíve discovered that both devices are functioning the same way.

Here are three albums that I was testing this AM:

Roberta Flack Ö Killing Me Softly
Eva Cassidy Ö Somewhere & Time After Time

Siduhe
2009-05-20, 09:14
I've just tried the Roberta Flack album. There are actually two versions on the Napster site (in one the first track is entitled "Jesse" and in the other "Jesse [LP Version]". Both albums play fine for me, song after song, initiated by pressing the play button from the web interface. Do you see the same (if you try playing via the web interface)?

If that works ok, is it only when you try to play from the Duet Controller? What is the exact sequence of buttons you are pressing?

Also, you aren't running Squeezecenter 7.4 are you? If so, it's bleeding edge at the moment and there's quite a lot of stuff isn't quite working as it should!

golddustpeak
2009-05-20, 10:04
The free trial only works with SN and or SC, there is no Web account, so Iím stuck with a controller.

I only see One Killing Me Softly Album and the first track is Killing Me Softly.
Pressing the play button on the album cover or pressing the play button on Play all or pressing the center button on the all seem to have the same result.

As I said some other albums seem to work fineÖ..

I guess Iíll just not invest in a subscription until I better understand what the extent of the problem is for me. Looks like I need to try a ton of albums, the good news is I still have a few weeks.

Siduhe
2009-05-20, 11:26
I am a bit confused and I think we may be talking at cross purposes. I am talking about playing Napster tracks via the Squeezecenter web interface, not via the Napster web interface. This may be because I am a subscriber to Napster rather than using the free trial. Are you saying that you can't see Napster tracks in the SC web interface, but can via the controller?

For example, I am running 7.4 (Napster integration is also in 7.3.3, not sure about 7.3.2) and I can browse to Music Services in the SC web interface, drill down to Napster tracks, click play, and the tracks play.

You should be able to do the same via the web interface or on the Transporter player menu, without using the Controller.

What version of Squeezecenter are you running?

This may be some quirk of the free trial, but I can confirm that (for me at least) the tracks you are having problems with work fine on a Boom, SB3, SB2, SB1 and Duet (I tried it on all of my players, no Transporter yet sadly). Hope this helps.

Siduhe
2009-05-20, 11:34
I attach a screen shot to explain what I mean by the SC web interface - it also shows the two Roberta Flack albums Killing Me Softly (and a whole bunch more besides!).

golddustpeak
2009-05-20, 13:40
Using the SC interface helps explain what's happening.
I'm using 7.3.3 but there is only one Killing me softly shown and just one track....

andyg
2009-05-20, 14:07
Are you guys both located in the same country? Napster's catalog differs depending on your country.

golddustpeak
2009-05-20, 14:18
Good question!

I'm in Colorado....

Siduhe
2009-05-20, 14:39
I'm in the UK - so that explains the different catalogue, but not the different behaviour in playing the same album.

Has to be an SC setting or a difference between 7.3.3 and 7.4 - any thoughts Andy?

jrichardson
2009-06-10, 12:05
Can you turn SC logs for Plugin.Napster to Debug, reproduce the error, then email them to me please

SO far, I have not been able to reproduce the error yet

KMorgan
2009-06-10, 13:15
GD Speak

That screenshot you posted shows that that "album" only contains one song, not that it is only playing one song from a whole album.

You will find that many Napster "albums" are actually singles. When you browse music in Napster (which can be a PITA) continue to the song-list view (by pressing ENTER or RIGHT not PLAY) so that you can check that you are indeed trying to play a whole album, not just one song.

Hope this is of some help.

Keith