PDA

View Full Version : MP3 to MP3 transcoding broken?



Roland Fischer
2004-05-21, 15:10
Well, I don't think wipe cache would change anything, the problem seems to
be that in convert.conf there is nothing specified for mp3-mp3 transcoding.
Here the log in short:
.....
2004-05-21 23:52:58.4299 checking formats for: mp3-mp3-*-*
.....
2004-05-21 23:52:58.5937 Found command: -
2004-05-21 23:52:58.6182 ******* Error: Didn't find any command matches for
type: mp3 format: mp3 ******
2004-05-21 23:52:58.6547 openSong: this is an mp3 file:
file:///M:/MP3_SONGS/A/Adamski/Adamski%20-%20Killer.mp3
2004-05-21 23:52:58.6768 file type: mp3 format: mp3 inrate: 128 maxRate:
64
2004-05-21 23:52:58.7215 command:
2004-05-21 23:52:58.7431 Couldn't create command line for mp3 playback for
file:///M:/MP3_SONGS/A/Adamski/Adamski%20-%20Killer.mp3


Roland

kdf
2004-05-21, 15:32
actually...for mp3 to mp3, it should be finding mp3-lame-*-* which is a special
case for such a thing.
-kdf

Quoting Roland Fischer <slimp3user (AT) graben13 (DOT) at>:

> Well, I don't think wipe cache would change anything, the problem seems to
> be that in convert.conf there is nothing specified for mp3-mp3 transcoding.
> Here the log in short:
> ....
> 2004-05-21 23:52:58.4299 checking formats for: mp3-mp3-*-*
> ....
> 2004-05-21 23:52:58.5937 Found command: -
> 2004-05-21 23:52:58.6182 ******* Error: Didn't find any command matches for
> type: mp3 format: mp3 ******
> 2004-05-21 23:52:58.6547 openSong: this is an mp3 file:
> file:///M:/MP3_SONGS/A/Adamski/Adamski%20-%20Killer.mp3
> 2004-05-21 23:52:58.6768 file type: mp3 format: mp3 inrate: 128 maxRate:
> 64
> 2004-05-21 23:52:58.7215 command:
> 2004-05-21 23:52:58.7431 Couldn't create command line for mp3 playback for
> file:///M:/MP3_SONGS/A/Adamski/Adamski%20-%20Killer.mp3
>
>
> Roland
>

kdf
2004-05-21, 15:41
here is a sample of the kind of thing you shoudl be seeing with the latest cvs:

2004-05-21 15:37:47.3968 checking formats for: mp3-mp3-*-*
2004-05-21 15:37:47.3970 Checking to see if mp3-mp3-*-* is enabled
2004-05-21 15:37:47.3972 There are 3 disabled formats...
2004-05-21 15:37:47.3974 Testing wma-wav-squeezebox-* vs mp3-mp3-*-*
2004-05-21 15:37:47.3976 Testing wma-mp3-*-* vs mp3-mp3-*-*
2004-05-21 15:37:47.3978 Testing mov-wav-squeezebox-* vs mp3-mp3-*-*
2004-05-21 15:37:47.3979 Testing mov-mp3-*-* vs mp3-mp3-*-*
2004-05-21 15:37:47.3988 enabled
2004-05-21 15:37:47.3991 Found command: -
2004-05-21 15:37:47.3993 Matched Format: mp3 Type: mp3 Command: [lame] --resampl
e 44100 --silent -b $BITRATE$ $FILE$ -
2004-05-21 15:37:47.3996 openSong: this is an mp3 file: file:///D:/mp3/PEARL%20J
AM/Lost%20Dogs/PEARL%20JAM%20-%20(03)%20Hard%20To%20Imagine.mp3
2004-05-21 15:37:47.3998 file type: mp3 format: mp3 inrate: 186 maxRate: 96
2004-05-21 15:37:47.4000 command: [lame] --resample 44100 --silent -b $BITRATE
$ $FILE$ -
2004-05-21 15:37:47.4018 Using command for conversion: "D:\slim\server\Bin\MSWin
32-x86-multi-thread\lame.exe" --resample 44100 --silent -b 96 "D:\mp3\PEARL JAM\
Lost Dogs\PEARL JAM - (03) Hard To Imagine.mp3" - |
2004-05-21 15:37:47.4041 Streaming with format: mp3
2004-05-21 15:37:47.4574 00:03:47:f6:0f:08 New play mode: play
2004-05-21 15:37:47.4749 00:03:47:f6:0f:08: Current playmode: play


You need to have the following line in convert.conf, which shodl be there by
default:

# special case for smart bitrates on mp3 input
mp3 lame * *
[lame] --resample 44100 --silent -b $BITRATE$ $FILE$ -


in one of the recent nightlies, it was possible to accidentally have that
profile disabled, but the debug log you showed would have shown a message if it was.

-kdf