PDA

View Full Version : Nightly 05-21: where is the "use iTunes" setting?



Michel Fombellida
2004-05-21, 06:06
I just installed the latest nightly, I don't find the "Use iTunes" settings
anymore.... and as a matter of fact slimserver has lost track of my iTunes
library.

Note that the "Home Menu Customization" is working fine now (no multiple
entries possible anymore).

Michel

kdf
2004-05-21, 07:01
what os?

Have you set iTunes settings for autolocated? if so, what's the music folder?
Try running the server from the command line with --d_itunes and see if the
debug shows any useful info.

I fixed one bug last night where the conversion for linux was being lost, but
this should not have affected actually finding the library.

-kdf

Quoting Michel Fombellida <mf22433 (AT) yahoo (DOT) com>:

> I just installed the latest nightly, I don't find the "Use iTunes" settings
> anymore.... and as a matter of fact slimserver has lost track of my iTunes
> library.
>
> Note that the "Home Menu Customization" is working fine now (no multiple
> entries possible anymore).
>
> Michel
>
>

Michel Fombellida
2004-05-21, 07:36
Hi,

XP Pro SP1 and yes it is on "Find iTunes library automatically".

My iTunes music folder is
D:\iTunes Music

the library is
C:\Documents and Settings\Michel\My Documents\My Music\iTunes\iTunes Music
Library.xml

The music files are visible in slimserver but the genres and artworks are not.
I am quite sure that in the previous version there was a setting "Use iTunes"
somewhere... and using it solved this problem with genres but I don't find it
anymore.

The logs say:

2004-05-21 16:27:18.1282 canUseiTunesLibrary().
2004-05-21 16:27:18.1283 findMusicLibraryFile().
2004-05-21 16:27:18.1283 itunes: attempting to locate iTunes Music Library.xml
2004-05-21 16:27:18.1285 findLibraryFromPlist().
2004-05-21 16:27:18.1288 findLibraryFromRegistry().
2004-05-21 16:27:18.1296 iTunes: found My Music here: for \iTunes\iTunes
Music Library.xml
2004-05-21 16:27:18.1313 itunes: unable to find iTunes Music Library.xml.


Michel

Michel Fombellida
2004-05-21, 07:48
Hi,

More feedback: I just changed the setting to "Specify iTunes Library" (instead
of automatic), I then went back to the front page of "server settings" and
guess what... the "Use iTunes" radio button is there now (between Language and
Music Folder sections), I am 100% sure it was not there before!

and now the logs say:
2004-05-21 16:37:53.9726 canUseiTunesLibrary().
2004-05-21 16:37:53.9727 findMusicLibraryFile().
2004-05-21 16:37:53.9733 itunes: found path via config file at: C:\Documents
and Settings\Michel\My Documents\My Music\iTunes\iTunes Music Library.xml
2004-05-21 16:37:53.9734 using itunes library: 0
2004-05-21 16:37:57.3252 canUseiTunesLibrary().
2004-05-21 16:38:01.0207 canUseiTunesLibrary().
2004-05-21 16:38:01.0249 canUseiTunesLibrary().
2004-05-21 16:38:01.0250 using itunes library: 0
.... a long list follows.

Michel

kdf
2004-05-21, 08:40
Quoting Michel Fombellida <mf22433 (AT) yahoo (DOT) com>:


> 2004-05-21 16:27:18.1296 iTunes: found My Music here: for \iTunes\iTunes
> Music Library.xml
> 2004-05-21 16:27:18.1313 itunes: unable to find iTunes Music Library.xml.

odd. clearly its being found, but then says unable. The only thing between is
a test ($path && -r $path). Somehow the server was testing and either not
storing the result correctly, or is unable to read the file. I'm not sure how
permissions could have changed recently. Also odd becuase if you specify the
location, it still has to pass the $path and -r $path test.

Glad you did get it back, but if you could try setting back to automatic and
restarting, it would be interesting to know if the problem returns, or was just
some temporary glitch.

cheers,
kdf

Michel Fombellida
2004-05-21, 09:31
Hi kdf,

I did set it back to automatic and restarted, the "Use iTunes" is still there
and the server is working fine... I guess it was a glitch.

Michel

kdf
2004-05-21, 09:34
Quoting Michel Fombellida <mf22433 (AT) yahoo (DOT) com>:

> Hi kdf,
>
> I did set it back to automatic and restarted, the "Use iTunes" is still there
>
> and the server is working fine... I guess it was a glitch.
>
thanks, but keep an eye on it. Let us know if the next nightly gives you any
troubles :)

=kdf

Michel Fombellida
2004-05-21, 10:27
Hi,

The server now seems to behave correctly but on the squeezebox I am getting an
error message when I try to play any title: "can't open file for".

Michel

kdf
2004-05-21, 10:38
Quoting Michel Fombellida <mf22433 (AT) yahoo (DOT) com>:

> Hi,
>
> The server now seems to behave correctly but on the squeezebox I am getting
> an
> error message when I try to play any title: "can't open file for".
Hi Michel,
Try server settings, additional, performance. Click Wipe Cache, and wait for
the rescan. Hopefully that will clear things up. Teh official release will
force a rescan of this type.

if that doesn't fix things, can you turn on d_source in the debugging. Server
Settings, Additional, Debugging. Check d_source and click change. you can then
view the log at: http://serverIP:9000/log.txt

try playing a song and report the messages you get when it fails to play. Sorry
for the quirks, but the testing is really appreciated and will help make 5.2 as
good as it can be.

cheers,
kdf

Michel Fombellida
2004-05-21, 11:12
Hi kdf,

No problem, I know I am using beta releases :-)

After I did the wipe cache and the server started to rescan my library... but
it did not find anything, I then noticed that the "Use iTunes" button was gone
again, so it was not really a glitch. I used the same trick, set iTunes
to "specify the iTunes folder", the "Use iTunes" button came back, set it back
to "automatic". Everything looks fine in the server but the squeezebox still
gives the same error message "Problem: can't open file for" (I see all the
titles of one disc scanning quickly still with the same error message).

I turned on the debugging as requested and I can see this at the bottom of the
log file (it is a long file, tell me if you need a specific part):

2004-05-21 19:58:24.9044 !! mov-mp3-*-* Disabled!!
2004-05-21 19:58:24.9045 ******* Error: Didn't find any command matches for
type: mov format: mp3 ******
2004-05-21 19:58:24.9046 openSong: this is an mov file: file:///D:/iTunes%
20Music/St.%20Germain/Tourist/05%20Latin%20Note.m4a
2004-05-21 19:58:24.9047 file type: mov format: mp3 inrate: 938 maxRate: 320
2004-05-21 19:58:24.9049 command:
2004-05-21 19:58:24.9050 Couldn't create command line for mov playback for
file:///D:/iTunes%20Music/St.%20Germain/Tourist/05%20Latin%20Note.m4a
2004-05-21 19:58:24.9072 the next song is number 5, was 4

Note that I use Apple lossless (only) and in the File Type I have specify to
use AIFF for Apple Lossless (not MP3).

Cheers,
Michel

kdf
2004-05-21, 11:38
Quoting Michel Fombellida <mf22433 (AT) yahoo (DOT) com>:

> Hi kdf,
>
> No problem, I know I am using beta releases :-)
>
> After I did the wipe cache and the server started to rescan my library... but
>
> it did not find anything, I then noticed that the "Use iTunes" button was
> gone
> again, so it was not really a glitch. I used the same trick, set iTunes
> to "specify the iTunes folder", the "Use iTunes" button came back, set it
> back
> to "automatic". Everything looks fine in the server but the squeezebox still
>
> gives the same error message "Problem: can't open file for" (I see all the
> titles of one disc scanning quickly still with the same error message).
>
> I turned on the debugging as requested and I can see this at the bottom of
> the
> log file (it is a long file, tell me if you need a specific part):
>
> 2004-05-21 19:58:24.9044 !! mov-mp3-*-* Disabled!!
> 2004-05-21 19:58:24.9045 ******* Error: Didn't find any command matches for
>
> type: mov format: mp3 ******
> 2004-05-21 19:58:24.9046 openSong: this is an mov file: file:///D:/iTunes%
> 20Music/St.%20Germain/Tourist/05%20Latin%20Note.m4a
> 2004-05-21 19:58:24.9047 file type: mov format: mp3 inrate: 938 maxRate:
> 320
> 2004-05-21 19:58:24.9049 command:
> 2004-05-21 19:58:24.9050 Couldn't create command line for mov playback for
> file:///D:/iTunes%20Music/St.%20Germain/Tourist/05%20Latin%20Note.m4a
> 2004-05-21 19:58:24.9072 the next song is number 5, was 4
>
> Note that I use Apple lossless (only) and in the File Type I have specify to
>
> use AIFF for Apple Lossless (not MP3).
>
this message shows that the server thinks you have a bitrate limit of 320kbps.
This will force a conversion to MP3. I'm assumign you dont have lame installed,
which is why this is failing. What player are you using? Go into player
settings, set the bitrate limiting to "no limit" and that should help.

By default, squeezebox wired and softsqueeze default to no limit. Wireless
squeezebox, slimp3 and any http software clients will default to 320.

-kdf

Michel Fombellida
2004-05-21, 11:58
Hi kdf,

That was it! I am using a wireless squeezebox and as I deinstalled/reinstalled
the server earlier today, the limit at 320 came back... I had forgotten that.
I indeed don't have lame installed (in this case, it is good that I did not
have lame installed such that I could detect the problem).

Cheers,
Michel

kdf
2004-05-21, 12:09
Quoting Michel Fombellida <mf22433 (AT) yahoo (DOT) com>:

> Hi kdf,
>
> That was it! I am using a wireless squeezebox and as I
> deinstalled/reinstalled
> the server earlier today, the limit at 320 came back... I had forgotten that.
>
> I indeed don't have lame installed (in this case, it is good that I did not
> have lame installed such that I could detect the problem).

it shows itself in other ways. The status of the web UI will show (converted to
320kbps CBR) and trackinfo for the current song will also show this in the
player UI. Also, the bitrate limiting player setting will say in teh
description whether or not LAME is found, and the file types server settings by
default will disable any formats for which binaries (incl lame) are not found.
It might be overkill, but the idea is to try to make it as obvious as possible
what is going on :)

now, you just need iTunes to be found automatically. From you older debug
message, it looks like the windows registry is giving back the wrong value for
the location of the library. \iTunes\iTunesMusic Library.xml doesn't seem like
its missing something. Maybe have a quick look at:
HKEY_CURRENT_USER->Software\Microsoft\Windows\CurrentVersion\Explorer \Shell Folders

see what information is in there as far as music paths.

-kdf

Michel Fombellida
2004-05-21, 12:53
Hi,

The only key related to music in this folder is "My music" and the value is
C:\Documents and Settings\Michel\My Documents\My Music.

Michel

Michel Fombellida
2004-05-21, 13:00
Note that I noticed that some recently ripped disks were not visible, I redid
the "wipe cache" and then the "Use iTunes" button went away once again. This
is reproduceable.

Michel

Michel Fombellida
2004-05-21, 13:05
Note that I did not experience this problem with the 05-20 nightly.
Michel

kdf
2004-05-21, 13:06
Quoting Michel Fombellida <mf22433 (AT) yahoo (DOT) com>:

> Hi,
>
> The only key related to music in this folder is "My music" and the value is
> C:\Documents and Settings\Michel\My Documents\My Music.
>

From your debug message, it appears that "" is being returned instead of the
proper path. I cannot explain why. Maybe Dean has some ideas.

The autolocate also looks for "Personal" in the registery if "My Music" fails.
However, in your case it is cearly coming back as a sucess...but without the
actual path.

-kdf