PDA

View Full Version : "SlimServer_v2004-05-18.dmg"-



Neil Serdinsky
2004-05-19, 11:24
No matter what changes I make, the bitrate remains at 320. At this point I did the following (all command line Mac OS X)

1) after making the setMaxRate changes to Prefs.pm and still having the problem I downloaded the 5-19 nightly
2) I manually mounted the .dmg
3) I stopped the Slim service
4) I moved the old ~/Library/PreferencePanes/SlimServer.prefPane and copied the mounted Install Files/PreferencePanes/SlimServer.prefPane in it's place
5) I restarted the Slim Service

Still 320 not matter what I do.

6) I tried setting the max rate in the plugins settings page on the webserver
7) I tried manually setting the bitrate in the url (i.e. stream.mp3?bitrate=128

Could the old settings be cached somewhere?

Thanks for your help,
Neil


Quoting Neil Serdinsky <neilserdinsky at mac.com>:

> I understand this is fixed in 5-19, but since I am only accessing my system
> remotely right now I cannot install the new build. Is the fix small enough to
> post so I can make the change manually for now?
>
> Thanks,
> Neil

I'm assuming this is the bitrate issue...in Prefs.pm, rewrite setMaxRate to this
(beware of linebreaks from the posting):

sub setMaxRate {
my $client = shift;
my $maxRate = clientGet($client,'transcodeBitrate') ||
clientGet($client,'maxBitrate');
if (!defined $maxRate) {
# Possibly the first time this pref has been accessed
# if maxBitrate hasn't been set yet, allow wired squeezeboxes to default to no
limit, others to 320kbps
$maxRate = ($client->model() eq 'squeezebox' && !defined
$client->signalStrength())
? 0 : 320;
clientSet($client,'maxBitrate',$maxRate);
}
return $maxRate;
}

kdf
2004-05-19, 11:51
Quoting Neil Serdinsky <neilserdinsky (AT) mac (DOT) com>:

> No matter what changes I make, the bitrate remains at 320. At this point I
> did the following (all command line Mac OS X)
>
> 1) after making the setMaxRate changes to Prefs.pm and still having the
> problem I downloaded the 5-19 nightly
> 2) I manually mounted the .dmg
> 3) I stopped the Slim service
> 4) I moved the old ~/Library/PreferencePanes/SlimServer.prefPane and copied
> the mounted Install Files/PreferencePanes/SlimServer.prefPane in it's place
> 5) I restarted the Slim Service
>
> Still 320 not matter what I do.
>
> 6) I tried setting the max rate in the plugins settings page on the
> webserver
> 7) I tried manually setting the bitrate in the url (i.e.
> stream.mp3?bitrate=128
>
> Could the old settings be cached somewhere?

If you are using the URL, it overrides the player setting. This will not be
reflected in the player settings because this will still remain as the default
for when the url is used without a bitrate parameter. You can verify the
bitrate from the rate that winamp reports when playing the stream. Before the
stream is actually playing, the bitrate will not be reported correctly due to a
silence.mp3 being streamed at 320 kbps when idle.

I've tested this with the lastest from CVS and it works as expected, so the
nightly should be doing the same. If you are unable to get playback at 128 when
using:
http://slimserverIP:9000/streams.mp3?bitrate=128
in winamp, then try going to player settings from the web UI, click forget this
player. The reconnect with the above url via winamp. The Bitrate Limiting
setting will still say 320, but your playback should come up as 128 once you
start playing a song.

-kdf

Neil Serdinsky
2004-05-19, 13:07
kdf <slim-mail@...> writes:

> player. The reconnect with the above url via winamp. The Bitrate Limiting
> setting will still say 320, but your playback should come up as 128 once you
> start playing a song.
>
> -kdf
>


I am going to have to wait until I am front of the box and do a re-install. I
think there must be something else going on since I tried forgetting the
player and forcing the bitrate to 128 in the URL and winamp still reports 320.
(I have also tested this in iTunes and Windows Media Player).

thanks.
Neil

P McDowell
2004-05-19, 14:16
"Neil Serdinsky" <neilserdinsky (AT) mac (DOT) com> wrote in
message news:loom.20040519T220606-695 (AT) post (DOT) gmane.org...
> kdf <slim-mail@...> writes:
>
> > player. The reconnect with the above url via winamp. The Bitrate
Limiting
> > setting will still say 320, but your playback should come up as 128 once
you
> > start playing a song.
> >
> > -kdf
> >
>
>
> I am going to have to wait until I am front of the box and do a
re-install. I
> think there must be something else going on since I tried forgetting the
> player and forcing the bitrate to 128 in the URL and winamp still reports
320.
> (I have also tested this in iTunes and Windows Media Player).
>
> thanks.
> Neil

Two things may be misleading you
The bitrate doesn't change till you skip to the next track
Winamp seems to average its bitrate reading, so you see the bitrate slowly
reducing unless you close and reopen Winamp, then you immediately see the
bitrate you set.

kdf
2004-05-19, 15:27
Quoting Neil Serdinsky <neilserdinsky (AT) mac (DOT) com>:

> kdf <slim-mail@...> writes:
>
> > player. The reconnect with the above url via winamp. The Bitrate
> Limiting
> > setting will still say 320, but your playback should come up as 128 once
> you
> > start playing a song.
> >
> > -kdf
> >
>
>
> I am going to have to wait until I am front of the box and do a re-install. I
>
> think there must be something else going on since I tried forgetting the
> player and forcing the bitrate to 128 in the URL and winamp still reports
> 320.
> (I have also tested this in iTunes and Windows Media Player).
it WILL report 320 when you connect. This is because hte server streams a
silent mp3 at 320kbps. You have to go into the web interface, select some song
to add to the playlist and then start the playback. Then, winamp will slowly
start to move towards 128 as the moving average that winamp displays gets closer
to the actual bitrate being played. OR you can then reconnect winamp and see
that its reporting 128.

-kdf

Neil Serdinsky
2004-05-20, 08:12
kdf <slim-mail@...> writes:

> it WILL report 320 when you connect. This is because hte server streams a
> silent mp3 at 320kbps. You have to go into the web interface, select some
song
> to add to the playlist and then start the playback. Then, winamp will slowly
> start to move towards 128 as the moving average that winamp displays gets
closer
> to the actual bitrate being played. OR you can then reconnect winamp and see
> that its reporting 128.
>


Well, I installed 5-19 and iTunes and winamp both still constantly rebuffer
and report "Network Stalled".

What I need to look into now is if I have a firewall problem or something else
unrelated to the Slimserver...

Thanks,
Neil