PDA

View Full Version : Radio Stream Problem..



Tirionvalar
2009-03-30, 07:22
Hello People...
Im trying to play this stream: http://hjck.radiocaracol.com/envivo.htm but I can get it..
Any idea how to get the correct URL??
Thanx

radish
2009-03-30, 20:54
Try this: http://66.175.96.8/cohjck

Tirionvalar
2009-03-31, 00:54
Hey radish..Thank you very much.....It works perfect...
Tell me how did you get that?

bpa
2009-03-31, 01:01
One way for those pages which present a "player" is to look for the EMBED in the html source code. The src= parameter to an EMBED is the url to be played. In your case


<EMBED type='application/x-mplayer2'
pluginspage='http://microsoft.com/windows/mediaplayer/en/download/'
id='mediaPlayer' name='mediaPlayer' displaysize='4' autosize='-1'
bgcolor='darkblue' showcontrols="true" showtracker='-1'
showdisplay='0' showstatusbar='-1' videoborder3d='-1' width="220" height="30"
src="http://audio.grupolatinoderadio.com/CO_HJCK.asx" autostart="true" designtimesp='5311' loop="false">
</EMBED>

Tirionvalar
2009-03-31, 01:47
Thanx bpa...I had an Idea on how to do it...and I got that .asx file..but I was not able to play the file on the Squeezenetwork.. And if you watch carefully the Url that Radish got is different (http://66.175.96.8/cohjck)..Do you know how to get that one?..
bye

bpa
2009-03-31, 02:05
The ASX plays fine on my SC. The contents of the ASX has Radish's URL



<Asx Version = "3.0">
<Entry>
<title>HCJK - El mundo en Bogota</title>
<Ref href = "http://66.175.96.8/cohjck" /><Ref href = "http://66.175.96.9/cohjck" />
</Entry>
</Asx>

radish
2009-03-31, 05:12
The ASX didn't play for me, but as bpa said I got a working URL from inside the ASX. Interesting that it worked for some but not others...do you have Alien installed bpa?

toby10
2009-03-31, 06:42
The ASX didn't play for me, but as bpa said I got a working URL from inside the ASX. Interesting that it worked for some but not others...do you have Alien installed bpa?

I have Alien and it won't play.

bpa
2009-03-31, 06:56
It's nothing to do with Alien - it's to do with ASX parsing.

The ASX playlist returns a MIME type of text/html and as part of debugging something else I happen to have this type disabled on my system and so the ASX got processed properly whereas on a standard SC the ASX file is processed as HTML which ends up with no entries.