PDA

View Full Version : Problem with SQL playlist :-(



mcw
2009-03-24, 16:11
Hi guys - I have a problem with SQL playlist. I've just installed a new setup, and if I try and create a new SQL playlist, I can go all the way through to the point where I click on "Save" and at that point it says:

Error:
No custom dir configured

and won't save :-(

I have:

Dynamic Playlists 2.7
SQL Playlist 2.4
TrackStat 2.8

and Squeezecenter 7.4. It also happens with 7.3.2

and this is under XP.

Please help - this is driving me mad. I use the SQL playlist I'm trying to create all the time, and I wouldn't want to do without it :-(

Thanks,

Mark

erland
2009-03-24, 21:55
You will have to configure the "Playlist directory" parameter under "SqueezeCenter Settings/Plugins/SQL Playlist". I think you may have to restart SqueezeCenter after you have changed it but I'm not sure.

mcw
2009-03-25, 02:30
You will have to configure the "Playlist directory" parameter under "SqueezeCenter Settings/Plugins/SQL Playlist". I think you may have to restart SqueezeCenter after you have changed it but I'm not sure.

Ahh -- thank you! My playlist folder was set to E:\Playists (can you see the typo? :-)

Next time you're in the editor near that code, could you add a

error("$playlistFolder is not a folder") if (! -d $playlistFolder);

or something similar? It would have saved me (and others in future I'm sure) a lot of grief (and I wouldn't be so tired today :-).

Many, thanks - and please don't take the above as a complaint -- your plugins are really useful -- keep up the good work.

Mark