PDA

View Full Version : Internet Radio



eschurig
2009-02-21, 22:35
I recently upgraded to Squeeze Center 7.3.2 (from version 6.5) and the installation seems to have gone well (other than loosing my preferences). However, I have come across two problems detailed below:

1. I've been playing with listening to some internet radio stations as I manually redo my favorites list. One station I used to listen to is a public radio station in Dallas, TX: KERA 90.1. When I try to listen to this station over "Internet Radio" via Squeeze Center on my squeezebox, I hear a thank you for tuning in but the station never plays. Curriously, the station plays fine if I go through "Squeeze Network." Other radio stations I've tried through internet radio seem to work fine. Is there something I can configure differently to fix this? Why would it play through "Squeeze Network" but not through my local Squeeze Center server? Since I just upgraded, I would have thought that differences between Squeeze Center and Squeeze Network would be minimal. This station used to work with my old slimserver version 6.5, although, it has been some time since I've listened to it.

2. My second problem has to do with softsqueeze and internet radio stations. After upgrading Squeeze Center as described above, I clicked on the softsqueeze link under "extras" in squeeze center to upgrade softsqueeze. Softsqueeze upgraded itself to version 3.7 from version 3.4. I seem to be able to play music from my library just fine but most internet radio stations will not play. I get an error from softsqueeze that says: "Problem: Unable to play file for: Stream". There are many stations that play fine on the squeezebox but won't play on softsqueeze. I did find a couple stations that would play on both. I think I saw somewhere that there is a new soft player available but couldn't seem to find it on the logitech website where softsqueeze could be found. Do I need to change to the new player? If so, where do I find it?

Thanks in advance for any help.

Best Regards,
Ed

eschurig
2009-02-23, 13:41
I just found a thread dated 12/14/2008 that discusses a problem similar to mine where softsqueeze will not stream internet radio stations but the hardware squeezeboxes will play fine. The thread talks about whether softsqueeze can play wma files or not and says that if squeeze center is installed on linux it won't play wma files. My setup has squeeze center installed on linux but softsqueeze is installed on windows xp. Is there something I need to do to get softsqueeze to stream internet radio stations that are wma encoded? I'm not sure how to tell if the stations that won't play are wma encoded but since the error message is "unable to play file type for station stream" this sure sounds like it could be the problem.

If the softsqueeze wma issue is my problem, do I need to install something in windows xp for softsqueeze or do I need to install something in linux for squeezecenter?

eschurig
2009-02-23, 13:55
I guess I did a very poor job of searching for posts on this issue before I posted. Please accept my apologies. There is a thread started on 2/2/2009 concerning softsqueeze problems with wma streams. Andy G responded that squeezecenter must be running on a windows machine for softsqueeze to be able to play wma streams.

Is there really no way to install a package in linux to get squeezecenter to perform wma transcoding to allow softsqueeze to play wma streams?

bpa
2009-02-23, 14:41
Install AlienBBC (use Extension Downloader plugin) and the mplayer application and besides enabling RealAudio streams, it also enable wma.

There has been a recent issue with WMA streams with new fast systems/ distros - so post back if you have problems.

eschurig
2009-02-23, 23:05
Thanks for the reply. I would have never imagined from reading the alienBBC info and mplayer description that this would solve the wma issue. It looks easy enough to install so I will give it a try tomorrow.

If fast systems are a problem with the wma streams it shouldn't affect me. I'm running debian etch on a 400MHz Pentium II. This machine has run my slimserver without problems for several years and I'm hoping to eek out another year or two.

I'll let you know if this works. Thanks again.

eschurig
2009-02-24, 00:27
I installed mplayer and AlienBBC as suggested. The installation seems to have affected both softsqueeze and my hardware player (squeezebox3). My hardware player can now play our local Dallas PBS radio station KERA 90.1. Previously this did not work unless I went through the Squeeze Network menu. It can also still play all of the other local Dallas radio stations provided in the internet radio menu.

Softsqueeze can also play KERA 90.1 now. Softsqueeze still cannot play any of the other local radio stations provided in the internet radio menu. However, I no longer get the error message "Problem: Unable to play file for: Stream". It now appears to think the stream is ok but no sound comes out. One observation is that I don't see the word connecting flash once as the stream is trying to connect. Something is still not quite right.

bpa
2009-02-24, 01:39
Did you install mplayer ?

AlienBBC should not have affected SB3 players unless you are trying to play a RealAudio stream. You should have been able to play the Kera WMA stream on your SB3 without AlienBBC so there may be some other issue in you system setup. Confusingly Kera labels the RealAudio stream as a MP3 stream so that may have been the original problem.

For some users, Softsqueeze is a bit unreliable and I believe sometimes "play" needs to be pressed twice or play/pause/play.

eschurig
2009-02-24, 10:13
Yes, I installed softsqueeze version 1:1.0-relsvn20070225-0.3etch1. With a version number like that, how could it not work! I can't explain why kera started working on my SB3 after the installation. I tried it several times before and it failed. Originally it did work fine but only over Squeeze Network. When it was failing on the SB3, it seemed to have trouble transitioning from the station introduction to actually playing the stream. Now I notice that there is no station introduction that gets played, it just goes right to the main stream. Could the AlienBBC intstallation help with this somehow?

I played around with the full list of local internet radio stations last night. All of the ones that worked were mp3 or a .m3u file. The troublesome stations were all listed as wma. The server seems to think it has connected with the station. Even softsqueeze seems somewhat fooled because there is no longer an error message and the timer is incrementing as if something is playing. Out of many tries and a number of stations, I did get one station to play that was listed as a wma. When I tried the same station later it wouldn't work again. This morning I can't get KERA to play through softsqueeze and it worked fine last night. All still works on my SB3.

I've never had trouble with softsqueeze before but I really only used it for playing from my local music library. I wonder if it is a timing issue and maybe my old machine is a little to slow. The cpu utilization looks fine but memory is tight. I'm still hoping there is a software issue that can be resolved. Does the extension plugin or AlienBBC have any version requirements for linux packages?

Softsqueeze works so well with my local libraries. Upgrading to Squeezecenter 7.3.2 motivated me to learn some new tricks with this toy. I connected with my University radio station this week that I haven't heard in 25 years. The internet radio stuff is fun and it would be nice if softsqueeze could play it too. Thanks for any help you can give.

mkeene08
2009-03-16, 18:19
I am having the same problem playing WMA streams in softsqueeze. I am running both squeezecenter and softsqueeze in Windows, but will not play a lot of internet radio stations. When connected (in softsqueeze) to my computer, it appears as if it thinks it's playing (switches to station, begins timer, etc) but no sound comes out. When connected to squeezenetwork on the other hand, it gives the error originally defined: "Problem: Unable to play file type for: Stream"

Anybody have a fix.

Thanks a lot, Matt

bpa
2009-03-16, 18:33
There is a bug in Softsqueeze particularly when runnging 7.3 and higher.

Until the fix is in new builds - a workaround is to change some setting in SqueezeCenter


1. Install lame.exe if you have not got it installed and then reboot SC
2. Under WebUI Settings/Advanced/FileTypes - disable Windows Media->Flac and Windows Media->WAV. Windows Media->MP3 should be enabled (probably using wmadec/lame).
3. Try a WMA station again using Softsqueeze.

mkeene08
2009-03-16, 19:36
Thanks for the quick answer. I've downloaded lame, but have no idea where I'm supposed to copy it to for squeezecenter to see it. I have the lame folder in my desktop at the moment but squeezecenter still says it's not installed. How do I actually "install" it?

Thanks, Matt

mkeene08
2009-03-16, 21:41
Nevermind, I got lame installed and your workaround worked!

Thanks again :)