PDA

View Full Version : SlimServer and MoodLogic



Edward Martinbor
2004-05-04, 14:51
I am having a weird problem. I will have to explain the whole process. I have a Windows XP machine with SlimServer 5.1.5 installed along with MoodLogic 2.7. However when I reboot, SlimServer will not start and gives me an error



Canít use an undefined value as a HASH reference at PerlApp/Slim/Music/MoodLogic.pm line 198



However if I uninstall MoodLogic everything works fine.



I then installed the latest version 5.1.6 and with MoodLogic. It worked fine. However when I rebooted the machine, SlimServer starts without any errors but when playing a song, it skips from 0.32 secs to 1:15 seconds to 2:13 but does not play. If I uninstall MoodLogic and restart the SlimServer Service, it plays fine.



I am using SoftSqueeze 0.4 for my player and my music files in WMA



Thanks



Edward

kdf
2004-05-04, 14:58
Quoting Edward Martinbor <edward (AT) Intraplus (DOT) net>:

> I am having a weird problem. I will have to explain the whole process. I
> have a Windows XP machine with SlimServer 5.1.5 installed along with
> MoodLogic 2.7. However when I reboot, SlimServer will not start and gives me
> an error
>
>
>
> Canít use an undefined value as a HASH reference at
> PerlApp/Slim/Music/MoodLogic.pm line 198

that looks like the result of bad information from a song file.

> However if I uninstall MoodLogic everything works fine.
>
you shoudln't have to uninstall, turning off 'use moodlogic' in server settings
should bypass any link with moodlogic.

> I then installed the latest version 5.1.6 and with MoodLogic. It worked
> fine. However when I rebooted the machine, SlimServer starts without any
> errors but when playing a song, it skips from 0.32 secs to 1:15 seconds to
> 2:13 but does not play. If I uninstall MoodLogic and restart the SlimServer
> Service, it plays fine.

> I am using SoftSqueeze 0.4 for my player and my music files in WMA

I wasn't aware moodlogic handled WMA, but I suppose that makes sense. The
moodlogic module in slimserver, however, is hardcoded to use MP3. This would
certainly explain why it wont play AND why you might get bad information about a
song file.


-kdf