PDA

View Full Version : Problem with playing AAC on Slimp3



Tourne
2009-02-07, 08:14
I have an early Slimp3 which has worked fine for years, but which now seems to be having problems playing AAC files. The tracks appears in the squeezecenter library, but when they are selected, I get a brief message saying something like "unable to play this file type". I haven't noticed this before and the wiki says that this model should play AAC. Anyone know what is going on?

Mark Lanctot
2009-02-07, 12:42
It plays AAC using transcoding to MP3, and this is done in the server software.

So, what version of SlimServer/SqueezeCenter do you have? What OS? Windows uses QuickTime, so you may want to update QuickTime.

fluffhead
2009-10-17, 07:50
I am now having this problem. I had it working on windows vista 32 bit a long time ago using the Lame encoder. and I cant get it to work on my new computer using vista 64 using either slimserver 6.5.2 or squeezebox server 7.4.

6.5.2 uses mov123.exe to decode mov,aac,mp4 amd m4a. I read somewhere that the latest version of itunes disables it. with 6.5.2 I get a windows message that mov123.exe crashed

7.4 uses FAAD2 to decode. and my suspician is that it just doesnt work under Vista64


I put the Lame files in the right directory. any help would be appreciated

bpa
2009-10-17, 08:16
In 7.4.0 there is a bug in convert.conf for AAC->MP3 (the $BITRATE$ is missing the trailing dollar sign). Either edit the conf file and restart or better still upgrade to 7.4.1

fluffhead
2009-10-17, 17:12
thanks, I edited the convert.conf file in 7.4. At first it did not work. It turns out I had both lame.exe and lame-enc.dll in the Squeezebox\server\Bin\MSWin32-x86-multi-thread\ directory. I removed the dll file and it now works beautifully. The slimp3 lives on. Thanks again

WOTNOH88
2009-10-20, 10:19
Hello,

I have this issue as well. I have version 7.4.1 of the server running on Mac OS X. Even after the upgrade to 7.4.1, the player displays a message stating it cannot play that type of file. Log entries in the Console state something to the effect of not being able to create a CLI for the file type (AAC, WMA, etc.). I cannot remember the wording of the messages, but that's the gist of them.

I appreciate any suggestions!

bpa
2009-10-20, 12:27
The previous bug was ONLY associated with AAC/MP4 - if you have similar problem with WMA - then I think your installation of lame is faulty.

Arfe the AAC->MP3 and WMA->MP3 settings enabled in WebUI Settings/Advanced/Filetypes

WOTNOH88
2009-10-21, 11:51
That was it -- I thought LAME was installed, but it wasn't. I installed it and it works now.

Thanks!