PDA

View Full Version : Please help SC does not start



sjansen
2009-01-21, 15:16
Hi All, please help me out!
I can get SC to run but I allways have to do it manually by pressing on start under SOTTS several times. It never starts automatically - yes, autostart is on..

I am using SSOTS on a QNAP 209 pro (Linux). The post of the logfile is below. Thanks for your help, I am very disappointed that it does not work as I want it to - the reason I bought that NAS was to use squeezecenter auto-starting when switching on the server..

[09-01-20 23:12:53 ] ssctrl Error while stopping SqueezeCenter.
[09-01-21 19:15:36 ] ssctrl Starting SqueezeCenter 7.3.1-24372.
[09-01-21 19:15:48 ] ssctrl Command line = /volume1/SSODS/sbin/start-stop-daemon --start --chuid ssods --nicelevel -5 --exec /volume1/SSODS/bin/perl -- /volume1/SqueezeCenter/slimserver.pl --daemon --pidfile /volume1/SqueezeCenter/Cache/squeezecenter.pid --cachedir /volume1/SqueezeCenter/Cache --logdir /volume1/SqueezeCenter/Logs --prefsdir /volume1/SqueezeCenter/prefs --noupnp --httpport 9001
[09-01-21 19:16:29 ] ssctrl failed to start SqueezeCenter.
[09-01-21 19:16:47 ] ssctrl Starting SqueezeCenter 7.3.1-24372.
[09-01-21 19:16:48 ] ssctrl Command line = /volume1/SSODS/sbin/start-stop-daemon --start --chuid ssods --nicelevel -5 --exec /volume1/SSODS/bin/perl -- /volume1/SqueezeCenter/slimserver.pl --daemon --pidfile /volume1/SqueezeCenter/Cache/squeezecenter.pid --cachedir /volume1/SqueezeCenter/Cache --logdir /volume1/SqueezeCenter/Logs --prefsdir /volume1/SqueezeCenter/prefs --noupnp --httpport 9001
[09-01-21 19:17:26 ] ssctrl failed to start SqueezeCenter.
[09-01-21 19:20:18 ] ssctrl Starting SqueezeCenter 7.3.1-24372.
[09-01-21 19:20:22 ] ssctrl Command line = /volume1/SSODS/sbin/start-stop-daemon --start --chuid ssods --nicelevel -5 --exec /volume1/SSODS/bin/perl -- /volume1/SqueezeCenter/slimserver.pl --daemon --pidfile /volume1/SqueezeCenter/Cache/squeezecenter.pid --cachedir /volume1/SqueezeCenter/Cache --logdir /volume1/SqueezeCenter/Logs --prefsdir /volume1/SqueezeCenter/prefs --noupnp --httpport 9001
[09-01-21 19:20:53 ] ssctrl failed to start SqueezeCenter.
[09-01-21 19:23:02 ] ssctrl Starting SqueezeCenter 7.3.1-24372.
[09-01-21 19:23:03 ] ssctrl Command line = /volume1/SSODS/sbin/start-stop-daemon --start --chuid ssods --nicelevel -5 --exec /volume1/SSODS/bin/perl -- /volume1/SqueezeCenter/slimserver.pl --daemon --pidfile /volume1/SqueezeCenter/Cache/squeezecenter.pid --cachedir /volume1/SqueezeCenter/Cache --logdir /volume1/SqueezeCenter/Logs --prefsdir /volume1/SqueezeCenter/prefs --noupnp --httpport 9001
[09-01-21 19:23:30 ] ssctrl SqueezeCenter started.
mDNSResponderPosix: Error reading service file /volume1/SqueezeCenter/Cache/mDNS.conf

Stephan

kluris
2009-02-16, 03:46
Same problem with more or less the same configuration.
Anyone out there that have any suggestions, please?

rossi
2009-02-19, 02:44
Same here also with QNAP209!

It worked all the time well since I updated to a newer nightly of 7.3.3.
Going back didnīt change to the better. :-(

P.S. Oh, I also changed to the "new" QNAP firmware. Maybe here is a problem.

rossi
2009-02-19, 08:24
Hi, me again.

Today I had time to downgrade the firmware from 2.1.2 to 2.1.0 and that did the trick. At least went everything well again after the downgrade.

Link: http://www.qnap.com/download_detail.asp?pl=1&p_mn=TS-209%20Pro%20II&ct_name=Firmware

The only issue was, that I had to reinstall SSOTS again because I couldnīt reach it anymore by web interface.

Hope that will help both of you as well.

sjansen
2009-02-23, 07:07
Hi Rossi,

thanks you very much for responding. I will try and let everybody know if it solves the problem. QNAP should also know so that they can fix it.

Best,
Stephan

sjansen
2009-02-23, 08:58
Hi Rossi and All,

yes, that does the trick. Thanks, you are great!

I installed 2.1.0 and all works fine now.

Thanks again! Best,
Stephan

rossi
2009-02-24, 00:25
Hi Stephan,

Nice to hear that I could help you. That is not often the case, when I post in a forum. Most of the time I ask silly questions. :-)

I think itīs not the right way to downgrade the firmware of the server. It would to be better to inform flipflip to change the SSOTS so that new bought ONAPs with 2.1.2 on it will also work. I think that will be very frustrating for anybody, who is buying a QNAP and it wonīt work for unknown reasons.

cheers,

rossi

P.S. FlipFlip, the maker of SSOTS is informed by PM.

flipflip
2009-02-24, 01:58
Hmm.. strange.. I cannot tell what is going wrong. The log in the first post does not show anything. You could try to start it from the command line:

ssctrl start

And if that doesn't show anything:

/volume1/SSODS/bin/perl /volume1/SqueezeCenter/slimserver.pl --daemon --pidfile /volume1/SqueezeCenter/Cache/squeezecenter.pid --cachedir /volume1/SqueezeCenter/Cache --logdir /volume1/SqueezeCenter/Logs --prefsdir /volume1/SqueezeCenter/prefs --noupnp --httpport 9001

If that doesn't show anything, add debug flags (there's a help on this in /volume1/SSODS/etc/ssods/ssods.conf). Not sure which flags would help.. Just try.

Actually, a new firmware _should_not_ break anything. However, please note that SSODS was built at a particular point in time with the firmware available then. While lots of effort has gone into making it independent from the firmware, there's _NO_WAY_ that SSODS will continue to work forever. Hence the official SSODS slogan: _DO_NOT_UPGRADE_THOSE_BLOODY_FIRMWARES_IF_YOU_WANT _SSODS_.

In this case here, however, I think you should be able to get it running. The binaries seem okay. Else not even the start script or the SSODS http interface would work. Enable debugging to see what's wrong. I cannot help you with this. I don't have a QNAP to test right now.

rossi
2009-02-24, 07:07
In this case here, however, I think you should be able to get it running. The binaries seem okay. Else not even the start script or the SSODS http interface would work. Enable debugging to see what's wrong. I cannot help you with this. I don't have a QNAP to test right now.

Thanks FlipFlip for answering so fast.

For my taste itīs a little too deep in the depth of that black wonder box (speaking in "Catweazle"), to have a motivation to brake a again running system with my silliness.

Maybe the others involved are smarter in computer things than me.

The only thing I can say is, that in my case my web access to SSOTS was broken and I had to reinstall it over the QNAPs OPKG. Then it worked fine again. The problem was, that I downgraded firmware and reinstalled SSOTS at the same time. So I can not say, what solved the problem for sure.

Maybe it would help to upgrade the firmware again and reinstall SSOTS again and see, whatīs hapening.

By the way: Programming SSOTS without having a QNAP is for me almost the same like Beethovens composing being deaf. A work of a true genius. Why is it so slipery over here? :-)

sjansen
2009-02-25, 14:03
Hi flipflip and rossi,

great you guys were available to help, thanks for that.
I looked many times in the log file and the only thing that was there in addition to what I had posted before was something like "crashed with PID 915" and I am not sure of the number anymore. Just like rossi I really do not want to return to the version that does not work. Actually I am not very knoledgable when it comes to linux and working on the command line and debugging would not be easy for me - sorry. I am actually proud I managed to get the QNAP running with all I did so far.

I think QNAP should give you a test system since they promote their system with SSODS and should have an interest in compatible firmwar - it was the reason I bought their system and I had planned to buy also the duett but now I am not sure I will. I also posted my problelm dirctly to them and never got any response...

flipflip, if it is important to you, I would try to fiddle around with the debugging but for me, right now, the problem is solved. By the way, I did not have to reinstall anything after downgrading. All my settings in SSODS and squeezecenter were as before.

Thanks again guys. Best,
Stephan