PDA

View Full Version : Alien BBC - fails on Slimp3



BigG123
2009-01-18, 07:21
I upgraded to the latest version of Squeeze Centre yesterday and the latest version of Alien BBC.

I can listen to live and listen again streams fine thru my Squeezebox and SoftSqueeze, but on my Slimp3 no joy. On the Slimp3 it seems to connect and the time starts counting, but no sound. If I go through to the properties on the slim it is saying that it is converting to a 320kbps mp3 stream.

The conversion to Mp3 from Flac works fine on the Slimp3, so with that I'm assuming that lame is ok,

Any thoughts advice would be welcome,

Thanks in advance,

Gordon

bpa
2009-01-18, 09:20
What version of SC ?
What version of AlienBBC ?

Perhaps there is a difference in the setting for lame. Compare the lame settings for Flc->MP3 setting in convert.conf against the RTSP->MP3 setting in Alien/custom-convert.conf

Triode
2009-01-18, 09:22
Suggest you set bitrate limiting for your squeezebox to force the use of lame and try that - does it have the same problem?

BigG123
2009-01-18, 11:05
Thankyou both,

I'm using the latest public release:
- Version: 7.3.1 - 24372 @ Fri Dec 19 17:56:44 PST 2008
- Alien BBC (v2.4a4-7.3)
- This is running on Windows (2k3 Server SP2)


I've just tried bitrate limiting on the Squeezebox, same problem as the Slimp3.

However, having had a look at suggested at the custom-convert.conf file and after a bit of fiddling the following solves the problem:
edit the lame part of the mp3 line to the following:
[lame] --silent -r -x -q $QUALITY$ $RESAMPLE$ -v $BITRATE$ - -

This solves the problem for both the Slimp3 and the bitrate limiting on the squeezebox.

Thanks again for the pointers,

G

ashimmin
2009-04-03, 14:48
Help me here. I have the same Alien BBC problem with a Slimp3 but I don't seem to be able to fix it as you suggest. I'm running:

Version: 7.3.2 - 24695 @ Mon Jan 19 18:55:04 PST 2009

on WinXP

I've created this custom-convert.conf in "Program Files\SqueezeCenter\server"

flc mp3 * *
# FB:{BITRATE=-B %B}T:{START=--skip=%t}U:{END=--until=%v}D:{RESAMPLE=--resample %D}
[flac] -dcs $START$ $END$ -- $FILE$ | [lame] --silent -r -x -q $QUALITY$ $RESAMPLE$ -v $BITRATE$ -



This should work, right? What have I done wrong?

Thanks

Alice

bpa
2009-04-03, 15:02
If you are hearing static - then it is a lame version problem.

Go back to original conf file.

Determine what version of lame you are running and add/remove "-x" according to whether you are running 3.96.1 or later.

ashimmin
2009-04-03, 15:29
I'm runing lame version 3.97.

I get silence.

What do you mean by go back to the original conf file? Are you suggesting editing that and not using a custom-convert.conf? I tried a custom-convert.conf both with and without the -x and it made no difference. Still silence.

Thanks for the quick response

I've uploaded a debug log of what happens when I stream. I guess this will make more sense to you than me ;)

Alice

LAME 32bits version 3.97 (http://www.mp3dev.org/)

usage: lame [options] <infile> [outfile]

<infile> and/or <outfile> can be "-", which means stdin/stdout.

RECOMMENDED:
lame -V2 input.wav output.mp3

OPTIONS:
Input options:
-r input is raw pcm
-x force byte-swapping of input

bpa
2009-04-03, 15:44
It wasn't clear whether you edited the Alien custom-convert.conf file or created your own and since you didn't say what was heard "silence" and "static" are symptoms for two different problems. The advice below is based on the fact you are on Windows and doing bit rate limiting.

First the "flc mp3" will do nothing for AlienBBC which uses RTSP.

Second, bit rate limiting on transcoded streams does not work on Windows. It works on Linux and OSX systems.

So you cannot use bit rate limiting to change the mp3 so you will need to modify the RTSP behaviour when transcoding to MP3 which is the "RTSP MP3 * *" entry in Alien custom-convert.conf.

This will affect all players using RTSP->MP3. I think you can use the "* *" to limit to say SlimP3 players.

ashimmin
2009-04-03, 15:58
Sorry, I'm getting pretty confused now. I was looking for the Alien plugin but of course everything has moved now. I was making a custom-convert.conf in SqueezeCenter\server. I from the log (attached) that the Alien plugin is over in \Documents and Settings\All Users\Application Data\SqueezeCenter\Cache\InstalledPlugins\Plugins\ Alien

should I be editing the custom-convert.conf in this Alien location and if so how should I edit it. It already seems to have the -r and -x options. File also attached.

Thanks

Alice

bpa
2009-04-03, 16:21
A clean unmodified AlienBBC installation with no bit rate limiting should work with SliMP3. Try that first before doing anything mods or changes.

If it plays silence (not static) - then get a log with player.source set to INFO of trying to play a live stream.

ashimmin
2009-04-03, 16:28
A clean install with no bitrate limiting is what I have.

Attached is the requested log file.

I am getting silence and not static.

Thanks

Alice

PS The log attachment in my the previous post might also useful.

bpa
2009-04-03, 16:42
09-04-04 00:24:52.6326] Slim::Player::Source::_readNextChunk (499) end of file or error on socket, song pos: 0

This error message usually means mplayer, socketwrapper or lame is not working.

Socketwrappper can be stopped by security/AV software. Do you have security s/w installed ?

Can you check the following;
1. Does mplayer installation test work OK ?
2. If 1 works then can you play AlienBBC on Softsqueeze ?
3. If 2 is OK - then disable Filetypes RTSP->WAV and RTSP->Flac and trying playing AlienBBC on Softsqueeze.

ashimmin
2009-04-03, 16:49
1. Mplayer test works OK
2. Softsqueeze playing works OK. So does Squeezebox

How do I do what you suggest in 3?

I'm running AVG 8.5

Thanks

Alice

bpa
2009-04-03, 16:54
Since case 2 Softsqueeze works OK then mplayer, socketwrapper and flac are working. NO need to worry about security s/w

To test 3.
* Open WebUI Settings/Advanced/Filetypes.
* There are 3 RTSP entries with dropdown boxes. Set the Flac and WAV entries to disabled and you should be left with just MP3 enabled (with mplayer/lame).

This will force AlienBBC to play using MP3 on all players - including Softsqueeze.

ashimmin
2009-04-03, 17:08
Ok, disabled the RTSP->WAV and RTSP->FLAC.

Plays OK in Softsqueeze

Still plays sliently in Slimp3.

Attached is the log file. The first play is for the Slimp3 and the second is for Softsqueeze.

Thanks

Alice

bpa
2009-04-03, 17:32
The log shows that there is something about the settings SC has used when streaming to SlimMP3. The SoftSuqeeze test shopws the basic command settings are correct.

At the moment I can only suggest two things to try.

1. Edit the custom-convert.conf file in Plugins/Alien and change the RTSP->MP3 entry to reduce speed of audio stream.
by changing $BITRATE$ to 64 for 64kbps.

[mplayer.sh] -really-quiet -vc null -vo null -bandwidth 10000000 -cache 128 -af volume=0,resample=44100:0:1,channels=2 -ao pcm:nowaveheader:file=/dev/fd/3 $FILE$ | [lame] --silent -r -x -q $QUALITY$ -b 64 - -

2. Try increasing the Radio Station Timeout to 20 in Settings/Advanced/Network

After changing the custom-convert.conf you will need to restart SC.

ashimmin
2009-04-03, 17:47
Changing the station timeout made no difference.

Changing the bitrate to 64K however did work. The Slimp3 now shows 'buffering xx%' and when it fills plays the station.

What does this tell us? Does this point us towards a better solution?

Thanks

Alice

bpa
2009-04-04, 01:53
What does this tell us? Does this point us towards a better solution?

Not sure except SlimMP3 is treated special.

In the logs there is a buffer threshold is shown to be 65535. I odn't have a SlimMP3 but I have tried using a bufferThreshold routine) to get buffer this low and I cannot.

There are two possibilities.

1. AlienBBC timing has too long a startup for SlIMP3
2. The 65535 threshold is somehow blocking with flow control in the mplayer-lame chain. Perhaps socketwrapper is dying or killing off the chain (it does that if no data movement).

This could be tested if you run SC from a command prompt window and player.source set to DEBUG - this will generate and show message from socketwrapper.

Otherwise I think only a developer with slimp3 can investigate further. I think user awy might be one to ask as he also was responsible for the buffer threshold stuff. The issues is probably no noticed on non Windows platforms since bit rate limiting works and/or no socketwrapper.

ashimmin
2009-04-04, 02:06
Ok, thanks a million for all your help. Was great to have such instant responses and things to try.

I will try the startup from the command line. I just open a command window in the SC root directory and then run the .exe? I don't need any command line parameters? I then just set the debug level and the socketwrapper debug will come in the command line window or will it get written to the log file that I can get via the web interface?

bpa
2009-04-04, 02:36
I think you will need to change directory to the SC "server" first and then run squeezecenter.exe

Make sure you change the command window size (use menu from icon in top left hand corner of command window) to something like 300 wide and 3000 long - that way you will save a lot of message.

ovonrein
2009-04-16, 14:30
I fortunately just stumbled over this thread after very nearly tearing out all my remaining hairs when my old Squeezebox V1 suddenly ceased to play BBC stations after I upgraded SC (V3 and SoftSqueeze were just fine).

I can confirm that nothing other than modifying custom-convert.conf will actually work (and what a sweet place to hide that file (sic)).

Has this been reported to Slim as a bug? For it appears to me that $BITRATE$ is a token that should be replaced with whatever I configure in my bitrate limiting? I know that others in this thread *did not* set bitrate limiting. However, in my experience, this is required for anything pre-Squeezebox V2: my V1 never played the BBC "out of the box" - I always needed to throttle. Therefore, the player config for my V1 had throttling set to 128.

From this thread, it seems to me that this setting is not correctly substituted for $BITRATE$...

Gingermagic
2009-07-04, 01:05
Changing the bitrate on my helped to make AlienBBC work on my SlimP3, but now normal music on my system (MP3's) struggle to play properly. They pause regularly (usually once or twice within a song) and have to re buffer themselves to catch up.

Could someone tell me what the line used to be so that I can see if changing it back fixes this issue. Does anyone know what else this could be? Is there a way to get both normal system music and AlienBBC working on an ols SliMP3 player or is it being ignored as being too old these days?

Don't see why it should be. All used to be fine before recent updates.

OS is Ubuntu 9.04 if that helps.

Cheers
Damian

bpa
2009-07-04, 01:25
If you only changes the line RTSP MP3 - it will only afect RTSP formats and not any other format MP3 - so yor MP3 problem is coincidental and unrelated.

You should check whether you made other changes to your system and not just the RTSP one.

You can disable a plugin from settings and rebbot to easily "undo" the RTSP change for testing.

Gingermagic
2009-07-04, 02:45
Thanks for that.

I restored the original file (noticed that I made a backup before changes) and the MP3 pausing is still there. I'd better start another thread for that.

Thanks again
Damian