PDA

View Full Version : SB1 Not updating firmware



egizzi
2008-12-14, 17:10
Hi- I just bought a used wired SB1 at a garage sale, looks great, basically unused. I'm running squeezecenter 7.3.

It connects fine (sees the server, gets the right addresses, etc.). Then the problem begins:

1) It asks for firmware update
2) I hold down brightness for a few seconds
3) It jumpts to the "Now Playing" screen and is frozen. It never enters the screen where the firmware updates
4) Then I unplug it and start over. Same thing.

Ideas?

Thanks

JJZolx
2008-12-14, 17:20
Kinda surprising, as the SB1 firmware hasn't been updated in years. Must be a really old Squeezebox that either hasn't been used recently, or was running with a very old version of Slim Server.

Can't imagine too many people who are still alive have seen an SB1 take a firmware update from any recent versions of SqueezeCenter, so this may be the first time it's even been attempted.

You might try installing an old version of the server, something like Slim Server 5.4 maybe, just to do the firmware update. If it works, then move to the latest and greatest. I seem to recall someone posting a link to a page with archived versions, but can't find it right now.

egizzi
2008-12-14, 17:37
Found 5.4 here:

http://www.slimdevices.com/downloads/SlimServer_v5.4.0/SlimServer_v5.4.0.dmg

Installed it

It updated firmware fine

Re-installed 7.3

It works fine.

Thanks!

Goodsounds
2008-12-14, 17:40
How did you determine it was "basically unused"?

egizzi
2008-12-14, 17:42
Still in original box, remote in plastic bag, ethernet cable still with wire-ties, no scuffs, etc. Owner said they won it at some event a few years ago and never used it.

Mark Lanctot
2008-12-15, 12:50
Just out of curiosity, how much did you pay for it? :-)

egizzi
2008-12-15, 21:36
$40

Seemed like a fair price

Mark Lanctot
2008-12-16, 06:39
Sure does, I'd jump at that - especially considering it was mint condition.