PDA

View Full Version : SC "breaks" albums into pieces



olc
2008-12-03, 19:58
I have a recurring problem in that SC frequently creates two (or sometimes even more) albums. I have checked the tags with MP3Tag and there is nothing there that would explain creating two entries in the album list. I have tried rescanning for new info and complete rescans to no avail.

What causes this/ More important, how do I fix it?

MeSue
2008-12-03, 20:40
Are the files all in one folder?

When you checked with MP3tag, did you check for multiple tag formats? This can cause problems for SC, and I think by default Mp3Tag only shows you one tag format at a time. See #6 at http://wiki.slimdevices.com/index.php/Mp3tagGuide

olc
2008-12-03, 23:26
Are the files all in one folder?

When you checked with MP3tag, did you check for multiple tag formats? This can cause problems for SC, and I think by default Mp3Tag only shows you one tag format at a time. See #6 at http://wiki.slimdevices.com/index.php/Mp3tagGuide

Yes each album has its own file folder and all files are flac format. Most of the tags come from freedb using MP3Tag, and then I check the tags for consistency.

AndyWright
2008-12-04, 08:28
Do you use replaygain? I had the same problem on a couple of albums and it turned out some of the tracks were tagged with different album-gain figures.

olc
2008-12-04, 11:05
Do you use replaygain? I had the same problem on a couple of albums and it turned out some of the tracks were tagged with different album-gain figures.

I don't adjust replay gain or otherwise alter the files.

MrSinatra
2008-12-04, 22:08
i'd guess the issue is in your files.

i assume you've done full clear and rescans.

if it continues post a bug and upload files to recreate the issue so they can verify the bug or identify the issue in your files.

tipsen
2008-12-05, 14:02
I've experienced the same with SC7.2.1 running from my Synolog DS-207+ - I have some albums with 2 or more CDs and whether or not they are indexed as one album seems pretty random! I've tried several full rescans (pretty time consuming) and I've had the albums span 1, 2 and 3 albums... - no changes to the files in between! It seems like you have to do a full rescan while crossing your fingers... The files are also FLAC files and all the tags seems to be ok when I check in MediaMonkey.
/tipsen

olc
2008-12-05, 21:08
I've experienced the same with SC7.2.1 running from my Synolog DS-207+ - I have some albums with 2 or more CDs and whether or not they are indexed as one album seems pretty random! I've tried several full rescans (pretty time consuming) and I've had the albums span 1, 2 and 3 albums... - no changes to the files in between! It seems like you have to do a full rescan while crossing your fingers... The files are also FLAC files and all the tags seems to be ok when I check in MediaMonkey.
/tipsen

Thanks but been there, done that. It isn't that there are multiple CDs that don't get merged. It is splitting a single CD into more than one album.

tipsen
2009-01-13, 07:19
Thanks but been there, done that. It isn't that there are multiple CDs that don't get merged. It is splitting a single CD into more than one album.
Still thinks it's the same problem - even though I'm experiencing the problem with multiple CD's it's still splitting the same CD in several bits!

Phil Leigh
2009-01-13, 08:02
Still thinks it's the same problem - even though I'm experiencing the problem with multiple CD's it's still splitting the same CD in several bits!

I've had this in the past and it has turned out to be (always) a problem with the tags...even if you can't see the problem. The 100% way of fixing is to use FLAC frontend to remove ALL tags and then use MP3Tag to put fresh new tags in. This has always fixed the problem for me.