PDA

View Full Version : Pausing Internet Radio



skiemele
2008-12-01, 15:21
I paused a radio station this morning (at about 9:45) by pressing the button on the front of a receiver. A couple of hours later, I restarted the playback by pressing the button again. I soon heard the time reported on the station as 9:50 am - when it was actually about 1 pm.

Where was the radio stream being buffered? I expected to begin hearing the radio station broadcast in (approximately) real time.

andyg
2008-12-01, 15:28
Generally, don't pause a radio station if you intend to pause it for more than a couple of minutes. If you unpause and the connection is still open, you'll hear the rest of the buffered content (3 minutes for 128k) before getting the live content. The behavior while paused depends on how the station handles idle connections. Most will just drop the connection.

Mark Miksis
2008-12-01, 15:35
This is why we need a real mute button :-)

BastiaanR
2009-05-19, 07:10
I noticed the opposite: Two evenings ago I paused a Internet radio station, to watch some TV, and about 20 minutes later it started (unpaused) on its own.

SC 7.3.3
Receiver fw: 60
Controller fw: r5577

I'll keep an eye on this to see if it happens again. If it does, I'll also test if it happens when connected to SqueezeCenter.

AVF_Chef
2009-07-13, 00:04
I'll bump this thread and have to agree to what BastiaanR wrote. Pausing Internet radio fails as it often restarts playing after some time passed. Sometimes it is only a couple of minutes, but it may also be after quite some time. I have noticed this problem for several versions of SC and have resently upgraded to SC 7.3.3 and changed from a NAS (QNAP) to a Windows environment. The problem is still present.

I have put one Duet in our dining room, mostly used to stream a local radio station as we have our breakfast. As the connected amplifier is hidden, we normally use the pause to stop the radio playing, but almost every night the radiostream starts up. U might say its practically to have the radio ready running as we rise in the morning, but it is a bit confusing if the television is already on and then radio starts playing at the same time, competing to get attention.

But also the quite opposite happens. We cansel the pause, the radio reconnect and start streaming, then approx 10 seconds after, it re-pauses. If we then cansel the pause again it will continue playing as normal. This happens about one out of ten times.

Our system at home is now running with 2 Duet packages and one additonal Reciver (total of tree players) and is/was planning one extra Reciever (playing the same (linked) as the dining room unit) to use as a player for our outdoor areas. But i would guess our neighbours would dislike to have 4 outdoor speakers howling at them quite suddenly at the dark of the night ;-)

f948lan
2009-07-13, 02:29
While I agree the behaviour described is wrong, why not just power off the player rather than pausing it?

I have never had the described 'un-pausing' problems from my powered off players, whether they are set to pause or stop on power off. If you configure them to pause on power off, and resume on power on, it will still behave the same way as a pause for music, by remembering its position in the track.

If you wish to make this easy for users, try the PowerSave plugin. That way the player can be made to automatically power off 15 minutes after pressing pause. For my duet, this also has the benefit of powering off the amp too.

Regards,
Graham

AVF_Chef
2009-07-13, 02:45
Reason for not powering down is simply WAF. My wife can handle the pause hard-button on the Controller, but messing about in the menu's just for powering down is NOT her option. And I agree: Powering down consequently also gives a slower startup instead of "instant on" when canceling the pause.

AVF_Chef
2009-07-13, 04:02
Thinking about it, this should probably be posted in the SqueezeCenter forum (or a duplicate tread):

Pause problem for internet radio, workaround? :

One solution: When SqeezeCenter detects pause is operated for one unit and is streaming radio, instead of pausing the stream: Mute the sound. Cansel the pause will return the volume to last used before mute. If volume control "+" is operated, the volume will turn upwards step by step from from zero/mute.

Another solution: "Press and hold" Pause will mute sound (general option) all playback modes.

f948lan
2009-07-13, 17:26
I just remembered reading this in the nightly release notes. Sounds likes it's fixed in 7.4 (which personally I'm avoiding until it supports MySQL too):

http://bugs.slimdevices.com/show_bug.cgi?id=9351

As a short term workaround if 7.4beta isn't for you yet, the WAF factor is why I recommended the PowerSave plugin - users can just pause the player as normal, but it will automatically power off after 15 mins (or whatever you set) on pause. No menu nav needed.

However reading the bug description you might need to set the player to Stop on Power Off, not just pause, as otherwise the unpause bug could potentially turn it back on!

As far as delay powering back up goes, for my duet it is almost instantaneous. The only delay is reconnecting to the internet radio stream, which would be necessary after a pause that long anyway - it just might not appear so on pause as SC will play a few minutes of buffer from the position the stream was in earlier before jumping to the 'real time'(ish) stream - this is something else that is now fixed. This should only take a few seconds, during which there is full feedback on the controller of what is happening, which should serve to pacify the impatient listener.

Hope this helps.

AVF_Chef
2009-07-13, 23:44
Thanks f948lan!

The bug-link looks much like what we experience at home, så I might just download the 7.4beta version later today.

Dogberry2
2009-07-15, 12:53
If I'm playing an Internet stream, I don't use pause, I use stop instead. (Press and hold the pause button.) I haven't investigated to see what this does internally, but it works okay, so my assumption has always been that it just drops the stream. If I want to keep the stream running but mute the music, I use the mute function (press volume up and down simultaneously). This also works well.