PDA

View Full Version : SN finds SB2, SC doesn't



rocket j squirrel
2008-11-30, 11:23
I recently moved to a new house, set up new wireless routers, finally unpacked my SB2 and reset it so it could connect to the network. It needed a firmware update, which I installed, and I installed SC.

SN was initially unable to see the SB, but I plugged in the SB2's PIN into SN* and it found the SB and my favorites, etc. Works fine, I can operate the SB through SN.

SC cannot find the player, though. I have the SC service running. SC reports "Your player was not found."

So: SN can see the player and SC cannot -- what do I need to do so SC sees the player?

WinXP, SC v 7.2.1.

==========
* Don't know why this step was needed, neither the SS computer nor the SB were changed.

Mark Lanctot
2008-12-01, 12:09
I presume, of course, that the firewall configuration was not changed?

Also another obvious thing - you're not trying to connect to SC while you're on SN, are you?

Sorry if that's being overly obvious, but it is worth checking.

Go back through network setup - hold left for 5 seconds or more. Just skip over the wireless settings, they're obviously working, as well as the IP, DNS and gateway settings (press FF to skip through these). But take a good look at the music source setting. Is the SB picking up your server? Can it see it or do you have to specify an IP address for the server? And what happens after that, does it just report "Problem: can't connect to SqueezeCenter" and go dark?

rocket j squirrel
2008-12-02, 07:51
Thank you, Mark.

Disabling the server's firewall does not change the behavior, SC still reports that the player cannot be found.

I'm not certain what you mean by trying to connect to SC "while [I'm] on SN." I can report that SC cannot see the player whether or not my browser has http://www.squeezenetwork.com/ open.

Going through the network setup on the player: the music source setting specifies the correct IP address for the server. When I then hit the right arrow, it displays "Connecting to Squeezecenter . . . " sits there for a while, then "Now Playing" displays.

However, now when I right-click on the Squeezecenter application and select "Open Squeezecenter," nothing happens. It used to open a new browser window, but not now. That looks to be a different problem which I'll try to sort out then come back to this issue.

So until then, thanks for your help on this.

rocket j squirrel
2008-12-02, 08:02
I'm back. I had to exit the SC application and re-launch it for it to respond.

It now finds the player. Since I didn't change any settings from when I first posted my request for assistance, I have no idea why now it works but I'm happy with this progress anyway.

Unlike SN, though, SC can't find my favorites. It looks like I have to run SN to play those. Ideas?

Mark Lanctot
2008-12-02, 08:16
Looks like you've solved it, so just a little clarification then.


I'm not certain what you mean by trying to connect to SC "while [I'm] on SN." I can report that SC cannot see the player whether or not my browser has http://www.squeezenetwork.com/ open.

What I mean is - when the player is connected to SqueezeNetwork, SqueezeCenter won't find the player because it's connected to SN.

However there's increased integration between SN and SC - I seem to recall SC being aware that the player was connected to SN and a dialog box asking whether you want to pull it back to SC. I may be wrong though!

Just having SN loaded in your browser doesn't necessarily mean the player is connected. On the right top corner of the page you'll see which player is currently connected though.


Going through the network setup on the player: the music source setting specifies the correct IP address for the server. When I then hit the right arrow, it displays "Connecting to Squeezecenter . . . " sits there for a while, then "Now Playing" displays.

In that case, it has connected to SC.


However, now when I right-click on the Squeezecenter application and select "Open Squeezecenter," nothing happens. It used to open a new browser window, but not now. That looks to be a different problem which I'll try to sort out then come back to this issue.

Some OS/browser/SC issue which appears to have resolved itself, but it looks like the player was connected to SC all along, just that the web GUI wasn't operating properly.

rocket j squirrel
2008-12-02, 09:10
Oh, okay - so "connected to SN" is what the player reports on the display.

I presently have two choices under Setup Squeezebox (4 of 4): "Connect to Squeezenetwork" or "Connect to [server name] (IP Address)". The server name (my computer's name) and the IP address for it are correctly entered.

After selecting "Connect to [server name] (IP Address)", SC finds the player. So all that stuff seems to be working.

However, my Favorites (streaming radio stations), which SN knows about, are missing in SC and in the player. Do I have to do something to import the favorites list into SC?