PDA

View Full Version : Squeezebox 2 - wireless (partially) stopped working



flavor8
2008-11-28, 14:39
My squeezebox 2 suddenly stopped being able to find the slimserver on my PC over wireless; however, over ethernet connection it works fine.

If I connect via wireless, it sees the router, gets an IP address, but then can't auto-detect the slimserver. When I type in my PC's IP address, it says that it's configured, but then turns off. When I turn it on it says it cannot connect the slimserver, yada yada.

Doesn't the fact that it gets an IP address mean that the wireless is basically working? If so, what could be causing this issue? Given that LAN -> LAN on the router works, it doesn't seem like wireless -> LAN would be causing issues; and, I've had it working fine on this router for years.

radish
2008-11-28, 15:51
Have you tried restarting the router?

flavor8
2008-11-28, 15:56
Yep, I've tried two different routers. I verified with a laptop connected via wireless that I can telnet to port 9000 on the PC (slimserver), also.

radish
2008-11-28, 16:35
Weird. In general the fact that the DHCP is working so it gets an IP shows two things, that the physical wireless link is working and that it's connected to the network OK (i.e. the passkey etc is correct). I'd try a few things if you haven't already:

1) Factory reset (see the wiki http://wiki.slimdevices.com/index.php/Hardware_Reset_commands)
2) Verify that the IP it gets is genuine (i.e. that it is within the correct range for your network). Also verify that the router lists the lease in it's web interface. It's possible that the SB isn't really associating and is using a failback address whilst looking as if DHCP is working.
3) Call support :)

alZmtbr
2008-11-28, 17:42
I had a similar issue with my wireless print-server. Turned out it was configured with the wrong wireless encryption (WAP I instead of II), once that was fixed, all was well. Similar in that the printer would react, then just stop after going through the motions that it was connected.

So check the encryption as well!

~a