View Full Version : Album Gallery Disappeared

2008-11-17, 23:51
The Album Gallery view recently disappeared! The menu only shows the "Text" view as an option, even though the Albums are currently showing up in text format and nothing happens when the button is clicked. The album artwork will display when an individual album is selected from any of the menu's, but I can no longer browse by the Album Gallery. I can't recall exactly what I was doing when this happened, but I believe it was after I began to change the way my multi album sets are handled. I started to consolidate them to reduce the multiple covers that show up in the Gallery view. After testing a few, things seemed to be working as they should after ensuring the name of each album in a set was the same, adding the disk number as appropriate to each album, etc and then rescanning after changing the setting to treat multi sets as a single album. Then at some point the album art gallery vanished and I can't get it back! I tried reinstalling but no change. None of the missing artwork threads seem to apply.
Any suggestions please??
It's SC 7.2.1 on WindowsXP , Fishbone skin with the same situation on the default.


2008-11-18, 12:44
I have the same issue. I toggled the artwork display to "Text only" in Firefox. The icon never gets set to the image one again..it stays as "Text only". If I start Squeezecenter in IE it works fine. I can toggle back and forth. The interesting feature is if I go to another system and run Squeezecenter in FireFox its ok??I tried deleting history/cache in FireFox but to no avail. This seems to be a definite inconsistency between browsers.

2008-11-18, 18:20
It occurred to me that I had run into this on my Macbook also, so I tried switching to Safari and the gallery works fine, just as you noted. I can toggle back and forth between both views. Switch back to Firefox and the problem is back. I'm using 3.04 on both computers. I later tried to switch to IE on my music PC, but encountered a problem getting it to start. Firefox would stay as the default no matter what I did to change the settings. So, I tried removing Firefox,planning to reinstall after getting IE running. Well, IE will not run properly and will not allow me to connect to web sites..."Application not found" message. It will connect only if the URL is entered as the default home page first! I can then navigate around on the page, but it will not allow downloads for some reason...I tried from both the Mozilla and the IE7 sites. Until I fix this I don't have a working browser or anyway to download one. Anyway, back to the gallery issue. I think this started after the recent upgrade to Firefox 3.04. I have one more PC that is running it and will try it with my external music drive to see if the problem is the same.

Is it just the two of us that are seeing this?


2008-11-18, 22:35
I gave up trying to get IE6 to work and reloaded Firefox 3.0.4 by using a flash drive. My gallery view is back to normal now. You may want to try reinstalling Firefox and see if it works for you. I'll try it on my Mac too.


2008-11-20, 15:00
Uninstalled Firefox .. nuked everything..what a pain.. did fix the issue though

2008-11-20, 22:21
I tried reinstalling both Firefox and SC, but it didn't fix the issue on my Macbook.The gallery appears with Safari browser but not Firefox. I can live with this, but would like to understand what's causing it. It seems no one else has encountered this but the two of us. Glad to hear you you are seeing your artwork again.


2008-11-21, 04:17
does clearing the browser cache fix it?

2008-11-21, 11:56
I attempted clearing cache in Firefox on Windows XP-SP3 but to no avail. Reinstall was my only option. I dare not reset the listing type again!

2008-11-21, 12:48
No, clearing the cache made no difference. I tried that early on and also have the browse set to clear on exit. Bit of a mystery...reinstalling Firefox worked on the PC but not the Mac.I don't really use the Mac any longer since I set up an older PC as a dedicated server.


2008-12-02, 16:02
...to ask Firefox to clear the cookies as well as the cache.

Press Ctrl-Shift-Delete to open the dialogue box for clearing private data. Make sure that "Cookies" is checked (it is not, by default), then click OK.

This will sort your immediate problem, but will also remove your personalisation data from all other websites.

ISTR that there is a way to selectively delete cookies, but I cannot remember how.

After I did this, the text-only setting did not get stuck again, so it may be some incompatibility with a cookie that was stored by an old version of the server following an upgrade.