PDA

View Full Version : Sound Quality Linux vs Windows



bernt
2008-11-17, 04:07
Hi!

I have this stereo connected to my computer with Kubuntu 8.10.
http://www.amazon.com/JVC-FS-Y1-Component-System-Player/dp/B0007XH72Y

The other day I burned a music cd from flac files and put it in the stereo to test it. And wow! What a sound compared to play the same music with Amarok.

The sound from the computer was distorted and flat compared to the cd.

If I installed windows, could I get better sound or is it the soundcard, cables or..?

Has anyone else noticed a difference in sound quality between Windows and Linux on the same hardware?

Kind Regards
/Bernt

socistep
2008-11-17, 05:15
Hi!

I have this stereo connected to my computer with Kubuntu 8.10.
http://www.amazon.com/JVC-FS-Y1-Component-System-Player/dp/B0007XH72Y

The other day I burned a music cd from flac files and put it in the stereo to test it. And wow! What a sound compared to play the same music with Amarok.

The sound from the computer was distorted and flat compared to the cd.

If I installed windows, could I get better sound or is it the soundcard, cables or..?

Has anyone else noticed a difference in sound quality between Windows and Linux on the same hardware?

Kind Regards
/Bernt

Yes I have found a difference, I dual boot into Ubuntu & XP - the root cause of my difference's was related to the wireless card through. The wireless card was performing poorly on Linux and that was impacting sound quality, this has been improved significantly on the move to 8.10 so doubt whether that is your problem.

I haven't since the 8.10 checked the sound quality between the 2, I guess this is a hard thing to measure as with the wireless issues resolved then it would be related to my own interpretation

bernt
2008-11-17, 05:31
Maybe it's my installation that is messed up. I have installed Kubuntu 8.04 with KDE 3.x, installed KDE 4.x and then upgraded to Kubuntu 8.10.

I think I try a clean install to see if that solves the problem.

socistep. How do you the set the volume in Kubuntu?

I have it set to 100% in Amarok and the system to 60-70%. If I set the system vol higher it get really distorted.

socistep
2008-11-17, 06:05
Maybe it's my installation that is messed up. I have installed Kubuntu 8.04 with KDE 3.x, installed KDE 4.x and then upgraded to Kubuntu 8.10.

I think I try a clean install to see if that solves the problem.

socistep. How do you the set the volume in Kubuntu?

I have it set to 100% in Amarok and the system to 60-70%. If I set the system vol higher it get really distorted.

I only use Squeezecenter/Duet now to listen to music and I go with the same approach - set the Duet at 100% and then control volume through my Hi-Fi, this gives the best sound

bpa
2008-11-17, 06:20
Generally the PC speaker sound output has gone through a mixer which can combine various sources (e.g. wave, CD , mic, line-in ) into one output. Many of these sources are enabled by default so a lot of audio processing (e.g. upsampling , mixing, downsampling, enhanced stereo) will be performed on the audio before output. By contrast with SC, audio from files are passed unaltered to the SB.

In Linux look for mixer control (e.g. Kmix in KDE I think or amixer on shell) to adjust volume amongst other things.

bernt
2008-11-17, 06:33
Everything in the Mixer is set to zero except for Front Speakers. For some reason this is the output source.

I have checked it from a terminal with alsamixer.

Mark Lanctot
2008-11-17, 06:33
It really should be mentioned here that SqueezeCenter doesn't care what OS you're running, the sound quality should not be affected (up to the point it drops out completely due to insufficient bandwidth). After all, you don't even need a soundcard to run SC. SC does not use any sound software or hardware.

Playing back through the computer using the kernel mixer is a different matter.

bpa
2008-11-17, 07:39
Everything in the Mixer is set to zero except for Front Speakers. For some reason this is the output source.


Amarok only plays through the "speakers" which may also be routed to a digital output on some cards. I'm assuming you have some output from the PC connected to your main audio setup.

What inputs are enabled ?

bernt
2008-11-17, 07:41
I guess I'm a little out of topic on this forum. My apologies.

This has nothing to do with SC or SB. I listen to music on my computer through above stereo and discovered by accident how bad it sound if a play the music on the computer vs playing cd on the same stereo.

I run SC on another pc and have the SB connected to another stereo with perfect results.

Mark Lanctot
2008-11-17, 07:54
I guess I'm a little out of topic on this forum. My apologies.

This has nothing to do with SC or SB. I listen to music on my computer through above stereo and discovered by accident how bad it sound if a play the music on the computer vs playing cd on the same stereo.

I run SC on another pc and have the SB connected to another stereo with perfect results.

Sorry, I missed that! Re-reading your post, I see you never mention SC, you're comparing computer -> stereo vs. CD player -> stereo.

Incidentally, this is why I gave up on computer audio. No matter what I did, it was always just...blah. I suspect if I spent mega $$$ on a soundcard (M-Audio Delta or similar) the results would have been better, but the SB was roughly equivalent in cost and a lot more flexible.

bernt
2008-11-17, 07:58
Amarok only plays through the "speakers" which may also be routed to a digital output on some cards. I'm assuming you have some output from the PC connected to your main audio setup.

What inputs are enabled ?

I'm a little confused by the settings in Kubuntu, Where do I check what inputs are enabled?

GlenL
2008-11-17, 08:02
Just a guess, but it may be down to the Ubuntu soundcard driver.

Ubuntu may be using a 'generic' soundcard driver that may not be specifically written for your soundcard.

You don't say what soundcard you have ... perhaps the manufacturer's web site may have a manufacturer written linux driver for it.

As I say, just a guess.

bpa
2008-11-17, 08:05
The topic is still useful as I think some users don't realize how much processing can happen within PC even when no special processing is selected.

All sound cards have inputs, output, mixers and some additional DSP capability. How the output is setup (e.g. accept 48kHz or 44.1kHz) will affect the sound quality as it may force resampling of the source signal.

bpa
2008-11-17, 08:07
Where do I check what inputs are enabled?

Kmix usually has 3 tabs - output, input and switches. Look at "input" tab.

peter
2008-11-17, 09:30
bernt wrote:
> I guess I'm a little out of topic on this forum. My apologies.
>
> This has nothing to do with SC or SB. I listen to music on my computer
> through above stereo and discovered by accident how bad it sound if a
> play the music on the computer vs playing cd on the same stereo.
>

Internal sound cards can be pretty bad. They also tend to produce a lot
of interference from the motherboard. External sound cards (or external
DACs) can be much better, but one might as well get an SB for the money

Regards,
Peter

agillis
2008-11-17, 11:01
Sounds cards in PCs have poor analog output for the reasons stated in this thred. There is a lot of electrical noise in a computer. If you are getting pops and clicks you can make sure your sound card is on it's own interupt. Use "lspci" from the command line in linux. But I don't think this is your problem.

Your best bet though is to use the SDIF out on your PC and connect that to your stereo. That way the A/D is done by the stereo not the PC. If your PC sound card doesn't have SDIF or digital out you can get sound sound cards or USB sound systems that do for under $25.

bernt
2008-11-17, 12:08
Kmix usually has 3 tabs - output, input and switches. Look at "input" tab.

Sorry, I can't find any of the tabs. I click on the speaker next to the clock and then the button Mixer. There is a lot of channels but only one is doing anything.

According to lspci my soundcard is a Creative Labs SB Audigy LS card.

I also booted from Kubuntu 8.10 livecd and it sounded the same. Slightly distorted and flat.

bpa
2008-11-17, 12:43
I would expect a display as follows from Kmix.

http://docs.kde.org/stable/en/kdemultimedia/kmix/working-with-kmix.html

On my Suse system KMix mixer is open by clicking on the "mixer" button at the bottom of the vomlume control. Alternatively start KMix from the application menus.

mudlark
2008-11-17, 12:46
left click the volume control then click the mixer tab. if no response open the terminal and type kmix. Kmix is there with kde4 I think.

settings > configure channels etc.

With my cmedia card I use the optical out which means me turning on the IEC958 switch

mudlark
2008-11-17, 12:50
left click the volume controlthen click the mixer tab.

settings > configure channels etc.

With my cmedia card I use the optical out which means me turning on the IEC958 switch

bernt
2008-11-17, 13:56
I would expect a display as follows from Kmix.

http://docs.kde.org/stable/en/kdemultimedia/kmix/working-with-kmix.html

On my Suse system KMix mixer is open by clicking on the "mixer" button at the bottom of the vomlume control. Alternatively start KMix from the application menus.

It does not look like that at all.

Under Help About Kmix it says Ver 3.0 using KDE 4.1.2.

After some experimenting using headphones I found out if I set the system vol to 100% and adjust the volume in Amarok to the same level as the CD sound. Distortion disappeared but the sound is still kind of flat, lifeless. But I guess that's depends on the hardware and cable and not the software.

And I'll do clean install some day.

Thank's for your help.

bernt
2008-12-09, 00:25
I did a clean install of Opensuse 11.0 and KDE 4.1.3. And I was not happy with the sound so I installed Vista and suddenly I got the same sound as I have with a cd.

For some reason Linux installed Audigy drivers, but the souncard is a SB Live 24. Maybe that had something to do with it.