PDA

View Full Version : duet receiver restarts songs



dbackman
2008-11-12, 22:16
So I'm having what appears to be a systemic issue with my squeezebox duet receiver. It appears to play songs part of the way through and then restart the song from the beginning.

I have both the duet receiver and an older SB3 on my network, and am running the latest SqueezeCenter 7.2.1. This is only happening on the Duet receiver.

While listening to just about any song in my library, the duet receiver will play the song normally for about a minute of two -- and will then restart the song from the beginning. This then continues over and over again. A check with the Network Test utility from the same location as the Duet receiver shows 5000k/sec with no loss.

Ironically, I don't get the same behavior on my SB3. This is VERY reproducible, and happens constantly.

Has anyone else seen (or rather heard) this symptom?

Note: it doesn't appear to be an RF problem, as it happens when the receiver is right next to the wireless access point or at the other end of the house. It also appears to happen when using the built-in ethernet port as well.

My entire music collection is Apple Lossless 44.1KHz/16bit.

Version information for anyone that might care:

SqueezeCenter

SqueezeCenter Version: 7.2.1 - 23630 @ Mon Oct 20 19:54:08 PDT 2008 - Debian - EN - utf8
Server IP address: 192.168.23.51
Perl Version: 5.8.8 i486-linux-gnu-thread-multi
MySQL Version: 5.0.51a-3ubuntu5.1
Platform Architecture: i686-linux
Hostname: slimserver
Server Port Number: 9000

Total Players Recognized: 2

Player Information

Name: DAC1
Model: Squeezebox v3
Firmware: 113
The IP address for this player is: 192.168.23.132:22818
The Ethernet MAC address for this player is: 00:04:20:xx:yy:zz

Name: Upstairs
Model: receiver
Firmware: 48
The IP address for this player is: 192.168.23.132:22156
The Ethernet MAC address for this player is: 00:04:20:xx:yy:zz
Wireless Signal Strength: 51

tskjaerpe
2008-11-19, 03:43
I have exactly the same problem. I have one Duet. I run my music from a Windows Home server. The problem occurs with both Flac and WMA files, and is extremely annoying.
The problem seemed to start about 10 days ago when the Duet controller announeced an update which I installed. The software version is 7.2 r3191. The firmware is 48.
While listening to a radio station, I have also experienced that the connection was interrupted with a message on the controller telling me that connection timed out.
When I switch off the controller and place it in the charger, the next morning it is on again. The menu line "Switch on/off Squeezebox" randomly is displayed in English or in my native language (Norwegian).

uka
2008-11-19, 11:41
I have a similar problem. It can work fine for a long time (hours), or it does not connect at all, or it plays only 2-3 seconds of the songs before cutting off, and then playing another 2-3 seconds. It seems to be random if it works or not, and I am not doing any changes to get it to work again. The only thing I can do is keep changing songs until it (somehow) decides to work again.

This also started happening after software upgrade to 7.2.1.

And it is VERY annoying.

Any suggestions to how this can be solved?

pks1414
2008-11-19, 13:22
It would seem that the last update has certainly messed something up. I have had my duet running great for Months, signal strengths very good, after this last update if I select random songs, it will play for ages then stop, reconnect and start up again, great I was hoping after 8 months things might be improving, lets hope they fix soon

mvalera
2008-11-19, 15:31
It's very unlikely that an update would cause this behavior. It's much more likely that a new wireless device has recently been added to you wireless "neighborhood" and is interfering with your Squeezebox Receiver.

I would use a tool like NetStumbler to do a wireless survey and use then set your router to the channel with the least interference.

If that doesn't work, I would contact support:

http://www.slimdevices.com/su_tech.html

Mike

pks1414
2008-11-20, 01:40
I don't think it will be anything to do with my Wireless neighbourhood,the nearest house to me is about 40 metres away, would they still be able to interfere even at that distance?

pks1414
2008-11-23, 08:49
I decided to write to support. Last night all I did was listen to music stopping, restarting, album artwork sticking, resetting controller/receiver, all in all a nightmare. I have checked wireless strength, all okay, even been to the neighbours to see if they had anything new installed that may have impact, nothing.

It all goes back to the fact that its only been happening for the last couple of weeks, or since the last update.

Hopefully I will get an answer as at the moment the system is unusable.

stewarda
2008-11-24, 15:32
I am having the same problem, only since the last update. Hoping for a bug fix soon.

ewadley
2008-11-24, 22:09
I have the same problem along with several others making my duet worthless to control from the controller, only through my laptop and squeezecenter will this unit work. Otherwise it will either resart songs in the middle, songs being played from my hard drive, or it will freeze up, loose contact and just generaly not work, all while it says it has full connection strength. Obnoxious. I have no solution however, Logitech customer support is worthless. Great product in concept, terrible execution.

pks1414
2008-11-25, 10:56
Hmmm..had an auto reply from Support on Sunday saying they would be contacting me within 24 Hours...its now Tuesday, not great for something that cost me 280, even a "Still looking would be good" Can you roll things back? it worked great before

Dermaplex
2008-11-26, 04:12
I downloaded from the controller the last version of the software, and since then, I don't ahve the issue anymore....

D.

pks1414
2008-11-27, 10:54
Was that a new update? mine says it is already up to date and that is the culprit. At least that is what I believe to be the culprit, however until support get back to me, and as a side issue it has now been 4 days!! I don't know any different. I am not wildly impressed with the level of support at this stage, so much for the 24 hours in their email

pks1414
2008-11-29, 13:40
Just tried again, exactly the same problems, I have to restart the controller to move things on, otherwise I listen to Foo Fighters but look at Simon and Garfunkel, getting really brassed off now as it will be one week tomorrow and I am still waiting to hear from support.

leehuang
2008-11-29, 20:00
Same here. I am pretty sure it's all happening after the software update. I only use the Squeezebox Suet for the Rhapsody music service. In the last few weeks, I was not able to listen to any session without being interrupted. I wrote to the the support, and they suggested a factory reset, which I did. But the problem persists. I really don't think it's my wireless's signal's problem. I've switched to my computer wireless to listen to the same Rhapsody service when the interruption happened, and it's always fine.

On top of this problem, my controller somehow loses the music source quite often. So the controller's screen will not have anything but a Settings menu item, and nothing I can choose from the available menu will bring the music source back. Restarting the controller won't work either (well, sometimes it did work, but not reliably). All I can do is just leave it alone, and come back a day or 2 and re-start again, then it will come back.

I really hope Logitech can investigate this problem. Or at least provide a way for us to revert back to the previous software.

-lee

tordenfod
2008-11-30, 12:04
Just reporting in line to this prob.
And i am wired from pc to reciever !!!

Just hoping tha logitech support and/or enginiers will come by my hairshop.. Then they will recieve an "update" that will set them back by years :-)

tordenfod
2008-12-01, 15:02
A bad wiring !!! My internet connection was OK in speedtest but reciever wassent to happy with the signal ..hmm

So maybe for all you other who have simular prob. CHECK connection and recheck and then check again :-))

mvalera
2008-12-01, 15:18
As I said this would be unrelated to any update we pushed out.

Please do a network test on the Receiver from the Controller (Settings -> Advanced -> Network Test) menu and contact support if you have similar issues.

If you are dropping a lot of packets at the bandwidth of your typical music source, then you are having network problems.

Mike

pks1414
2008-12-02, 09:57
A response from support would have been good as it has now been over a week, what exactly is the test looking for, and why has this happened over the last 3 weeks. As I said in an earlier post, signal strength always max. no changes in network, in fact neither neighbour has a wireless network anyway.

Just looking at the Test History the bar chart is to the 100% side and is green, is that good?? It also says press right for help, but that doesn't do anything, about sums things up!!

It worked great up until recently, could run the random mix all day without a hiccup, now its awful. If it doesn't stick on a song, it restarts, or the album art sticks and the only cure is to re-boot the controller

I haven't changed anything, my neighbours certainly haven't, that only leaves one other

EDIT: In fact looking through the forum, there seems to be quite a few people who have started to experience problems since the beginning of November

ANZAC
2008-12-03, 08:00
Hmmm..had an auto reply from Support on Sunday saying they would be contacting me within 24 Hours...its now Tuesday, not great for something that cost me 280, even a "Still looking would be good" Can you roll things back? it worked great before

Try a factory reset m8? It worked for me, but on a different problem? 4 me it was worth having to start from scratch? See the top sticky?

ringhal
2008-12-06, 22:49
I starting having the same problems about 2 days ago. Hopefully this will be fixed very soon.

Ecue
2008-12-15, 04:05
Since the last update, my Duet skips the current song instead of restarting.

When it happens, below two lines appear on the Squeezecenter log file.

[08-12-15 20:00:34.1778] Slim::Networking::IO::Select::select (271) Error: Select task failed: Can't use an undefined value as a SCALAR reference at /usr/share/perl5/Slim/Player/Protocols/File.pm line 204.
[08-12-15 20:00:34.1783] Slim::Networking::IO::Select::select (271) Error: Select task failed: Can't use an undefined value as a SCALAR reference at /usr/share/perl5/Slim/Player/Protocols/File.pm line 204.

I am using Squeezecenter 7.3 on Debian Etch.

I hope this helps resolving the problem.

tskjaerpe
2008-12-19, 17:25
My problem with restarting songs seems to to have disapeared with version 7.3 - at least so far.