PDA

View Full Version : Squeeze Box Controller Doesn't See my Receiver (Probably Linux setup problems)



Rimmer100
2008-11-11, 14:19
Hello,

Even though I haven't got this working properly yet, I am still really liking it. I thought that the controller was going to be smaller than it is but I am impressed at what it can do. Once I get these problems sorted I am going to switch to 7.3 as music playing from the remote is a brilliant idea. Anyway I am hoping that some of you kind people can help me with my issues.

Symptom:
SBC doesn't see my SBR. Controller is connected to the network (it has got an IP address) and the icon on it is white but it doesn't list my player in the 'Choose Player' menu.

I think there is an issue with how the SqueezeCenter broadcasts it's address to the Controller and the Receiver in the sense that they aren't getting through. When I do the setup the Receiver stays with the light on blue. By using Robin Bowes brilliant Net-UDAP (http://projects.robinbowes.com/Net-UDAP/trac) I was able to interrogate the SBR and find out what was up. It had connected to the network fine (via ethernet) and had got an IP address from the DHCP server but it didn't know what the server_address or squeezecenter_address were. By setting these manually to my server, the light went dull white and I was ready to go. I can play music from the SqueezeCenter webadmin without any problems.

(Is it the controller that tells the receiver what these addresses should be during setup or does it pick them up via a broadcast from the server?)

On the remote I have manually input the address of the server (192.168.0.1) as a music source. A couple of times I have seen this address resolved by that controller to routerfc6.iansnet but even when this has happened I still don't see the player listed.

(I do know that the hardware works as I temporarily installed a server on a Windows machine so I have seen it all working. Although I did still have to use Net-UDAP to point it to the server)

My setup is as follows:

A Mini-ITX computer running Fedora Core 6 from a compact flash card. (When I set it up FC7 didn't like the IDE > CF adapter I was using so wouldn't load). By far the fastest router I've had compared to older off the shelf models. It has two onboard network ports and 512 MB memory. ETH0 connects to the cable modem, ETH1 connects to an 8 port 100/1000 switch.

The computers pick up their IP addresses from the DHCP server on the router. Some of them I have reserved the IP addresses for in the dhcp config. The private IP addressing is 192.168.0.x. The router which is running the SqueezeCenter software is 192.168.0.1 and has a hostname of routerfc6.iansnet

In the squeezecenter file that lives in sysconfig I added the following to the SQUEEZECENTER_ARGS= line:
--httpaddr=192.168.0.1 --cliaddr=192.168.0.1 --playeraddr=192.168.0.1

I did this as from what I read this was how to stop SqueezeCenter from binding to the public address, which is what it was doing originally. The SqueezeCenter status page seems to suggest that this has worked:

>
SqueezeCenter Version: 7.2.1 - 23630 @ Mon Oct 20 19:52:55 PDT 2008 - Red Hat - EN - utf8
Server IP address: 192.168.0.1
Perl Version: 5.8.8 i386-linux-thread-multi
MySQL Version: 5.0.27

Platform Architecture: i686-linux

Hostname: routerfc6.iansnet

Server Port Number: 9000

Total Players Recognized: 1
>

I also changed a parameter in the server.conf file:

allowedHosts: 127.0.0.1,192.168.0.*

There is a bind command in this file as well which is binding to 127.0.0.1 should I change that or leave it?

As this is also a router I have iptables running. I suspect that my problem could be here.

Currently I have the following rules loaded:

>
# Generated by iptables-save v1.3.8 on Sat Nov 8 16:02:07 2008
*nat
:PREROUTING ACCEPT [22552:2062540]
:POSTROUTING ACCEPT [1877:177412]
:OUTPUT ACCEPT [9304:672005]
-A POSTROUTING -o eth0 -j MASQUERADE
COMMIT
# Completed on Sat Nov 8 16:02:07 2008
# Generated by iptables-save v1.3.8 on Sat Nov 8 16:02:07 2008
*filter
:INPUT ACCEPT [128111:23200653]
:FORWARD ACCEPT [406007:311501670]
:OUTPUT ACCEPT [120833:52584908]
-A INPUT -i eth0 -p icmp -j DROP
-A INPUT -i eth0 -p tcp -m tcp --tcp-flags FIN,SYN,RST,ACK SYN -j DROP
-A INPUT -i eth0 -p tcp -m tcp --dport 0 -j DROP
-A INPUT -i eth0 -p tcp -m tcp --dport 1 -j DROP
COMMIT
# Completed on Sat Nov 8 16:02:07 2008
>

As you may have guessed I am largely a Linux novice. I setup the router a while ago to get around poor performance from an aging Netgear RP614 v2. I'd like to have SqueezeCenter running on here as it is always on, unlike the Windows machines in the house. My music store is on a separate NAS box which is also always on.

The SBR is connected via ethernet and has an IP of 192.168.0.10. The SBC is connected to the SqueezeBox using the bridging mode. I do have a wireless network and have tried connecting the remote through this, but it doesn't make any difference.

The remote is running firmware 7.2 r3191 which I managed to download to it (after a bit of a fight) when I had the temporary Windows server setup. The SBC has an IP of 192.168.0.11.

I have looked through the forums and tried a number of the iptable commands that people have suggested but they haven't worked for me as I don't really understand what I'm doing.

Any help would be gratefully received.

Cheers

Ian

Rimmer100
2008-11-21, 08:29
Anyone had any thoughts about this?

I submitted it to support but haven't had a response. It seems it went to US support who then forwarded it to European but I am guessing it probably got lost on the way...