View Full Version : Controller seems to be dead?

2008-11-11, 12:42

Have the Squeezecenter local server, coupled with a Duet setup, running for about a week now. I had some initial install issues, but these panned out well after some tweaking.

However - I picked the controller this afternoon, which was no longer connected to the network. It started searching, as usual - normally this does not take longer than 10 seconds. After 10 seconds, the controller screen garbles - and gets distorted. No screen changes, just a freeze - nothing happens - the Searching graphic is shown, but with alternating lines, and out of sync vertically.

Since there was no spontaneous reboot - I removed the battery, and put it back in the charger, figuring it might need some juice.

After a load of about two hourse - the controller does not wake up any more.
Screen is dead, and I can get 0.2 seconds of light coming from the buttons, but the screen remains black, and the buttons immediately turn off again as well.

I thought this might be the battery - but no luck -even with battery removed, and in the loader, each time power is applied to the controller -- 0.2 seconds button light, and .... dead again

It seems the controller does not want to boot anymore, hence I cannot have access with SSH any more either to fetch log files, and I don't have a SD card available right now (which probably won't help, since it does not retain power?).

I'll refer to customer service - but since I only have the setup for a couple of days, I'd first like to see whether I can fix this somehow, before sending it back ...

Anybody have any experience with a dead controller and CPR?

Thank you, in advance,


2008-11-11, 13:01

The manual suggests:

1. Hold down the home button for 12 seconds to force a power down.
2. While holding down the add button, press the home button again.
The button lights will flash and the Controller will power on.
3. Release the add button when the Logitech logo appears.

While trying this, the same story goes - light on the buttons for a couple of microseconds, and then all goes quiet (dead) again ...

Strange - thinking about a malfunction of the hardware, due to a crash.
If anybody has any other ideas - I'm all ears ...

This is happening with firmware 7.2 if I'm not mistaken ; in the meantime everything receiver related, and squeezecenter related works like a charm.


2008-11-11, 13:58
Please call up support. Looks like you've tried holding down the Add button to perform a Factory Reset without any luck.

I've seen plenty of defective Controllers, but I've never seen any with your symptoms.


2008-11-11, 14:09
Hello MickeyG,

thank you for your input - I was already afraid it was coming to that, so I already opened a ticket with the support desk - awaiting their reply

I had the idea that other people might experience similar issues, one day - so I thought it better to at least get the word out that this *might* happen

I'll wait for their input - and post as to what happens with the device



2008-11-12, 13:52

just wanted to update this thread -- I had a dead controller for about the most of the 8 hours that passed after my last post.

Put it in the charger - and look and behold, this morning, it started up, after a factory reboot through holding the Home button for 12 seconds.
All of a sudden - it leapt into action again ...

Then - 45 minutes later --- same crash as before, with the garbled screen and all ... I decided to leave it alone for a while -- an autorestart happened after about 3 minutes, approximately - and since then - spotless response, as of old - no glitch or anything anymore ...

I'm presuming this is a hardware bug, in the sense that the chip loses it's settings or something ...

I'm happy - controller is working again, so don't despair if you have similar circumstances as described above - it might be you don't need to send it in for replacement after all ...

Just sharing,


2008-11-18, 04:41

just wanted to point out that my joy was shortlived - the controller is dead in the water again, and the last trick that I pulled to make it come alive again, seems to have lost it's charm ... no go :(

I contacted support more than one week ago - and up until now, still no answer

I'll file a new support request - hopefully I get an answer this time :(

2008-11-19, 05:14
I found that I got no email back from support but if I followed the link (in the original confirmation email) back to the support case on the website that in fact there had been replies to my case.

And yes I checked my spam folders/filters

2008-11-19, 06:14

thanks yellow160 for your reply

I opened a new ticket yesterday, and received an acknowledgement almost within the hour ; 16hrs later a followup email was sent acknowledging the fact that it got bumped to second tier support - and I should expect a mail regarding this issue within 24hrs

also found the link to MyStuff - where your tickets are stored and viewable upon login - I can follow that as well now.
I think for some reason the first ticket I opened did not come through at their desks - but not sure as to the why or how ...

Anyways - support is supporting now, in the sense that I'm awaiting their info on the subject :)

will keep the thread alive to see how it fares

by and all - regardless of the controller hiccup I'm experiencing - Squeeze rocks --- and solves a lot of problems in my setup here!
just saying - when it's bad I'll complain, but when it's good - I'll promote it - hence ....


2010-08-29, 15:10
what was the ultimate solution to this issue? Was the unit actually bad?

I am having the same frustrating problem with a unit that i bought off of e-bay. It worked maybe once and then i get the same 'lights flash' issue that you are describing.

Any help would be much appreciated. I dont think ill get support from logitech on this e-bayed item.

2010-08-30, 02:23
Hello Poulsen11,

I purchased the Duet straight from the Logitech webshop - and contacted them with the fact that the Duet controller was broken.

They requested I send them the battery of the broken Duet along with the charger adapter - which I was not able to do immediately due to time restraints. About 10 days after the initial ticket opening, I received a new Duet controller combo box (ie. controller + station), completely new - through the mail.

I actually never sent the broken device, and nobody requested that either, probably just policy that is not actually enforced - it's still here in the closet, but still broken, so no use for that anymore I'm afraid.

I'm afraid that in your case, Logitech warranty is excluded, unless you'd have the original invoice from the person who sold it to you on EBay?

Hope this helps - good luck!

Kind regards,