PDA

View Full Version : Music problems



Hildebrandt
2008-11-08, 04:47
Hi all...
Using SB Duet and pleased - apart from the occasional BIOD...
I have a problem with SC: when scanning it doesn't always find the covers (folder.jpg in the album directories) for my mp3's... Some of the ones it finds can be seen on the SC console, but apparently it doesn't pass all covers to the SB controller... Is there a size limit to the covers???

Also i sometimes have a sudden increase/decrease in volume a few seconds after starting a song...

Finally: How can i set the SC/SB to play all songs in an album after starting one??? I know i can select Play All and hear the entire album - in interested in starting e.g #3 and have SC/SB continue with #4 etc until end of album.

Siduhe
2008-11-08, 04:50
The size limit is 500x500 but 300x300 is recommended.

http://wiki.slimdevices.com/index.php/Album_Artwork

On your final question, go into Settings and select Player Settings and scroll down to "Play Other Songs in Album" - change it to Play other Songs in Album or Directory. Then Apply. When you go to song three and press play, it should add the whole album to the playlist but start playing from song three.

Hildebrandt
2008-11-08, 06:30
The size limit is 500x500 but 300x300 is recommended.
Ah - Ok... mine is 1200x1200 - will resize and see if all covers are registered...


On your final question, go into Settings and select Player Settings and scroll down to "Play Other Songs in Album" - change it to Play other Songs in Album or Directory. Then Apply. When you go to song three and press play, it should add the whole album to the playlist but start playing from song three.

tried that before - that doesn't work for me, it doesn't progress to #4...

Siduhe
2008-11-08, 08:26
tried that before - that doesn't work for me, it doesn't progress to #4...

Someone else had a similar problem recently - will see if I can find the thread (assuming it wasn't you?). Are you are trying to play songs via the Controller rather than via the web interface, or do you see the same (incorrect) behaviour in both?

Siduhe
2008-11-08, 08:29
Here it is: could this be your issue?

http://forums.slimdevices.com/showthread.php?p=354084

MeSue
2008-11-08, 09:26
The size limit is 500x500 but 300x300 is recommended.

I recall reading something from a Logitech employee that said there is no size limit for cover art. I believe the only cover art size issue has something to do with iTunes integration. I have some covers that are larger than 500x500 and they work fine.

Siduhe
2008-11-08, 09:53
Sue, I think you are right in respect of the Controller - but according to Michael there is a limitation in the webui.

http://forums.slimdevices.com/showthread.php?p=350683&highlight=500x500#post350683

At the least 1200x1200 will slow the caching down a lot!

Hildebrandt
2008-11-08, 12:17
Here it is: could this be your issue?

http://forums.slimdevices.com/showthread.php?p=354084


The issue is how you select the track.
if you select the track with the center circle it will only play the one track.
you have to sellect the track with the play button(triangle) to the top right of the wheel and then it will play from that track on.

hope this helps others
This solved the problem - thx... controller still erratic re. covers - will do the resizing tonight and see if that helps... Will post results!

Hildebrandt
2008-11-08, 15:42
*sigh* did the resizing of the covers - and a total rescan... same results - on controller several albums are missing covers, this includes albums that has covers when i utilize the web interface for SC... This is strange...
Any ideas???

Also - when an album has contrbuting artists (e.g Imagine by Armin van Buuren) the album artist is listed as various artists... How do i force SC to identify albums by the folder titles, and not by the files?? (folder name is "Armin van Buuren - imagine" - so this should also be the album name)

Siduhe
2008-11-09, 05:17
Is it just the Controller that the artwork is missing from, or is the artwork also missing in the Web interface?

What is the name format of your artwork - cover.jpg, folder.jpg or similar? Check that the cover art which isn't being picked up conforms to the SC requirements - in particular, Folder.jpg is not the same as folder.jpg and will not be picked up.

As for the Various Artists bit, I suspect you have the "Group Compilation Albums together" functionality switched on. This will group compilation albums under Various Artists. Just change this option to "List Compilation Albums by each artist".

Hildebrandt
2008-11-09, 06:47
Is it just the Controller that the artwork is missing from, or is the artwork also missing in the Web interface?

What is the name format of your artwork - cover.jpg, folder.jpg or similar? Check that the cover art which isn't being picked up conforms to the SC requirements - in particular, Folder.jpg is not the same as folder.jpg and will not be picked up.

The artwork is in folder.jpg format - and all showed in web interface, but not on controller.

Browsing these forums i learned that several others have the same problem - theres some speculation to the problem isthe cache in the controller... One solution appears to be a reset of controller - this requires a total re-setup incl Wireless etc...

I found a solution, however: First turn off controller, then remove battery and re-insert it. The controller then powers up - and swiftly loads ALL the artwork!! Don't know if it matters - but my music was running while i did it... So atm i'm good... Will look into the compilation-thing...

thx!

Hildebrandt
2008-11-09, 08:20
Just change this option to "List Compilation Albums by each artist".

yep - that took care of the "various Artists" bit - but this is not much better... Title is now taken from all the "artist" tags of the MP3s in the folder... So instead of the album title being "Imagine by Armin van Buuren" its now "Imagine by Armin van Buuren, Armin van Buuren with DJ Shah, Armin van Buuren feat. Jaren, Armin van Buuren feat. Audrey, Armin van Buuren feat. Sharon, Armin van Buuren feat. Jacquel, Armin van Buuren feat. Cathy B, Armin van Buuren feat. Vera Os, Armin van Buuren feat. Jennife"
You see my problem??? Any ideas on how to make SC take the album title from the folder title, not the tags of the MP3s???

Siduhe
2008-11-09, 08:46
Ah, you are running into the dreaded Various Artists Logic problem - there are many, many threads on the boards with strong views on all sides as to how Squeezecenter should handle this.

To answer your immediate question - Squeezecenter will only use Guess Tags functionality when the mp3s (or whatever format the music is) has no tags which SC can read for information.

Can I just try to understand what your ideal formulation would look like - I assume this is on the Duet Controller that you want to see the albums? Do you just want to see the Album name? If so, try Settings/Advanced/Album Sort Method on the Controller and select Album. Does that sort you out?

Hildebrandt
2008-11-09, 10:32
Ah, you are running into the dreaded Various Artists Logic problem - there are many, many threads on the boards with strong views on all sides as to how Squeezecenter should handle this.

To answer your immediate question - Squeezecenter will only use Guess Tags functionality when the mp3s (or whatever format the music is) has no tags which SC can read for information.

Can I just try to understand what your ideal formulation would look like - I assume this is on the Duet Controller that you want to see the albums? Do you just want to see the Album name? If so, try Settings/Advanced/Album Sort Method on the Controller and select Album. Does that sort you out?
Tried it - no changes... I'm kinda old school with these things - considering editing the DB and manually changing the few entries/albums thats bugging me...

MeSue
2008-11-09, 11:16
yep - that took care of the "various Artists" bit - but this is not much better... Title is now taken from all the "artist" tags of the MP3s in the folder... So instead of the album title being "Imagine by Armin van Buuren" its now "Imagine by Armin van Buuren, Armin van Buuren with DJ Shah, Armin van Buuren feat. Jaren, Armin van Buuren feat. Audrey, Armin van Buuren feat. Sharon, Armin van Buuren feat. Jacquel, Armin van Buuren feat. Cathy B, Armin van Buuren feat. Vera Os, Armin van Buuren feat. Jennife"
You see my problem??? Any ideas on how to make SC take the album title from the folder title, not the tags of the MP3s???

Specifying an Album Artist tag for that album should solve it. You can do the same for any other compilations that you don't want to have listed with a bunch of artists.

Hildebrandt
2008-11-09, 13:25
Specifying an Album Artist tag for that album should solve it. You can do the same for any other compilations that you don't want to have listed with a bunch of artists.

Ok?? Sweet - How do i do that???

MeSue
2008-11-09, 14:31
Depends which tagger you use. I use J River Media Center and it is a default field. But if you use something different you might want to post this as a new question so the people who use it will be able to help.

Hildebrandt
2008-11-09, 15:22
I found a solution, however: First turn off controller, then remove battery and re-insert it. The controller then powers up - and swiftly loads ALL the artwork!! Don't know if it matters - but my music was running while i did it... So atm i'm good...

:o( No i'm not - just added music to collection, same thing happened... And my trick above didn't help... Also - SC didn't 'catch' the covers until i clicked and opened the album(s)... Now trying a total rescan to see if that helps...

*EDIT* It did... But had to do the procedure twice...
This is annoying - hope Logitech fix this...