PDA

View Full Version : Slimp3 & SB with FLAC



David Cullen
2004-04-17, 09:52
Not a techy so apologies if this is a dumb question...

At the moment I have 2 sp3s which will end up in the dining room and main
bedroom.

I ripping all my CDs and encoding them with FLAC. At the moment I have lame
& flac on the server so that the sp3s can play the flacs.

My plan is to get a wired SB to put in the main listening room along with an
external DAC.

Thinking about this made me wonder whether slimserver would have a problem
playing FLACs natively to the SB whilst still being able to play them to the
sp3s as well?

And what will happen if I synch an sp3 with a SB? Will the sb still be
playing the FLAC natively?

TIA

David Cullen

dean
2004-04-17, 12:53
Hi David,

On Apr 17, 2004, at 9:52 AM, David Cullen wrote:

> Not a techy so apologies if this is a dumb question...
>
> At the moment I have 2 sp3s which will end up in the dining room and
> main
> bedroom.
>
> I ripping all my CDs and encoding them with FLAC. At the moment I have
> lame
> & flac on the server so that the sp3s can play the flacs.
>
> My plan is to get a wired SB to put in the main listening room along
> with an
> external DAC.
>
> Thinking about this made me wonder whether slimserver would have a
> problem
> playing FLACs natively to the SB whilst still being able to play them
> to the
> sp3s as well?
Each can play independently and the appropriate conversions will happen
for each.

>
> And what will happen if I synch an sp3 with a SB? Will the sb still be
> playing the FLAC natively?
If you sync the two players, they both will be getting MP3 encoded data
in order to make sure that we can control the sync/latency.

-dean

Mr. JC
2004-04-17, 16:24
Hi again,
I'm getting the following install issues with all of the shorten, lame, etc.
packages I'm trying to install on my debian system.

My libc6 version is:
# dpkg -l | grep libc
ii libc6 2.2.5-11.5 GNU C Library: Shared libraries and
Timezone

seems like these packages demand a newer version of libc6. i'm reluctant to
upgrade libc6 and i cannot find source code version of lame.

any help is most appreciated since I just got this thing and I cannot get it
to go yet!!!

# apt-get install shorten
Reading Package Lists... Done
Building Dependency Tree... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.

Since you only requested a single operation it is extremely likely that
the package is simply not installable and a bug report against
that package should be filed.
The following information may help to resolve the situation:

Sorry, but the following packages have unmet dependencies:
xmms-shn: Depends: libc6 (>= 2.3.2-1) but 2.2.5-11.5 is to be installed
E: Sorry, broken packages

Mr. JC
2004-04-17, 16:27
I did manage to find the source for shorten 3.5.1, downloaded it to my
debian machine, compiled, and it appears fine. However, when I restart
slimserver, I get the following:

2004-04-17 17:54:49.4949 Reading WAV information from shorten -x
\/music1\/jgb81\-11\-12\/jgb1981\-11\-12d1t01\.shn - 2>/dev/null|
2004-04-17 17:54:49.5276 Warning: shorten -x
\/music1\/jgb81\-11\-12\/jgb1981\-11\-12d1t01\.shn - 2>/dev/null|: can't
move to position '44'
2004-04-17 17:54:49.5385 Reading WAV information from shorten -x
\/music1\/jgb81\-11\-12\/jgb1981\-11\-12d1t02\.shn - 2>/dev/null|
2004-04-17 17:54:49.5599 Warning: shorten -x
\/music1\/jgb81\-11\-12\/jgb1981\-11\-12d1t02\.shn - 2>/dev/null|: can't
move to position '44'

Yet, when I run "shorten -x" on any of the above files, it decodes to .wav
w/o a gripe.

ideas?