View Full Version : Missing Music

2008-10-26, 05:53
I've just noticed that a load of my library isnt showing up in SQ.
I use iTunes 8 and a nightly build from a few days ago.

There is a large difference between the two, 10 days worth out of the orignal 42. All my music is ether MP3 or Apple lossless, and no DRM.

I have scanned a couple of times to see if it would fined the extra music but with no luck.

I searched for missing music but couldnt see any other threads that had similar problems.


2008-10-27, 04:16
Having done another full scan and still having missing music.
Cannt even see any logic regarding what is present and what is missing.

2008-10-27, 04:28
I don't use iTunes or a Mac (I am guessing you are on a Mac and using a nightly 7.3... but you'll need to confirm to get reliable help) but as no-one else has replied I'll have a go.

Normally I'd assume that there was problem with your tags but you seem to imply that all has been OK up till now. I guess you can browse to all your music via Browse Music Folder?

You might consider enabling the scanner debug logging, running a new scan and then looking at the logs to see what they say......

or just wait till someone more aufait with iTunes/Mac stuff replies! :-)


2008-10-27, 05:41
I have added a load more music, and it sure does look like most of the missing is from it, but some of the new is present.

I am running version:
SqueezeCenter Version: 7.2.1 - 23614 @ Sat Oct 18 02:02:12 PDT 2008 - Windows XP - EN - cp1252

I will stick the debug logging on; I did look at the logs and wonder why they were blank!

Thank you.

2008-10-27, 06:56
I put (scan) - All Scan Logging to debug but when it finishes and I use the view log option it still appears to be empty.

2008-10-27, 08:54
I think your best best is to contact support. You may get some answers from the community here, but our support techs are likely in the best position to help you solve your problem.



2008-10-27, 11:24
I did log, but I've just fixed it!

It seems there was an old iTunes xml in the directory from when I was a PC bod.
Removed that, pointed SC at the right place and it is importing the right number of files.

Dont know how I also fixed it, but rather than take an hour for 8000 tracks it now looks like 10,000 is only going to take 15mins.