PDA

View Full Version : scan complete but not stopping!?



dcote
2008-10-16, 07:41
i am running:

SqueezeCenter Version: 7.2 - 22900 @ Tue Aug 26 10:59:02 PDT 2008 - Linux - EN - utf8
Server IP address: 192.168.0.102
Perl Version: 5.8.8 armv5tejl-linux-thread-multi
MySQL Version: 5.0.27
Platform Architecture: armv5tejl-linux
Hostname: Turbonas
Server Port Number: 9001
Total Players Recognized: 3

when i run the scan (new+changed as well as playlists only), it goes thorugh the motions and finishes with the usual "SqueezeCenter has finished scanning your music collection."

but the clocks on "Database cleanup #2" and "Total Time: xx:xx:xx" keep ticking. this morning it was 10:52:32 and counting! (i re-scan every night).

i have another thread open on the scanner (?), not sure if this has anything to do with it: http://forums.slimdevices.com/showthread.php?t=53828

apart from the clocks ticking, there does not seem to be any other indication that anything is wrong. somehow, i suspect the web UI is the culprit, not the scanner...

can i ignore this? and/or how do i read the scanner's log file correctly to find out if there is a problem?

thanks in advance,

dominique

sc53
2008-10-16, 11:37
I really cannot comment on the technical parts of your question, but will share with you that when i developed problems with the scanning on my system (Mac Leopard/SC 7.2) someone recommended downloading the 7.2.1 nightly release. I did so and the scanning function has been perfect ever since. Something to try if you don't get any better answers to your questions!

mfrost
2008-12-30, 06:09
I am seeing the exact same problem on version 7.3.1 on a QNAP 209.
The "Database Cleanup #2" will never end.

Version: 7.3.1 - 24372 @ Fri Dec 19 17:30:38 PST 2008
Hostname: FROSTNAS3
Server IP-adress: 192.168.1.39
Server HTTP Port Number: 9001
Operating system: Linux - DA - iso-8859-1
Platform architecture: armv5tejl-linux
Perl Version: 5.8.8 - armv5tejl-linux-thread-multi
MySQL Version: 5.0.27
Total Players Recognized: 1

dcote
2008-12-30, 06:13
actually, i must admit that i haven't seen this effect in a while. the only thing (i believe) i did was to clear out the DB and do a complete rescan (due a different bug).

wierd... is it reproduceable on your system or only sporadic? (like on mine)

mfrost
2008-12-30, 15:49
It is reproducable. Also after a complete rescan.

The strange part is that I have a 7.3.1 Squeezecenter installation on an Win XP PC, using the same Itunes library - and on this installation it works perfect without any problems!