PDA

View Full Version : ERROR: Missing Firmware.... ReadyNAS NV+



gurutek
2008-10-15, 16:19
Hi Chaps

After seeing the new release of the Squeezebox Boom, and it's seemless intergration with the ReadyNAS NV+ (Via the Squeezecentre Software Being Installed along with the latest Readynas formware), i decided to make the purchase and buy one.

After setting it up on my wireless network tonight, I've been plagued by one continuous error message that appears relentless, appearing every 5 seconds, and ultimatly rendering the operation of the BOOM useless!!

The Error Message:
"Error: Missing Firmware
Server can't connect ot internet to obtain firmware update"
Renders my device totally useless - It is IMPOSSIBLE to use the squeezebox boom - As this error message appears every 5 seconds and interupts whatever you are doing!

For further information I have included my squeezecenter Log file:

2008-10-01 21:42:48 squeezecenter_safe started.
[08-10-01 21:43:33.5638] Slim::Utils::Misc::msg (1398) Warning: [21:43:33.5577] Use of uninitialized value in sprintf at /usr/share/perl5/Slim/Utils/MySQLHelper.pm line 354.
[08-10-01 21:43:48.4405] Slim::Utils::Misc::msg (1398) Warning: [21:43:48.4348] Downloading firmware from http://update.slimdevices.com/update/fi ... box_10.bin, please wait...
[08-10-01 21:44:00.9224] Slim::Utils::Firmware::download (358) Warning: Successfully downloaded and verified /usr/share/squeezecenter/Firmware/squeezebox_10.bin.
[08-10-01 21:44:00.9338] Slim::Utils::Misc::msg (1398) Warning: [21:44:00.9284] Downloading firmware from http://update.slimdevices.com/update/fi ... box_40.bin, please wait...
[08-10-01 21:44:13.3751] Slim::Utils::Firmware::download (358) Warning: Successfully downloaded and verified /usr/share/squeezecenter/Firmware/squeezebox_40.bin.
[08-10-01 21:44:13.3863] Slim::Utils::Misc::msg (1398) Warning: [21:44:13.3809] Downloading firmware from http://update.slimdevices.com/update/fi ... ter_62.bin, please wait...
[08-10-01 21:44:30.5698] Slim::Utils::Firmware::download (358) Warning: Successfully downloaded and verified /usr/share/squeezecenter/Firmware/transporter_62.bin.
[08-10-01 21:44:30.5811] Slim::Utils::Misc::msg (1398) Warning: [21:44:30.5757] Downloading firmware from http://update.slimdevices.com/update/fi ... x2_112.bin, please wait...
[08-10-01 21:44:48.5193] Slim::Utils::Firmware::download (358) Warning: Successfully downloaded and verified /usr/share/squeezecenter/Firmware/squeezebox2_112.bin.
[08-10-01 21:44:49.5303] Slim::Schema::init (161) Warning: Creating new database - empty database or database from 6.3.x found
[08-10-01 21:45:33.6339] Slim::Utils::PluginManager::enablePlugins (411) Couldn't load Slim::Plugin::PreventStandby::Plugin. Error: Plugin is incompatible with your platform.
[08-10-01 21:45:40.7149] main::checkDataSource (904) Warning: Schema updated or no tracks in the database, initiating scan.
[08-10-01 21:46:14.2825] Slim::Utils::Firmware::downloadAsyncError (500) Warning: Firmware: Failed to download http://update.slimdevices.com/update/fi ... 73.bin.sha (Validation of firmware /var/lib/squeezecenter/cache/jive_7.2_r2873.bin failed, SHA1 checksum did not match), will try again in 10 minutes.

My Readynas NV+ is running the latest firmware - Radiator 4.1.3.

I hope we can have some resolution to the problem, as I've especially gone out and bought a Squeezebox Boom because it's supposed to intergrate seemlesly with my Readynas NV+. Until it's fixed the squeezebox is useless!

Cheers
Robbie

gurutek
2008-10-15, 16:25
O ya

Thought it may be useful if I posted my Squuezecenter Info:

SqueezeCenterSqueezeCenter Version: 7.2 - 22900 @ Tue Aug 26 11:25:48 PDT 2008 - Netgear RAIDiator - EN - utf8
Server IP address: 192.168.0.2
Perl Version: 5.8.8 sparc-linux
MySQL Version: 5.0.24a-Debian_3.infrant1

Platform Architecture: sparc-linux

Hostname: NAS

Server Port Number: 9000

Total Players Recognized: 1


Player InformationName: Squeezebox Boom

Model: boom

Firmware: 33

The IP address for this player is: 192.168.0.16:40336

The Ethernet MAC address for this player is: 00:04:20:1e:7f:16

Wireless Signal Strength: 66

andyg
2008-10-15, 16:25
Try the official build, not the one that ships with the ReadyNAS:

http://www.slimdevices.com/su_downloads.html

gurutek
2008-10-15, 16:43
Will do - If I could figure out how to uninstall the original one, then install the BIN file on a LINUX readynas....... Hmmmmm.............. Come to thionk of it - I don't want to brick my readynas with my whole life on it........

Is there not an easier option?

Anoop M.
2008-10-15, 17:12
I don't usually post instructions like this but I think this may help you resolve your issue.

To perform a clean install of Squeezecenter on your ReadyNAS, try the following:

- Download the following files from the ReadyNAS download page

1. CleanSlimServer found here: http://www.readynas.com/?page_id=94

2. Radiator version 4.01c1-p1(or whatever it may be at the moment) found here: http://www.readynas.com/?page_id=102
* This is the latest firmware release for your ReadyNAS

3. Squeezecenter 7.2 for the ReadyNAS found here: www.slimdevices.com/su_downloads.html

Place those files in a folder on your desktop

- Run RaidAR, then click on Setup and login to the ReadyNAS admin page

Update ReadyNAS Firmware

- On the admin page, go to System > Update > Local tab

1. Click on Browse and browse to the folder you stored the files in earlier

2. Select the Radiator 4.01c1-p1 file and click "Upload and verify image..."

3. Once the file uploads, click on "Perform System Update"

4. Once the update is finished, go to the Shutdown tab and "Shutdown and reboot your device", then click apply

Once your ReadyNAS boots up, log into the admin page again and move on to the next step

Run CleanSlimServer

- On the admin page, go to System > Update > Local tab

1. Click on Browse and browse to the folder you stored the files in earlier

2. Select the CleanSlimServer file and click "Upload and verify image..."

3. Once the upload is finished, click on "Perform System Update"

4. You will be prompted to restart the ReadyNAS and directed to the Shutdown tab, select "Shutdown and reboot your device", then click apply

Once your ReadyNAS boots up, log into the admin page again and move on to the next step

Remove previous version of Slimserver/Squeezecenter and install new version

- On the admin page, to to Services > Streaming Services

1. Check the box next to SlimServer, then click on Remove in the same section

2. Now, go to System > Update > Local tab

3. Click on Browse and browse to the folder you stored the files in earlier

4. Select the Squeezecenter 7.2 file and click on "Upload and verify image..."

5. Once the upload is finished, click on "Perform System Update"

6. Once the update is finished, go to the Shutdown tab and "Shutdown and reboot your device", then click apply

This should get you to a state where you can upgrade the firmware on your Boom.

thanel
2008-10-15, 23:53
i had the same problem - the above solution should do the trick and isn't as involved as it appears.

gurutek
2008-10-16, 14:00
Hi Anoop

Thanks for the reply.......

I tried what you said, but unfortunatly it hasn't worked, and I now have two new problems, and these are:

Initially the squeezecentre install worked on my Readynas, but when trying to connect my Squeezebox Boom to the squeezecentre, my Boom just froze on the "connect" screen :(
Following a reboot of the Readynas I tried to connect my boom to the squeezecentre, but got "Cannot connect ot Squeezecentre" error message, and when I tried to get to the squeezecentre via IE, it just wouldn't return any results................

So even though it appears to have been re-installed, it now doesn't work at all!

PLEASE HELP.

Anoop M.
2008-10-16, 15:15
Are you sure SqueezeCenter is running?

gurutek
2008-10-16, 15:19
Yes, the squeezecentre is running.

I have just re-blasted my box with the full readynas firmware (RAIDiator-4.1.4), and even now I can't get the SlimCentre to work :(

IE just can't establish a connection with port 9000 (Squeezcentre).

WTF?

Anoop M.
2008-10-16, 15:22
Do you have any firewalls within your router?

If so...as a test turn them off and lets see if you are able to bring up the web interface.

gurutek
2008-10-16, 15:48
Hi Anoop

Turned off windows firewall - Still the same issue?

Even tried it from an XP machine - Still the same.......

Anoop M.
2008-10-16, 15:50
Sorry I might not have made myself clear....Try to see if there is a firewall in your Router.

mherger
2008-10-16, 22:54
You said SC was running, but you couldn't access it. How do you know it
really is running? After all it doesn't allow you to connect neither a
player nor to its web UI.

Any updated server.log?

Michael

gurutek
2008-10-17, 07:55
Hi Chaps

Thanks for all your reply's. Well, the radynas developers obviously are some issues to iron out with the integration of the squeezecentre. Don't really know what the problem was (something to do with the squeezecentre DB), but I found the solution - Basically you need to download an addon called: CleanSqueezeCenter_DB from http://www.readynas.com/?page_id=617. Once this rebuilds the squeezecenter DB you are able to get back into the squeezecentre - Phew................

Now I need to retry connecting my Boom to the squeezecntre (Currently waiting to rescan my music library) and see if i still get the first annoying error message....... Hope Not!!!

Cheers
Robbie

watsonneil
2008-11-08, 11:36
Be very careful following this advice! I followed the instructions on the firmware update and I now have a ReadyNAS which complains that it has 'bad disks detected'. Fantastic! It worked fine before, the Duet complained about not being able to update so I followed the official (looking) instructions and I now have a non-working Duet and my ReadyNAS is broken.

Thanks for the advice. The Duet is obviously not the plug'n'play device I'd hoped for. But not only that, it's broken a perfectly good device which was fine until I installed the bl**dy Duet.

edickon
2009-02-16, 16:55
Up to this point my ReadyNAS Duo has been complaining that it couldn't connect to the internet to get firmware upgrades. Basically sat there.

I tried this solution, I did everything asked of me, including the clean Squeeze Centre. Also made sure windows firewall is off. Now when I try to set up squeeze centre from within the ReadyNAS Duo page it just gives me a page load error.

Any help appreciated here - I understand that this is all pretty new technology but it is doing my head in... Still trying to persuade my wife this was a good idea...