PDA

View Full Version : Wireless Range Expander with Duet Controller



ajkidle
2008-10-15, 05:26
Sorry if this is the wrong forum for this post -- there doesn't seem to be a dedicated "network issues" forum, so I guess general is as good a place as any.

I've discoved that plaster walls combined with the chimney running through the middle of my house is not a friendly setup for WiFi. Or, at least it weakens the signals enough to cause problems for my SBC. In hopes of solving this, and to pave the way for getting WiFi out to the deck for a future Boom, I picked up a Linksys wireless range expander (WRE54G). This is mated with my Linksys WRTP54G -- one of their routers with VOIP built in. Both are using the same SSID and same WPA settings. They see each other and life is grand.

But not quite. I had hoped that the WRE54G would just boost the signal throughout the house. But now I've come to understand (I think) that a WiFi device such as the SBC attaches itself to a particular access point. So if I'm close to my router when I turn on the SBC, it links itself to the router. And similarly, if I'm close to the range expander when I turn on the SBC, it links itself to the expander. But if I move from one side of the house to the other, the SBC doesn't roam with me -- it holds on to that original (now very weak) connection.

Is there someway to make the SBC "wander" and grab the stronger access point's signal as I move throughout the house? If not automated, is there a way to manually force the controller to reconnect to the other AP without cycling the SBC's power?

One other quick note, I have version 3 of the WRE54g which does not allow you to use a different SSID than the router's. Older versions allowed this, which could have been a potential (albeit messy) solution, but no dice.

Any ideas? Or am I doing something obviously wrong with this configuration?

Thanks,
Andy

Skunk
2008-10-15, 07:05
Roaming support is supposedly coming with SC 7.3. http://forums.slimdevices.com/showthread.php?t=53361

In the meantime, it might be easier to manually roam if you added 'Wireless Network' to the Controller's home menu.