PDA

View Full Version : Intermittent Controller problems



MeSue
2008-10-13, 19:53
I have had my controller for about 2 weeks now and for the most part, I love it. But every once in a while, when I pick it up from the cradle, it will not scroll. I can move forward and back through the screens, but can't scroll anything up or down. Then sometimes when I back out of a menu and go back in, the menu will be all out of order, or the menu will have one item repeated all the way down. Restarting the controller resolves the problem.

I'll have to do more testing to be sure, but I think it might be happening after I have restarted the SqueezeCenter service for some reason, such as installing a plugin.

SqueezeCenter Version: 7.2.1 - 23460 @ Wed Oct 8 02:52:48 PDT 2008 - Windows Server 2003 - EN - cp1252

Has anyone else experienced this?

MeSue
2008-10-16, 08:54
Last night I restarted SqueezeCenter and my Controller went wacky again. It took 3 restarts of the Controller before all the menu items would display. Then when I would go to now playing and press the button to get the full playlist, all I would get is a blank page. No amount of restarts would allow me to see the now playing list.

Then this morning I restarted my whole server and all is back to normal. Very strange.

iPhone
2008-10-16, 09:40
I have had my controller for about 2 weeks now and for the most part, I love it. But every once in a while, when I pick it up from the cradle, it will not scroll. I can move forward and back through the screens, but can't scroll anything up or down. Then sometimes when I back out of a menu and go back in, the menu will be all out of order, or the menu will have one item repeated all the way down. Restarting the controller resolves the problem.

I'll have to do more testing to be sure, but I think it might be happening after I have restarted the SqueezeCenter service for some reason, such as installing a plugin.

SqueezeCenter Version: 7.2.1 - 23460 @ Wed Oct 8 02:52:48 PDT 2008 - Windows Server 2003 - EN - cp1252

Has anyone else experienced this?

In 6 months, this has happened to me twice. Once after a SBC firmware upgrade so I rebooted the Controller and all was well. I assumed it was the due to the firmware update. It happened again about two weeks ago. I had been using the SBC for about 4 hours then we went out to dinner and I didn't put it in the cradle. I picked up the SBC when we got home so I could set/adjust my alarms and I had no Scroll Wheel control. I shut the SBC off. Turned it back on, No Joy. Pulled the Battery and it was now to low to power up full, it went to 'Low Battery' warning so I removed the battery again and put the battery from my pre-production SBC in and all was fine.

I didn't have any SC restarts during these two events. I assumed it was an update issue the first time (might have been, might not) and the second I have no idea what might have caused it.

There is one thing I did notice both times. I have the "clicker' turned on so that I hear something happening when I move the scroll wheel. Both times no sound whne scrolling. That tends to make me thing that output receiver is off. No sound, no movement because a signal is not being generated.

Sue, did you have "clicking" when the scroll wheel stopped working?

MeSue
2008-10-16, 09:57
Sue, did you have "clicking" when the scroll wheel stopped working?

I have sound effects turned off for scrolling. All other sound effects are on but very low volume.

maggior
2008-10-16, 18:53
I reported a problem where under certain artists in my music collection, the UI on the controller would hang when I accessed their albums and it would eventually reboot the controller.

There were also some goofy things I'd see in the UI at times - outdated status info on the screen, menu selections that would not highlight, etc.

They have recently submitted a fix and it resolved all of my issues with the controller. I think the problem they fixed was a pretty general issue that could impact many things. It was listed as a critical issue.

You might want to try updating to this version of the controller software and see how it goes.

This is the bug report that all controller hanging/crashing issues got merged into. Toward the end, you will find a location and instructions on updating the controller software:

http://bugs.slimdevices.com/show_bug.cgi?id=9554

The version I installed was 3080 and it has been working great for me since last Sat.

Updating doesn't require updating SqueezeCenter, which is good. I'm not ready yet to move to 7.3.

MeSue
2008-10-16, 19:31
The version I installed was 3080 and it has been working great for me since last Sat.

Thanks. I think I already have this. My Controller reports version 7.2 r3080 Oct. 10.


I'm not ready yet to move to 7.3.

I want to, but not brave enough yet. Too many plugins I NEED! ;-)

iPhone
2008-10-16, 19:43
Thanks. I think I already have this. My Controller reports version 7.2 r3080 Oct. 10.



I want to, but not brave enough yet. Too many plugins I NEED! ;-)

We are all addicted to our plugins aren't we! I truly think that is one of the reasons that Squeezebox will always win out over Sonos with the Techies, Nerds, and anybody that just doesn't have to have a single box that you can just feed it CDs and your done. Of course that feed it CDs market still has a fairly steep buy in price.

maggior
2008-10-16, 20:23
Thanks. I think I already have this. My Controller reports version 7.2 r3080 Oct. 10.



I want to, but not brave enough yet. Too many plugins I NEED! ;-)

You're just too on top of things :-).

Yeah, I hear you regarding plugins. When I updated to 7.2, my weather/time plugin stopped working. I just could not get used to just having the date and time on my SB when it was off. Thankfully somebody fixed it pretty quickly. It is really the only 3rd party plugin that I really care about, so I'm not that bad off.

Like you guys, the plugins are a differenting feature to me.

MeSue
2008-10-17, 17:44
And speaking of plugins, it seems that my plugins are somewhat related to this issue. Here is what I have discovered...

This is definitely happening when SC is restarted, but only after adding or updating plugins. And it is only the settings menu that is affected.

Does anyone want to try to replicate it? Steps are:

1. Have Controller cradled (not sure if this matters, but mine is always cradled when not being used.)
2. Install or update a plugin (I don't *think* it matters which one, but I have updated MusicInfoSCR a lot recently and that's how I started noticing this)
3. Restart SqueezeCenter (I do it using the services console in Windows)
4. Once SC is back up, pick up Controller from cradle, navigate to Home > Settings, and try to scroll.

In my case, scrolling won't work until I restart the Controller.

MeSue
2008-10-18, 16:30
Well, I discovered I can fix this without restarting the Controller by switching to a different player and back. I'm still curious if it happens to anyone else...

peterw
2008-10-18, 18:21
Well, I discovered I can fix this without restarting the Controller by switching to a different player and back. I'm still curious if it happens to anyone else...

Yep. I don't use my Controller much, but sometimes will pick it up & see blue or red in the wifi indicator area (even though it's cradled in the same room as my AP, 10 feet of nothing but air separating them). When this happens, I can't do much unless I change players. Thankfully I have more than one. :-)

I've seen some odd stuff like: with a bad wifi indicator, I could go to Home > Settings > Player sleep and try to send a command. After manually switching players, the sleep command is executed. I expect the sleep command is stuck in the HTTP request queue, and switching players makes the Controller re-establish its connection to SC7.