View Full Version : Bug 9377: SC on Vista fails with a BEEP

2008-10-06, 17:21
We're trying to find some more information about bug 9377. http://bugs.slimdevices.com/show_bug.cgi?id=9377

The symptoms are: when you try to run SC (whether as an application or a service) on Vista, the PC makes a beep sound, and SC fails to start.

A server log shows a message of

[08-08-25 14:25:20.6826] Slim::Utils::Prefs::__ANON__ (269) Error: can't create new preferences directory at Profiles\All Users\Application Data\SqueezeCenter\prefs

Has anyone seen this, or solved it, or have any theories how we could reproduce this? It doesn't affect all users, but the affected ones are stopped dead.

The fact that not all users are affected leads me to think it might have to do with some windows setting, or particular virus software installed.

Thanks for any info!

2008-10-06, 18:46
I haven't developed anything for Vista, and don't even have a Vista system, but should you be using AppData instead of Applicaton Data?

2008-10-07, 08:33
We asked Michael Herger about that and he thought the old way should still work.

2008-10-07, 08:39
I know for a fact that the old (Windows XP style) paths still work - for example, you can still get to "C:\documents and settings\default user" to mount the default user registry hives - but you might try using the new ones anyway. I would certainly defer to Michael in terms of the programming aspects of this issue.

I'm sure you've checked this, but do the machines in question have UAC turned on? If so, differing credential levels might be a factor...and who is the service running as? I can see a scneario where the service runs in a context where UAC pops up an "are you sure you want to do the thing you just explicitly asked me to do?" message, but becuase it's not running in the context of the interactive user, you don't see it, and can't click through...but that is a shot in the dark. I see that a lot with silent/elevated credential installs and software deployment systems.

Important to note, though, now that I think about it, that UAC is a system wide setting, not a per-user setting. So less of what I said above makes sense. Either way, I would disable UAC if it's turned on, and see if you get the same error. Also worth noting that the administrator in Vista isn't really an administrator...you'll notice you can right click things and either "Run" or "Run as Administrator." So maybe that's causing an issue somewhere? Obviously, I think you might be running in to the joys of Vista permissions.