PDA

View Full Version : 7.2 Default skin has no track skip buttons?



horseflesh
2008-10-01, 17:31
I see << and >> buttons, but no controls for the previous/next track as seen in Fishbone.

Using Winamp as a client, the << >> buttons don't seem to do anything at all. Is there a way to add track skip to the default skin? I know I can click in the playlist, but that isn't always convenient.

Thanks!

mherger
2008-10-01, 23:39
> I see << and >> buttons, but no controls for the previous/next track as
> seen in Fishbone.

What would you expect the above buttons to do?

Michael

horseflesh
2008-10-01, 23:48
The << >> buttons do not do anything, with a click or click-hold, in the Default skin or Fishbone. The Previous/Next track skip buttons work as expected, but the Default skin does not have them.

mherger
2008-10-02, 00:39
> The << >> buttons do not do anything, with a click or click-hold, in the

They're exactly this: Previous/Next. Don't they work? What kind of player are you using?

> Default skin or Fishbone. The Previous/Next track skip buttons work as
> expected, but the Default skin does not have them.

It's a bit confusing, but the << >> buttons in Fishbone aren't the same, but they're fast forward/rewind (within a track).

--

Michael

bpa
2008-10-02, 01:50
User interface and capabilities change with versions.

What players and SC/SS version are you using ?

Are you still using SS 6.2.x ?

Are you trying the >> and << with Winamp or Roku M1000 ?

horseflesh
2008-10-02, 10:53
OK, so they are track skip controls, good... but they still don't work!

I am using Winamp at the moment but I have also tried Windows Media Player. I haven't tested it at home with my Roku M1000 yet.

Anyway, in the Default skin, the << >> buttons do not do anything *at all.* The web display is unchanged. It's like this in FF 3.03 and the latest IE7.

If that is a consequence of using a streaming mp3 client instead of a real hardware client, that's just life and I will use another skin, but I would like to file a bug. :)

kdf
2008-10-02, 11:31
If that is a consequence of using a streaming mp3 client instead of a real hardware client, that's just life and I will use another skin, but I would like to file a bug. :)

When you do, add this log snippet:

[11:21:33.5906] Slim::Control::Request::execute (1887) Error: While trying to run function coderef [Slim::Control::Commands::buttonCommand]: [Can't usean undefined value as an ARRAY reference at C:/slim/7.3/server/Slim/Hardwar/IR.pm line 506.]

stream.mp3 doesn't have ir support, and the code doesn't initialise any ir handling for it. Therefore, it causes the above error and you get no result from the click.

-kdf