PDA

View Full Version : Slow indexing of a new shared drive (XP)



Kevin Hawkins
2004-04-09, 13:04
Dean - The library is 100K tracks. This 'blanking' has been a problem to me
on many different machines and builds of the server - always Windows - I
just thought it was how it worked. It is ok on artist seraches but on track
names or even worse pressing 'random play all' it stalls for two mins or
more - always embarrasing during demos ....

BTW - how many RAM sockets are there on the LaCie motherboard and how many
used for the 128K ??

Now some good news.....

I think I've sorted my problem with the NAS drive BTW ;-) It is either
caused by

1) The residual database cache file from the previous build hanging
around and screwing things up. I have now manually deleted the file from the
server folder and started again. Now on start the Slim players do not blank
at startup.
Significantly at startup the shared drive is now accessed instantly
(cf at least 30 mins wait before) which makes me think this is a DB cache
problem.
I am in now way convinced on the database cache functionality in the
Windows builds - does it work effectively for other people ???

OR

2) The fact that the shares were accessed using a different username
/ password to the user that I was logged into Windows with. ie I had to
manually provide the new user/pw details at the time I created the shortcut.
Now logging in with the same username/password as the share - and with the
drives now showing up under 'My Network Places' it works fine.
Interestingly before I manually added the shortcut (Create Shortcut) but
now I have 'copied' the drive from My Network Places and 'pasted shortcut'
to the library folder. The icon is different in that it doesn't have the
little shortcut 'arrow' anymore. Is this significant ? It was definitely
created with 'paste shortcut'.

My indexing speed is now back to about 20 tracks per second from 1
every 5 secs that is a big difference. Two orders of magnitude :-) Looks on
target for about a 2 hour index - which although twice as long as the
'other' app is back in the realms of reasonable again and about what I had
with the two USB2 network shares.



Kevin

> -----Original Message-----
> From: discuss-bounces (AT) lists (DOT) slimdevices.com
> [mailto:discuss-bounces (AT) lists (DOT) slimdevices.com] On Behalf
> Of dean blackketter
> Sent: 09 April 2004 17:49
> To: Slim Devices Discussion
> Subject: [slim] Slow indexing of a new shared drive (XP)
>
> On Apr 9, 2004, at 9:11 AM, Kevin Hawkins wrote:
>
> > Yep - that was the next step - but I had some worries
> over the RAM in
> > the disk which is 128MB, I wanted to get that upgraded
> to 512MB but am
> > not sure if it socketed even. Opening the case voids the
> warranty :-(
> > . This was a first step - getting all the music on there.
> I've opened mine and it's a mini-itx motherboard with
> regular socketed RAM.
>
> > - before on my server it really struggled with 256MB
> RAM, almost
> > everything took ages - it still does a little with 512K
> but it is much
> > better.
> > Searching for a song by title will still blank the Slim
> players for a
> > good 2 mins though ...
> Wow, that shouldn't happen. How big is your library.
>
> -dean
>
>