PDA

View Full Version : Can't play Albums from Controller



rksingla
2008-09-24, 19:39
My squeeze setup (Duet and SqueezeBoom running off SC 7.2 on a ReadyNAS Duo) has been working great until last night. Suddenly the controller refused to play albums. All other functions worked, and i coudl play an album by hitting play on one of the tracks. But it will not play the entire album by hitting play when the album is selected. It seems to be working fine when i play an album from SC directly, but not from the controller.

I tried rebotting the NAS, and the Controller. I also tried a full rescan. No change.

Any ideas?

rksingla
2008-09-24, 22:27
in case it helps any, here are the log entries produced when i try to play an album:

[08-09-24 22:21:49.1532] Slim::Control::Commands::playlistcontrolCommand (1630) Begin Function
[08-09-24 22:21:49.2962] Slim::Control::Request::execute (1800) Error: While trying to run function coderef [Slim::Control::Commands::playlistcontrolCommand]: [Can't call method "name" on an undefined value at /usr/share/perl5/Slim/Control/Commands.pm line 1807.
]

rksingla
2008-09-26, 08:51
In case anyone experiences the same problem, I resolved it finally by using the SC database cleanup script available on the ReadyNAS site and then doing a full rescan.

mvalera
2008-09-26, 15:48
You might try Netgear Support. They provide support for SqueezeCenter running on their hardware.

Mike