PDA

View Full Version : Softsqueeze v0.3 startup problems



Oliver Cookson
2004-04-08, 06:56
Yes but they are all in the same directory.

You need to extract the ZIP to the correct struct, there is a "/lib"
folder which needs to be created with the correct libraries inside.

It may be worth noting in some form of installation instructions as
quite a few people have been stumped by this (it took me a few looks to
realise I was being stupid).

HTH

Cheers

-----Original Message-----
From: Donald B. Lagosz-Sinclair [mailto:dbls (AT) comcast (DOT) net]
Sent: 08 April 2004 14:40
To: Slim Devices Discussion
Subject: [slim] Softsqueeze v0.3 startup problems

I get the same message ("Could not find the main class...") no matter
how I run it. All the files that came in the SoftSqueeze zip file are
present:

File Name Size Date Last Mod.
---------------------------- ------- ---------------------
jl0.4.jar 106,732 6 Apr 2004 8:33 pm
LICENSE.txt 18,349 23 Mar 2004 11:22 am
log4j-1.2.8.jar 352,668 6 Apr 2004 8:33 pm
ostermillerutils_1_03_00.jar 413,169 4 Apr 2004 8:28 pm
SoftSqueeze.jar 942,645 6 Apr 2004 8:34 pm

Donald B. Lagosz-Sinclair
2004-04-08, 10:58
The eureka moment!

I hadn't noticed that some of the files had a different path in the ZIP file.
In my experience, most ZIP files I've downloaded extract to a single directory.
At best (for Windows users, anyway), package it in a self-extracting file that
eliminates the possibility of someone missing that step; at the least, the web
site should say that the "Use folder names" checkbox must be checked,
especially since the "path" column could be scrolled off to the right in the
WinZip window.

Very nice interface; a couple of observations/suggestions:

1. Since there are two windows (and two icons when switching tasks), could
we have different captions, e.g. "SoftSqueeze" and "SoftSqueeze Remote"?

2. The volume control seems to have no effect.

-:- dbls

----- Original Message -----
From: "Oliver Cookson" <OCookson (AT) 3t (DOT) co.uk>
To: "Slim Devices Discussion" <discuss (AT) lists (DOT) slimdevices.com>
Sent: Thursday, April 08, 2004 9:56 AM
Subject: [slim] Softsqueeze v0.3 startup problems


> Yes but they are all in the same directory.
>
> You need to extract the ZIP to the correct struct, there is a "/lib"
> folder which needs to be created with the correct libraries inside.
>
> It may be worth noting in some form of installation instructions as
> quite a few people have been stumped by this (it took me a few looks to
> realise I was being stupid).
>
> HTH
>
> Cheers
>
> -----Original Message-----
> From: Donald B. Lagosz-Sinclair [mailto:dbls (AT) comcast (DOT) net]
> Sent: 08 April 2004 14:40
> To: Slim Devices Discussion
> Subject: [slim] Softsqueeze v0.3 startup problems
>
> I get the same message ("Could not find the main class...") no matter
> how I run it. All the files that came in the SoftSqueeze zip file are
> present:
>
> File Name Size Date Last Mod.
> ---------------------------- ------- ---------------------
> jl0.4.jar 106,732 6 Apr 2004 8:33 pm
> LICENSE.txt 18,349 23 Mar 2004 11:22 am
> log4j-1.2.8.jar 352,668 6 Apr 2004 8:33 pm
> ostermillerutils_1_03_00.jar 413,169 4 Apr 2004 8:28 pm
> SoftSqueeze.jar 942,645 6 Apr 2004 8:34 pm
>
>