PDA

View Full Version : Wireless Network Problems



jparton
2008-09-15, 13:18
Hi, new to the Duet and these forums, be gentle ;-)

I did search the forums but couldn't find a solution.

I'm baffled with connecting my Duet to my Wireless network.

It was working fine with the router I had when I first installed the Duet.

I decided to upgrade my router to solve some other issues I was experiencing, now I can't get the Duet to connect to my WiFi on the new router (a Belkin F5D9630-4Av1_UK_1.00.04)

I've configured my router firewall and the windows firewall as instructed on the Slim Devices website (screen shots of both attached) and all I get is "Lost Sqeezebox" errors on the controller. It does see the SSID of the WiFi but just won't connect.

The minute I plug in the old router it connects again, but I don't want to use this router long term - I've compared the settings on both routers side by side, and I can't see any config difference, yet it will not attach to the Belkin.

Apart from the Firewall configs I've reset all the devices, etc...

Anyone got any suggestions?

Thanks in advance.

jparton
2008-09-20, 01:06
bumping to see if anyone can help...

radish
2008-09-20, 16:54
Well first off if you're just using devices on your local network you shouldn't have any ports forwarded on the router. That's not causing your problem, but it's a security issue.

How's the router setup - security options etc. I'd recommend initially turning off WPA and anything else (e.g. MAC filtering) for testing.

jparton
2008-09-21, 02:41
Thanks for the suggestion Radish.

On the Controller I can go into Advanced Settings and it says it is connected to my home WiFi in the status, and all the data is filled out on the Network Status screen including "SNR:" with a moving number (not sure what that is) so it leads me to suspect that the Squeezebox is connected ok.

As in my previous post the weird thing is despite saying it's connected I can't see my music source from my PC so I have nothing to play!

th00ht
2008-09-21, 03:22
Hi, This can all be a bit baffling. Replacing a router isn't that simple these days...

Thinks to check:
1) After replacement of the Router do all devices have the same IP addresses as before? and hostname? Routers normally have a DHCP server implemented that hands out IP Addresses. The new router does not know anything of the previous one so that could be the problem. I do not know what SC will do when it sees the same hostname (SqueezeBox name) with a different IPAddress. Anybody?

2) Your probably did this but just for completeness: Reset the network settings on the squeezebox by unplugging and replugging it and redo the network setup.

3) If possible connect the SqueezeBox with a ethernet cable to see it this helps things.

jparton
2008-09-21, 07:57
Humm, I switched off my security (WEP) on the router and it now works - less than ideal but I guess better than nothing!

Nope spoke too soon, went back after 60 min and it's lost the connection again, what a load rubbish this thing is!

jo-wie
2008-09-21, 10:40
Do you use the same radio channel as on the old wlan router? Do you have neighbors with wlan routers? Interferences can be an issue.

Why do you not use WPA/WPA2 security?

jparton
2008-09-22, 09:54
After speaking to Belkin customer support it now works.

I changed so many things I did not do them in order to isolate the cause, but one of the following (or a combination of all) fixed it:

- I changed to 128bit WEP encryption from 64bit
- I changed the wireless channel my router was using
- I upgraded the router firmware

Now all seems to be working, the only weird thing is neither of the two Squeezebox components appear in the my routers DHCP list...

jo-wie
2008-09-23, 03:46
Units are only shown in the DHCP list when a system leased an IP address from the DHCP server. Fixed IP systems or systems which got the addresses from another DHCP server (which you should disable) are not shown.

I highly recommend that you change you security to WPA/WPA2 when your system is stable. If you're using WEP you can also completely disable security on your WLAN router.

And you should disable the port forwarding in your router configuration, otherwise "everybody" from the Internet can access your SqueezeCenter.