PDA

View Full Version : Squeezebox2 Wireless Headaches



cliffo
2008-09-10, 00:23
Hi All,

I keep getting drop outs on my wireless LAN with my SB2.

I am running a Billion 7404-VGP-M with WPA security. Using an external HDD connected via USB2 on a Dell Inspiron 6400 laptop.

When I connect via ethernet it works flawlessly.

The music will play for a random amount of time, sometimes I even get through an entire song but never more than 5 minutes before the SB2 will just stop playing and display a "Connection Timed Out" message. Often teh display will go blank as well before coming back on but not starting the music again.

Here' the latest info from the log:

[08-09-10 17:17:12.4330] Slim::Player::Source::errorOpening (1759) Error: While opening current track, so mark it as already played!
[08-09-10 17:17:12.4334] Slim::Player::Source::errorOpening (1759) Backtrace:

frame 0: Slim::Utils::Log::logBacktrace (/<C:\PROGRA~1\SQUEEZ~1\server\SQUEEZ~1.EXE>Slim/Player/Source.pm line 1759)
frame 1: Slim::Player::Source::errorOpening (/<C:\PROGRA~1\SQUEEZ~1\server\SQUEEZ~1.EXE>Slim/Player/Squeezebox2.pm line 646)
frame 2: Slim::Player::Squeezebox2::failedDirectStream (/<C:\PROGRA~1\SQUEEZ~1\server\SQUEEZ~1.EXE>Slim/Networking/Slimproto.pm line 612)
frame 3: Slim::Networking::Slimproto::_disco_handler (/<C:\PROGRA~1\SQUEEZ~1\server\SQUEEZ~1.EXE>Slim/Networking/Slimproto.pm line 421)
frame 4: Slim::Networking::Slimproto::client_readable (/<C:\PROGRA~1\SQUEEZ~1\server\SQUEEZ~1.EXE>Slim/Networking/IO/Select.pm line 248)
frame 5: (eval) (/<C:\PROGRA~1\SQUEEZ~1\server\SQUEEZ~1.EXE>Slim/Networking/IO/Select.pm line 248)
frame 6: Slim::Networking::IO::Select::select (slimserver.pl line 531)
frame 7: main::idle (slimserver.pl line 481)
frame 8: main::main (slimserver.pl line 90)
frame 9: PerlSvc::Interactive (/<C:\PROGRA~1\SQUEEZ~1\server\SQUEEZ~1.EXE>PerlSvc.pm line 99)
frame 10: PerlSvc::_interactive (slimserver.pl line 0)
frame 11: (eval) (slimserver.pl line 0)

It's obviously a wireless issue of some kind as via ethernet I have no problems at all.

I have tried changing the wireless channel, wireless power on the Billion all to no avail.

Is anyone able to provide any clues as to what is the problem and way to fix it.

Thanks in advance,
cliffo

cliffo
2008-09-10, 23:10
anyone have any ideas, tips or suggestions?

cheers,
cliffo

Phil Leigh
2008-09-10, 23:48
Try setting a static IP for the laptop and SB. It superficially appears that something (software activity) on the laptop is interfering with the playback OR something is interfering with your wireless network. The latter seems more likely.

Start by running the SqueezeCenter network tests. Help - Server & Network Health

cliffo
2008-09-11, 00:53
Hi,
Thanks for the reply. I do have static IP's set on both the laptop and the SB2.

Here's the result of the tests

SERVER TEST @ 5000kbps

< 10 : 0 : 0%
< 20 : 0 : 0%
< 30 : 0 : 0%
< 40 : 0 : 0%
< 50 : 0 : 0%
< 60 : 0 : 0%
< 70 : 0 : 0%
< 80 : 0 : 0%
< 90 : 0 : 0%
< 95 : 1 : 0%
< 100 : 0 : 0%
>=100 : 301 :100% #################################################
max : 100.000000
min : 91.233766
avg : 99.970973



NETWORK TEST
Server Response Time

The response time of the server - the time between successive calls to select.
< 0.002 : 371577 :100% #################################################
< 0.005 : 238 : 0%
< 0.01 : 138 : 0%
< 0.02 : 5 : 0%
< 0.05 : 56 : 0%
< 0.1 : 14 : 0%
< 0.5 : 3 : 0%
< 1 : 0 : 0%
< 5 : 0 : 0%
>=5 : 0 : 0%
max : 0.378034
min : -0.015358
avg : 0.000205

Warning Thresholds : Low High Backtrace
Select Task Duration

The length of time taken by each task run by select.
< 0.002 : 559 : 77% ######################################
< 0.005 : 3 : 0%
< 0.01 : 91 : 13% ######
< 0.02 : 5 : 1%
< 0.05 : 53 : 7% ###
< 0.1 : 12 : 2%
< 0.5 : 4 : 1%
< 1 : 0 : 0%
< 5 : 0 : 0%
>=5 : 0 : 0%
max : 0.377574
min : 0.000029
avg : 0.006108

Warning Thresholds : Low High Backtrace
Timer Task Duration

The length of time taken by each timer task.
< 0.002 : 621 :100% #################################################
< 0.005 : 1 : 0%
< 0.01 : 1 : 0%
< 0.02 : 0 : 0%
< 0.05 : 0 : 0%
< 0.1 : 0 : 0%
< 0.5 : 0 : 0%
< 1 : 0 : 0%
< 5 : 0 : 0%
>=5 : 0 : 0%
max : 0.006441
min : 0.000087
avg : 0.000267

Warning Thresholds : Low High Backtrace
Execute / Notification Task Duration

The length of time taken by each execute command or notification callback.
< 0.002 : 33 : 24% ###########
< 0.005 : 51 : 37% ##################
< 0.01 : 41 : 30% ##############
< 0.02 : 0 : 0%
< 0.05 : 0 : 0%
< 0.1 : 11 : 8% ###
< 0.5 : 2 : 1%
< 1 : 0 : 0%
< 5 : 0 : 0%
>=5 : 0 : 0%
max : 0.375190
min : 0.000159
avg : 0.011629

Warning Thresholds : Low High Backtrace
Scheduler Task Duration

The length of time taken by each scheduled task.
< 0.002 : 0 : 0%
< 0.005 : 0 : 0%
< 0.01 : 0 : 0%
< 0.02 : 0 : 0%
< 0.05 : 0 : 0%
< 0.1 : 0 : 0%
< 0.5 : 0 : 0%
< 1 : 0 : 0%
< 5 : 0 : 0%
>=5 : 0 : 0%
max : 0.000000
min : 0.000000
avg : 0.000000

Warning Thresholds : Low High Backtrace
Async HTTP Task Duration

The length of time taken by each asynchronous http callback function.
< 0.002 : 2 :100% ##################################################
< 0.005 : 0 : 0%
< 0.01 : 0 : 0%
< 0.02 : 0 : 0%
< 0.05 : 0 : 0%
< 0.1 : 0 : 0%
< 0.5 : 0 : 0%
< 1 : 0 : 0%
< 5 : 0 : 0%
>=5 : 0 : 0%
max : 0.000216
min : 0.000213
avg : 0.000215

Warning Thresholds : Low High Backtrace
Database Access

The time taken for information to be retrieved from the database.
< 0.002 : 126 : 80% ########################################
< 0.005 : 1 : 1%
< 0.01 : 1 : 1%
< 0.02 : 12 : 8% ###
< 0.05 : 13 : 8% ####
< 0.1 : 1 : 1%
< 0.5 : 3 : 2%
< 1 : 0 : 0%
< 5 : 0 : 0%
>=5 : 0 : 0%
max : 0.145074
min : 0.000509
avg : 0.007701

Warning Thresholds : Low High Backtrace
Web Page Build

The length of time taken to build each web page.
< 0.002 : 0 : 0%
< 0.005 : 0 : 0%
< 0.01 : 0 : 0%
< 0.02 : 0 : 0%
< 0.05 : 53 : 95% ###############################################
< 0.1 : 3 : 5% ##
< 0.5 : 0 : 0%
< 1 : 0 : 0%
< 5 : 0 : 0%
>=5 : 0 : 0%
max : 0.092613
min : 0.022042
avg : 0.029423

Warning Thresholds : Low High Backtrace
Process Template

The time to process each Template Toolkit template when building web pages.
< 0.002 : 2919 : 92% ##############################################
< 0.005 : 18 : 1%
< 0.01 : 57 : 2%
< 0.02 : 162 : 5% ##
< 0.05 : 11 : 0%
< 0.1 : 0 : 0%
< 0.5 : 0 : 0%
< 1 : 0 : 0%
< 5 : 0 : 0%
>=5 : 0 : 0%
max : 0.042810
min : 0.000067
avg : 0.001250

Warning Thresholds : Low High Backtrace
Timer Lateness

The time between when a timer task was scheduled and when it is run.
< 0.002 : 615 : 99% #################################################
< 0.005 : 2 : 0%
< 0.01 : 3 : 0%
< 0.02 : 1 : 0%
< 0.05 : 2 : 0%
< 0.1 : 0 : 0%
< 0.5 : 0 : 0%
< 1 : 0 : 0%
< 5 : 0 : 0%
>=5 : 0 : 0%
max : 0.035441
min : -0.264424
avg : -0.002759

Warning Thresholds : Low High Backtrace
IR Queue Length

The delay between an IR key press being received and being processed.
< 0.002 : 0 : 0%
< 0.005 : 0 : 0%
< 0.01 : 0 : 0%
< 0.02 : 0 : 0%
< 0.05 : 0 : 0%
< 0.1 : 0 : 0%
< 0.5 : 0 : 0%
< 1 : 0 : 0%
< 5 : 0 : 0%
>=5 : 0 : 0%
max : 0.000000
min : 0.000000
avg : 0.000000

To my eye, these all look okay?

Regards,
cliffo

Nonreality
2008-09-11, 02:14
I've had more drop offs with the new version for some reason. Never had them before but now I do. Not sure what they did with the new version but I had been using 7.1 in beta with no problems. Once it went off beta I started with drop outs. Went to 7.2 and was a little better but still they are there.

Phil Leigh
2008-09-11, 02:30
what av are you running?
server/network health looks ok from the results you posted

Phil Leigh
2008-09-11, 02:36
make sure you turn off any "advanced" features on the router. Also, as a test try setting the router into fixed 11b mode (not G) and see if the issue persists

cliffo
2008-09-13, 22:29
make sure you turn off any "advanced" features on the router. Also, as a test try setting the router into fixed 11b mode (not G) and see if the issue persists

Hi and thanks for the advice.

I tried all your suggestions but it still is dropping out. Running at 11b it did seem to not drop out as often but it was still a regular occurrence.

I am tempted to turn off the WPA security and see if that may be the problem though don't like the idea of leaving the network open.

Regards,
cliffo

cliffo
2008-09-14, 00:16
Just to provide an update, I performed a factory reset on the SB2 and since re-entering all the network info it seems to be running fine again.

I'll probably jinx myself here but so far its gone for 45 minutes without any issues.

Fingers crossed the problem has been solved.

Thanks for the suggestions people.
cliffo

cliffo
2008-10-28, 20:30
Well I've gone over a month wothout too many major issues.

I have just updated to the latest 7.2.1 Squeezecenter and am back to getting dropouts. I have pasted the log info below that appears each time it drops out and the SB2 stops playing.

Any ideas?
Regards,
cliffo

[08-10-29 14:26:00.8439] Slim::Player::Source::errorOpening (1756) Error: While opening current track, so mark it as already played!
[08-10-29 14:26:00.8443] Slim::Player::Source::errorOpening (1756) Backtrace:

frame 0: Slim::Utils::Log::logBacktrace (/<C:\Program Files\SqueezeCenter\server\squeezecenter.exe>Slim/Player/Source.pm line 1756)
frame 1: Slim::Player::Source::errorOpening (/<C:\Program Files\SqueezeCenter\server\squeezecenter.exe>Slim/Player/Squeezebox2.pm line 646)
frame 2: Slim::Player::Squeezebox2::failedDirectStream (/<C:\Program Files\SqueezeCenter\server\squeezecenter.exe>Slim/Networking/Slimproto.pm line 619)
frame 3: Slim::Networking::Slimproto::_disco_handler (/<C:\Program Files\SqueezeCenter\server\squeezecenter.exe>Slim/Networking/Slimproto.pm line 421)
frame 4: Slim::Networking::Slimproto::client_readable (/<C:\Program Files\SqueezeCenter\server\squeezecenter.exe>Slim/Networking/IO/Select.pm line 248)
frame 5: (eval) (/<C:\Program Files\SqueezeCenter\server\squeezecenter.exe>Slim/Networking/IO/Select.pm line 248)
frame 6: Slim::Networking::IO::Select::select (slimserver.pl line 531)
frame 7: main::idle (slimserver.pl line 45)
frame 8: PerlSvc::Startup (/<C:\Program Files\SqueezeCenter\server\squeezecenter.exe>PerlSvc.pm line 95)
frame 9: PerlSvc::_startup (slimserver.pl line 0)
frame 10: (eval) (slimserver.pl line 0)

bebop
2008-11-25, 07:07
Same problem here Cliffo, see my post :

http://forums.slimdevices.com/showthread.php?t=55448

I can also add that the failure happens with the Boom both on wired LAN and on WIFI

the log of the failure is similar :

[08-11-22 15:39:04.6454] Slim::Player::Source::errorOpening (1756) Error: While opening current track, so mark it as already played!
[08-11-22 15:39:04.6462] Slim::Player::Source::errorOpening (1756) Backtrace:

frame 0: Slim::Utils::Log::logBacktrace (/usr/share/perl5/Slim/Player/Source.pm line 1756)
frame 1: Slim::Player::Source::errorOpening (/usr/share/perl5/Slim/Player/Squeezebox2.pm line 646)
frame 2: Slim::Player::Squeezebox2::failedDirectStream (/usr/share/perl5/Slim/Networking/Slimproto.pm line 619)
frame 3: Slim::Networking::Slimproto::_disco_handler (/usr/share/perl5/Slim/Networking/Slimproto.pm line 421)
frame 4: Slim::Networking::Slimproto::client_readable (/usr/share/perl5/Slim/Networking/IO/Select.pm line 248)
frame 5: (eval) (/usr/share/perl5/Slim/Networking/IO/Select.pm line 248)
frame 6: Slim::Networking::IO::Select::select (/usr/sbin/squeezecenter-server line 536)
frame 7: main::idle (/usr/sbin/squeezecenter-server line 481)
frame 8: main::main (/usr/sbin/squeezecenter-server line 1048)

As mentioned in my post, it is trange that Softsqueeze on my Laptop connected exactly as the Boom, plays the same music just fine.

Aux Memes
2008-12-07, 08:23
Is there an answer to this problem anyone?

[08-12-07 15:29:56.6775] Slim::Player::Source::errorOpening (1756) Error: While opening current track, so mark it as already played!
[08-12-07 15:29:56.6779] Slim::Player::Source::errorOpening (1756) Backtrace:

frame 0: Slim::Utils::Log::logBacktrace (/<G:\SQUEEZ~1\server\SQUEEZ~1.EXE>Slim/Player/Source.pm line 1756)
frame 1: Slim::Player::Source::errorOpening (/<G:\SQUEEZ~1\server\SQUEEZ~1.EXE>Slim/Player/Squeezebox2.pm line 646)
frame 2: Slim::Player::Squeezebox2::failedDirectStream (/<G:\SQUEEZ~1\server\SQUEEZ~1.EXE>Slim/Networking/Slimproto.pm line 619)
frame 3: Slim::Networking::Slimproto::_disco_handler (/<G:\SQUEEZ~1\server\SQUEEZ~1.EXE>Slim/Networking/Slimproto.pm line 421)
frame 4: Slim::Networking::Slimproto::client_readable (/<G:\SQUEEZ~1\server\SQUEEZ~1.EXE>Slim/Networking/IO/Select.pm line 248)
frame 5: (eval) (/<G:\SQUEEZ~1\server\SQUEEZ~1.EXE>Slim/Networking/IO/Select.pm line 248)
frame 6: Slim::Networking::IO::Select::select (slimserver.pl line 531)
frame 7: main::idle (slimserver.pl line 481)
frame 8: main::main (slimserver.pl line 90)
frame 9: PerlSvc::Interactive (/<G:\SQUEEZ~1\server\SQUEEZ~1.EXE>PerlSvc.pm line 99)
frame 10: PerlSvc::_interactive (slimserver.pl line 0)
frame 11: (eval) (slimserver.pl line 0)