PDA

View Full Version : Squeezebox with Onkyo TX-SR605 optical cable delay?



cvanfo
2008-09-08, 17:01
Hello. I've got an Onkyo TX-SR605 that I'm having an issue with and I'm hoping someone here with a similar unit can help me out. I've got a squeezebox connected to the CD input with an optical cable. Everytime I turn on the squeezebox and reciever it starts out dolby digital stereo. Great, grand, fantastic! However, when the squeezebox actually starts playing music the receiver changes it to PCM stereo. This is all well and good except that whenever it does this about two seconds of the first song are silent. It drives me insane everytime it happens! It works just fine when connected with RCA cables, but I prefer the sound of the optical cable. I've tried assigning the listening mode presets to last used, but everytime I turn both units off it reverts back to the original settings. Anyway, is this normal with all units or is there something else I can try. Any help would be appreciated. Thanks in advance.

iPhone
2008-09-08, 18:30
Hello. I've got an Onkyo TX-SR605 that I'm having an issue with and I'm hoping someone here with a similar unit can help me out. I've got a squeezebox connected to the CD input with an optical cable. Everytime I turn on the squeezebox and reciever it starts out dolby digital stereo. Great, grand, fantastic! However, when the squeezebox actually starts playing music the receiver changes it to PCM stereo. This is all well and good except that whenever it does this about two seconds of the first song are silent. It drives me insane everytime it happens! It works just fine when connected with RCA cables, but I prefer the sound of the optical cable. I've tried assigning the listening mode presets to last used, but everytime I turn both units off it reverts back to the original settings. Anyway, is this normal with all units or is there something else I can try. Any help would be appreciated. Thanks in advance.

First question: What Squeezebox are we talking about (give us the model)? It is most likely because Linear PCM is the actual format of the output of the Squeezebox. Are you using any source or timing setting in the Onkyo? This sounds like a sync or clock issue. Using the RCAs has nothing to do with this as this issue is on the digital side before the DAC which is why the analog sounds fine.

matthijskoopmans
2008-09-08, 23:39
I use an SR-805 and have the same issue. It has nothing to do with Optical or the Squeezebox. The Onkyo circuits are a bit slow when switching when using digital signals. Don't get me wrong: they are absolutely great amps, but this is their one flaw.

Since you are on a 605, I would suggest using RCA. I find the Burr-Brown nicer, warmer output compared to the Wolfsen in the Onkyo 605.. but that is your choice.

Cheers

Matt

Skunk
2008-09-09, 07:29
From the owners manual p85 (available at Onkyo's site):

Digital Input Signal Formats
The digital input signal formats are available only for the input sources that you have assigned a digital input jack; otherwise you will see “Analog” indicated on the screen (see page 50).

Normally, the AV receiver/AV amplifier detects the signal format automatically. However, if you experience either of the following issues when playing PCM or DTS material, you can manually set the signal format to PCM or DTS:
• If the beginnings of tracks from a PCM source are cut
off, try setting the format to PCM.
• If noise is produced when fast forwarding or reversing
a DTS CD, try setting the format to DTS.

1 Press and hold the AV receiver/AV amplifier’s
[DIGITAL INPUT] button for about 3
seconds.
2 While “Auto” is displayed (about 3 seconds),
press the [DIGITAL INPUT] button
again to select: PCM, DTS, or Auto.
DTS or PCM: The DTS or PCM indicator,
depending on which format you have set, flashes,
and only signals in that format are output. Digital
signals in other formats are ignored.
Auto (default): The format is detected automatically.
If no digital input signal is present, the corresponding
analog input is used instead.

Merlin
2008-09-09, 11:49
Not too sure if this will work as I dont use this setting and dont use digital out, but in the Squeezecentre settings:

Player>Audio> there is a option called 'audio startup time' maybe you can alter that so that the music isnt streamed for a couple of seconds, to give your amp time to switch over.