PDA

View Full Version : SqueezeCenter 7.2: (Disc x) apear after album name



vrelits
2008-08-31, 06:59
After installing 7.2 and scanning new music, the new albums gets attached "(Disc x)" after the album title even if there is only ONE disc. E.g. Phil Collins - Hits (Disk 1)
(using Danish language option)
Is this something new in 7.2? I really want to get rid of it, but cannot find any option or anything to turn if off. I checked the tags and it's not in the tags.
I can see an use for this for multidisc collections, but today I usually enter that in the tags, Disc 1, 2 and so on.
Anybody else noticing this?

StuartC
2008-08-31, 07:04
Also, in multi-disc sets it doesn't combine them even if that setting is on.

sebp
2008-08-31, 10:05
After installing 7.2 and scanning new music, the new albums gets attached "(Disc x)" after the album title even if there is only ONE disc. E.g. Phil Collins - Hits (Disk 1)
(using Danish language option)
Is this something new in 7.2? I really want to get rid of it, but cannot find any option or anything to turn if off. I checked the tags and it's not in the tags.
I can see an use for this for multidisc collections, but today I usually enter that in the tags, Disc 1, 2 and so on.
Anybody else noticing this?
Not here.
I'd make sure there is no disc number tag embedded in the files, which could lead SC to think this is a multidisc album.


Also, in multi-disc sets it doesn't combine them even if that setting is on.
Can't see this here either.
Check that the album title tags are exactly the same for all the files of the multidisc set : they should not embed the "(Disc #)" string.

tamanaco
2008-09-03, 07:48
Not here.
I'd make sure there is no disc number tag embedded in the files, which could lead SC to think this is a multidisc album.

Is there a way of "not" displaying the (Disk x of x) at the end of the Albums via the Web UI without having to remove the disknumber tag from the files? Did I miss this option in the settings? I have many multi-disk albums and I store them in separated folder appending - CDx at the end of the Album name as it makes easier/faster for me to navigate folders and find a specific CD or track. I don't care for many of the so called "Bonus" CDs or for some specific CDs that make up some full albums. To convert a subset of my Main FLAC library for use in my MP3 Player I use dBpowerAmp batch converter. Having the ability to only select a specific CD get the tracks I want without having to navigate a single Album folder with 50+ tracks is very convenient. So, a typical multi-disk album (folder) looks like this.

Artist Name
-->Album Name - CD1
-->Album Name - CD2
-->Album Name - CD3

Having the Web UI and SB3 display the name as Album Name - CD1 (Disk 1 of 2) is a bit redundant and a waste of SB3 display space based on my setup. Btw, I use Trackstat and the option I selected in the Settings->Interface->Title Format reads:
TRACKNUM. TITLE (TRACKSTATRATINGDYNAMIC)

Suggestions?

vrelits
2008-09-15, 03:02
I've found out that the problem came from dbPowerAmp which put "1" in the disc tag even though the GUI said "1/1".
I corrected the disc tags to be "1/1", rescanned, and the (Disc x) after album name is now gone.
So it seems it only appends (Disc x) if disc tag is "1", "2" and so on.
Funny enough it doesn't display anything for "1/2", "2/2" and so on, as you would escpect. Maybe this is due to the
fact that in these cases I have my albums names as <album name>, Disc x.

tamanaco
2008-10-14, 13:00
I just added 2 new CDs today and now I get (Disc 1) appended to the end of Album Name of these single CD albums. Is there no way to repress this tag from showing up? As I mentioned before, Disc is not part of my Title Format. Something isn't Kosher here. When I look at the DISC tag of these new CDs it shows 1/1, but only these two new CDs are displaying this behavior. All my other single CD albums are not displaying the (Disc 1) at the end of the Album Name and their DISC tags show 1/1. I had given up on repressing the (Disc x of x) on my multiple CD albums, but I don't want see it displayed in my single CD albums. I used dBpowerAMP to rip "all" the CDs. Why are only these two new additions are displaying this behavior? Any suggestions.

iPhone
2008-10-14, 13:07
I just added 2 new CDs today and now I get (Disc 1) appended to the end of Album Name of these single CD albums. Is there no way to repress this tag from showing up? As I mentioned before, Disc is not part of my Title Format. Something isn't Kosher here. When I look at the DISC tag of these new CDs it shows 1/1, but only these two new CDs are displaying this behavior. All my other single CD albums are not displaying the (Disc 1) at the end of the Album Name and their DISC tags show 1/1. I had given up on repressing the (Disc x of x) on my multiple CD albums, but I don't want see it displayed in my single CD albums. I used dBpowerAMP to rip "all" the CDs. Why are only these two new additions are displaying this behavior? Any suggestions.

I went into dBpowerAmp and turned off the Tag for "Disc Number". Go into option and uncheck the box for tagging files with a Disc Number. I don't need it anyway as I even rip multi-disc sets as one album. And who really needs or doesn't know that a single disc CD is one disc?

I corrected all my already ripped CDs with MP3TAG or dBpowerAmp depending where they were stored.

tamanaco
2008-10-14, 13:30
I went into dBpowerAmp and turned off the Tag for "Disc Number". Go into option and uncheck the box for tagging files with a Disc Number. I don't need it anyway as I even rip multi-disc sets as one album. And who really needs or doesn't know that a single disc CD is one disc?

I corrected all my already ripped CDs with MP3TAG or dBpowerAmp depending where they were stored.

iPhone, thanks for your response, but I don't really want to remove any tags from my Music Library. I use my FLAC Library and several MP3 subsets transcoded from this main FLAC library in more than one place, in more than one device and using other streaming programs. I'd like to be consistent with my tags. Is too much work to change them everywhere. All I want is to suppress the (Disc 1) and (Disc x of x). Shouldn't the Title Format option take care of this?

androidtopp
2008-10-14, 13:31
Agreed - I had the same issue as iPhone, just had to adjust my dBPowerAmp settings. Now if I could only get it to not fill in the "year..."