PDA

View Full Version : SC7.2 has trouble here



sg2
2008-08-31, 01:51
Hello,

I have been reading other people's posts about SC7.2 "not always starting for them". I have experienced troubles myself that I thought were similar, and subsequently posted a question to the tech support, which I recap below :

Question Reference #080830-002064
=================================
I have been using 7.0.1 since it was out, with a "normal" Duet experience.

I updated to 7.2 a couple days ago. Since then, my Duet would find SC and
play local music, but anything related to Internet (Extras/news feeds, web
radios etc.) would fail. Also, the bottom of the web page showing SC was
carrying an error message related to DNS.

I have been hunting for a potential cause for this. I have suspected that
Logitech has modified the startup sequence for SC when run as a service
(which is my case).

Just to check, I went to XP admin tools, stopped the SC service and
restarted it, and everything worked again.

Cold rebooted the machine, again everything outside of my local music was
not available. Stop/start SC service, and works again.

This is 100% reproducible here.

So I suspect that whatever modification was made to the startup sequence of
SC when run as a service, has SC start too early, and in my case before the
routing/firewall service (Kerio Winroute) which also runs on this machine
(which is the internet gateway for my home LAN). Stop/start SC service cures
the problem.
=================================


Since I posted that, I had two occurrences where SC7.2 had been stop/started thus was working fine, but the Controller lost the ability to reach anything beyond local files again. Again, stop/start SC service would restore normal operation.

Now this morning I had something entirely different. I was standing in front of the computer while it was booting, and before I would log in, I got an error popup telling me that SC had crashed : http://s.guillard.free.fr/sc7.2crash/p1.JPG

I logged in and got the regular "app has crashed, send report" popup : http://s.guillard.free.fr/sc7.2crash/p2.JPG

I clicked on "get tech info" which told me that the crashdump files were sitting in a temp folder : http://s.guillard.free.fr/sc7.2crash/p3.JPG

I grabbed those files so that maybe someone at Logitech can look into them (being an operating system component developer myself, I would definately love to get a crashdump :)), those files can be retrieved here : http://s.guillard.free.fr/sc7.2crash/SC7.2-crashdump.zip

Regards,
--
Stéphane

PS : a word on my SC setup :

- I run SC on an XP SP3 computer that is also the family gateway to the internet : it has two LAN boards, one to the ADSL modem and one to the family LAN

- the router / firewall app is Kerio Winroute in its uptodate version

- the DUET recevier is connected directly to the LAN (Ethernet)

- the DUET controller is talking to the SC computer through a point to point ad hoc wireless connection with the receiver (something always very difficult to restore after a power down or an update by the way, it takes at least 5 factory reset trials to have everything back in place, looking like a DHCP issue where the controller might try to grab an IP before the receiver is able to pass through)

- when I was running 7.0.1 I had no such issues as the ones above

sg2
2008-09-02, 13:49
Up...

Regards,
--
Stéphane