PDA

View Full Version : SqueezeCenter a bit knackered after upgrade to 7.2



Brian Ritchie
2008-08-29, 13:56
I've just upgraded from the official 7.1 release to the official 7.2, running under Windows XP. And it's all gone frightfully wrong.

The installation did go a bit weird at first: it ground my PC to a complete standstill where it wouldn't respond to mouse clicks or the keyboard; but after a bit all seemed to go OK, and SC seemed to start up OK afterward. But then...

In the web interface (default), none of the subsection links I tried works - Firefox (3.0.1) goes into a loading loop for a while, then stops.

When I saw that, I did a full rescan, which took ages, but made no difference. Then I tried the other interfaces...

Using the IR remote on my SB3, Artists just goes to Artists. If I do this N times, I have to go back N times to get to Music Library. (Well, where N=2 or 3, I'm not that patient.)

The Controller, however, works! I can browse away quite happily. But when I used it to send a playlist to the SB3, it seemed to get stuck in a strange "intro" mode, where it would play 2 seconds of a track, then skip to the next. (Even the artwork display on the controller kept up, it was almost hypnotic to watch.) I couldn't pause it, I couldn't turn it off (with either remote), it would just unpause or turn on again a couple of seconds later, and keep going. I thought I was in a Steven King novel :-) Fortunately, turning the power off at the socket worked.

The X albums by Y artists with Z songs figures look perfectly reasonable, so the music's in there... somewhere...

Of course, this *is* Windows, and I haven't tried rebooting. If that doesn't work, I'll revert to 7.1 and hope that that still works. (Update: reboot's made no difference. I have another theory, but it will take time to test...)

I've not seen any other reports of problems like this. Why's it picking on me?

-- Brian

Brian Ritchie
2008-08-29, 16:54
My theory was that it could be because I was using MusicIP but in a slightly odd way, in that I also had a Music Folder specified. (I did this because early on I found that just using MIP caused all the artwork to disappear.) Though this seemed to work OK in 7.1, perhaps 7.2 was less forgiving?

So I emptied the Music Folder string in the settings. Immediately, SC started a full scan. I watched some telly. When I came back (and it had finished), things seemed no better: clicking Artists on the webiface just hung.

So I stopped SC, wiped the cache completely, and restarted. Another scan; this took about 45 minutes. Webiface still hangs. Damn!

At this point, I had another go with the remotes (I didn't think to try between these two steps, unfortunately). As before, the IR suffers a similar problem: Artists recurses without getting anywhere. The controller works OK. Now, my test playlist actually seemed to play OK on both players; but I can only select music using the controller, not the IR remote nor the webiface. Indeed, the webiface doesn't even get as far as showing the current playlist (it just shows "Loading..." beyond my patience boundary, though admittedly that's getting rather short!)

(On the controller, and on the currently-playing item on the webiface, the artwork looks fine. So I guess it's OK to leave the Music Folder blank when using MusicIP now.)

I will go back to 7.1. If it still doesn't work, I will wipe the cache and do yet another scan. That better work!

(Update: just going back to 7.1 worked. It seemed to take a few hours before the Controller decided to update (downdate?) itself, but it worked fine either side.)

-- Brian