PDA

View Full Version : Re: fun with transcoding



Greg Hamilton
2004-03-30, 11:12
Question?

Does the down sampling work for streaming players?
I've tried streaming with winamp using both the url format and
by changing bitrate in the player settings. Neither provided a
down sampled stream.





---- On Mon, 29 Mar 2004, kdf (slim-mail (AT) deane-freeman (DOT) com)
wrote:

> Quoting John Gorst <john_gorst (AT) hotmail (DOT) com>:
>
> > kdf wrote:
> >
> > > You can do what you want by using a line in
convert.conf:
> > > mp3 mp3 http SetTopIP
> > > [lame] --resample 44100 --silent -b 320 $FILE$ -
> > >
> > > The SetTopIP will identify your settop box to the server,
and removing
> > $BITRATE$
> > > in favour of a hardcoded rate ensures that conversions for
that player are
> > set
> > > at 320.
> >
> > Thanks for that, works a treat.
> >
> > In case anyone is new to this (as I am) replace [lame] with
$lame$, make
> > sure that you have lame(search for a download site on
google, you cant
> > download it from lames homepage for legal reasons) installed
on your
> > system (in c:\windows\ for windows users).
> >
>
> To clarify, [lame] is the new format of the convert.conf for
nightly builds
> within the last week or so. $lame$ should still be
compatible. The differnce
> is that [lame] lets the server check for the binary and ignore
the line if lame
> is not found. This way, the wong will still play at its
native bandwidth if
> lame isn't found, instead of skipping to the next song.
>
> -kdf
>

kdf
2004-03-30, 11:27
Quoting Greg Hamilton <gregoryhamilton (AT) ureach (DOT) com>:

> Question?
>
> Does the down sampling work for streaming players?
> I've tried streaming with winamp using both the url format and
> by changing bitrate in the player settings. Neither provided a
> down sampled stream.

if you have a build more recent than March 27, then it should. This is not a
feature that is available in the current 5.1.1 official release. If it snot
working with the recent build, then something has been broken.
-kdf

>
> ---- On Mon, 29 Mar 2004, kdf (slim-mail (AT) deane-freeman (DOT) com)
> wrote:
>
> > Quoting John Gorst <john_gorst (AT) hotmail (DOT) com>:
> >
> > > kdf wrote:
> > >
> > > > You can do what you want by using a line in
> convert.conf:
> > > > mp3 mp3 http SetTopIP
> > > > [lame] --resample 44100 --silent -b 320 $FILE$ -
> > > >
> > > > The SetTopIP will identify your settop box to the server,
> and removing
> > > $BITRATE$
> > > > in favour of a hardcoded rate ensures that conversions for
> that player are
> > > set
> > > > at 320.
> > >
> > > Thanks for that, works a treat.
> > >
> > > In case anyone is new to this (as I am) replace [lame] with
> $lame$, make
> > > sure that you have lame(search for a download site on
> google, you cant
> > > download it from lames homepage for legal reasons) installed
> on your
> > > system (in c:\windows\ for windows users).
> > >
> >
> > To clarify, [lame] is the new format of the convert.conf for
> nightly builds
> > within the last week or so. $lame$ should still be
> compatible. The differnce
> > is that [lame] lets the server check for the binary and ignore
> the line if lame
> > is not found. This way, the wong will still play at its
> native bandwidth if
> > lame isn't found, instead of skipping to the next song.
> >
> > -kdf
> >

kdf
2004-03-30, 11:40
Quoting Greg Hamilton <gregoryhamilton (AT) ureach (DOT) com>:

> Question?
>
> Does the down sampling work for streaming players?
> I've tried streaming with winamp using both the url format and
> by changing bitrate in the player settings. Neither provided a
> down sampled stream.

Are you using Moodlogic, by any chance? It seems when that's turned on, files
come up as 0 for bitrate. This pretty much kills any chance for the bitrate
limit to trigger.

-kdf