PDA

View Full Version : plugins not plugging



Paul Phillips
2004-03-28, 19:38
Hi -- I sense I am missing something obvious but it has eluded me thus
far so I seek assistance.

Modules I add to the server are not appearing anywhere in the web
interface. The module(s) are clearly being loaded successfully by the
server, but there are no new options anywhere that I can find. The
server is v5.1.1 on debian linux, streaming to an old school slimp3 from
the days before built-in wireless.

slimp3@spoon:~$ ./slimserver.pl --d_plugins
[cutting the built-in plugins]
2004-03-28 18:25:33.6328 Requiring Plugins::Information plugin.
2004-03-28 18:25:33.6540 Requiring Plugins::ShoutcastBrowser plugin.
2004-03-28 18:25:33.7134 Requiring Plugins::Television plugin.

The server also lists them in the plugins section via the web interface,
they're checked as enabled, etc. I'm stumped. Any tips appreciated. I
can't even tell for sure where the new options are supposed to be. My
only guess is that my perl is too old (it's v5.6.1) but the installation
docs say "perl 5.6 or greater" and upgrading perl on this particular
machine is not appealing to do on a wild guess basis.

Incidentally, when I upgraded the server I could no longer add more than
one song to the playlist. I found out by searching the archives that
changing the skin would fix it!? Sure enough. And the standard skin works
again once I changed back. Now that would have been easy to find...

--
Paul Phillips | Think globally, act conveniently.
Stickler |
Empiricist |
pp: i haul pills |----------* http://www.improving.org/paulp/ *----------

kdf
2004-03-28, 23:29
Not all plugins have options available to the web interface. The plugins are
designed for the player interface. In the main menu list, there is the plugins
menu. If you don't have this, then you can add it from the server settings.
You will see a list of menu items, with arrows and an x. Below this are a list
of menu items that you can add, but are not included by default. Plugins is one
of them.

After this, you should see this menu item on your player, and be able to use the
plugins.

-kdf

Quoting Paul Phillips <paulp (AT) improving (DOT) org>:

> Hi -- I sense I am missing something obvious but it has eluded me thus
> far so I seek assistance.
>
> Modules I add to the server are not appearing anywhere in the web
> interface. The module(s) are clearly being loaded successfully by the
> server, but there are no new options anywhere that I can find. The
> server is v5.1.1 on debian linux, streaming to an old school slimp3 from
> the days before built-in wireless.
>
> slimp3@spoon:~$ ./slimserver.pl --d_plugins
> [cutting the built-in plugins]
> 2004-03-28 18:25:33.6328 Requiring Plugins::Information plugin.
> 2004-03-28 18:25:33.6540 Requiring Plugins::ShoutcastBrowser plugin.
> 2004-03-28 18:25:33.7134 Requiring Plugins::Television plugin.
>
> The server also lists them in the plugins section via the web interface,
> they're checked as enabled, etc. I'm stumped. Any tips appreciated. I
> can't even tell for sure where the new options are supposed to be. My
> only guess is that my perl is too old (it's v5.6.1) but the installation
> docs say "perl 5.6 or greater" and upgrading perl on this particular
> machine is not appealing to do on a wild guess basis.
>
> Incidentally, when I upgraded the server I could no longer add more than
> one song to the playlist. I found out by searching the archives that
> changing the skin would fix it!? Sure enough. And the standard skin works
> again once I changed back. Now that would have been easy to find...
>
> --
> Paul Phillips | Think globally, act conveniently.
> Stickler |
> Empiricist |
> pp: i haul pills |----------* http://www.improving.org/paulp/ *----------
>