PDA

View Full Version : Duet browsing SLOW.



EvilNat
2008-08-07, 12:09
So I have both an older SB3 and a New Duet in my house. The SB3 is connected via wireless and the Duet is hard-wired.

The problem is that the Duet controller is super slow when browsing my music library when connected to either SB3 or Duet base-station. Browsing the artists or albums list is fairly responsive, but when I click on one of the albums to actually see the individual songs, the controller slows almost to a halt. Sometimes it takes up to a minute to access the individual music files. Sometimes it times out entirely and either bumps me back to the previous screen or out to the home screen.

I am pretty sure that both my wireless network and squeeze center are working fine as my SB3 can browse lightning-quick through my library.

My configuration is as follows:

all .flac files hosted on a NAS device. squeezecenter accesses these files via a mounted network drive letter (Z:) on the host computer.


Any ideas?

Siduhe
2008-08-07, 13:03
Couple of thoughts - have you updated the firmware on the Controller? It should prompt you to do that automatically, but if you are on an early version of the firmware, it may not do this. Try Settings/Advanced/Software Update and see if it will let you update.

The fact your files are on an NAS can slow down Squeezecenter's responsiveness, but shouldn't affect the Controller, by which I mean that the Controller shouldn't be significantly more slow than the SB3. One possibility could be your antivirus or firewall - if you disable this (assuming you have some installed) does performance improve?

One other thing to check, what are your Power Management settings on the Duet? Settings/Advanced/Factory Test/Power Management.

EvilNat
2008-08-07, 15:39
I am running the latest sqeezecenter 7.1. Latest firmware 7.1r2722

I just ran a network test and 5000kb was all green 100%

Power settings are:
sleep timeout 60
suspend timeout 3600
suspend enabled checked
suspend wake unchecked
wireless power save unchecked


This problem has been with the unit through a couple sofware/firmware updates.

simbo
2008-08-08, 00:11
It's something do to with the way album art is obtained, and the hit this has when your music's on a NAS.

EliteAV discovered a workaround and posted here (last post on page) (http://forums.slimdevices.com/showthread.php?t=45121&highlight=controller+albums&page=3)

Running his UPDATE query against the DB will considerably speed up the performance when you click on an album.